Автор Тема: Проблема с запуском Steam (часть 2) [решено]  (Прочитано 4998 раз)

Оффлайн guzanovmax

  • Давно тут
  • **
  • Сообщений: 153
    • Email
Здравствуйте. Нужна помощь:
Дистрибутив Кентавр 7.0.1 64bit. Установил steam из p7 (пакет i586-steam.32bit + зависимости).
При запуске выдает:
Спойлер
OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457.
Драйвера ставил из статьи http://www.altlinux.org/%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%BF%D1%80%D0%BE%D0%BF%D1%80%D0%B8%D0%B5%D1%82%D0%B0%D1%80%D0%BD%D1%8B%D1%85_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%BE%D0%B2_NVIDIA_%D0%B8_ATI
Выхлоп команды $ glxinfo | grep render:
Спойлер
direct rendering: Yes
OpenGL renderer string: AMD Radeon HD 7700 Series 
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,

« Последнее редактирование: 23.07.2014 16:10:51 от guzanovmax »

Оффлайн faithman

  • Завсегдатай
  • *
  • Сообщений: 52
    • Email
Re: Проблема с запуском Steam (часть 2)
« Ответ #1 : 06.07.2014 12:16:31 »
ALTLinux 7.0.4 KDesktop x86_64
Core i3-3220T (HD Graphics 2500)

Поставлен steam, но при запуске клиента получаю сообщения такого рода:
OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457.

Установил XCOM Enemy Unknow. Поставил настройки графики поминимуму для моей системы, но картинка без текстур, дождя и вовсе нет. Проверил на злощастной бубунте, на мой системе графика нормальная, текстуры есть, только анимация по скорости хромает, но это нормально для такой карты.
Работаю на открытых драйверах. Пробывал ядра 3.10, 3.12
Есть предложения?
Спойлер
glxinfo |grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Desktop
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
« Последнее редактирование: 06.07.2014 12:21:56 от faithman »

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 900
    • Email
Re: Проблема с запуском Steam (часть 2)
« Ответ #2 : 06.07.2014 12:20:43 »
Сверяйте версии драйверов и ядра в бунте и альте, скорее всего проблема в этом.

Оффлайн faithman

  • Завсегдатай
  • *
  • Сообщений: 52
    • Email
Re: Проблема с запуском Steam (часть 2)
« Ответ #3 : 06.07.2014 12:35:49 »
Сверяйте версии драйверов и ядра в бунте и альте, скорее всего проблема в этом.
Проверять не стал, но поставил HL1 через Steam, там с графикой всё нормально. Может требования к драйверам повысились у клиента. Спасибо за подсказку.

Оффлайн ps1h

  • Завсегдатай
  • *
  • Сообщений: 418
    • Нихрена не работает!
Здравствуйте. Нужна помощь:
Дистрибутив Кентавр 7.0.1 64bit. Установи л steam из p7 (пакет i586-steam.32bit + зависимости).
При запуске выдает:
Спойлер
OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457.
Драйвера ставил из статьи http://www.altlinux.org/%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%BF%D1%80%D0%BE%D0%BF%D1%80%D0%B8%D0%B5%D1%82%D0%B0%D1%80%D0%BD%D1%8B%D1%85_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80%D0%BE%D0%B2_NVIDIA_%D0%B8_ATI
Выхлоп команды $ glxinfo | grep render:
Спойлер
direct rendering: Yes
OpenGL renderer string: AMD Radeon HD 7700 Series 
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,


Такая же ошибка вылазила, только у меня карта Nvidia, решил проблему так: 
Запускаю стим через primusrun и всё работает нормально без ошибок.

Оффлайн ps1h

  • Завсегдатай
  • *
  • Сообщений: 418
    • Нихрена не работает!
Ещё раз словил такой баг на свежеустановленном 64битном альте. Сейчас пришлось ещё добавить пользователя в группу video.

On some systems your user must be part of the 'video' group.  If there is a video group and you are not a member try joining the group, logging out and logging back in and see if that helps.

В прошлый раз не помню делал это или нет...
А так же установить:
apt-get install i586-primus.32bit