Автор Тема: Проблема с видеокартой ATI.  (Прочитано 11067 раз)

Оффлайн kibanovalexandr

  • Завсегдатай
  • *
  • Сообщений: 16
    • Email
Купил пару месяцев назад новую видеокарту AGP  1024 mb Power Color ATI  AG4670 1GBK3-P  AX4670 DDR3 DVI/TVORTL  до этого стояло  интегрированное  видео и начались  проблемы. Раньше не было  проблем с установкой любых дистрибутивов  Линукса  : Мандривы,  Убунты ,  АлтЛинукса  сейчас же ни могу ни один нормально установить  в каждом диструбутиве какие то  да проблемы с отображением видео . В АлтЛинуксе 4 видео отображалось в фиолеово - коричневом  цвете. Только в Альт  Линуксе  5 beta Ковчег  более менее показывает. Хотя цвет правильно отображает чувствуется  вроде бы  есть проблема  с кодеками,  изображение с квадратами , не  такое четкое как в винде.  Тем более нет  и речи работы с 3D рабочим столом и  разными  спецэффектами . Ну не  хочет и все. Хотя  видеокарта  современная  и должна  была справиться , но все упиратся  в  драйвера.  Если уж с фильмами  есть проблемы  с отображение то уж о  3D  рабочем  столе  и нечего  говорить. Намучался с установкой разных  диструбутивов  и версий   Линукса. Не знаю  то ли нет драйвера поддерживающего мою видеокарту (новая) открытого драйвера то ли еще  что. Думаю один  временный  выход  придется  убирать видеокарту и на  встроенной работать. Пока  не решится проблема  с драйверами для линукса. Хочется опробовать новые версии , но все  упирается  в новую видеокарту. Хотелось  бы что бы нужные драйвера  присутствовали сразу на диске  и устанавливались  автоматом  без проблем и не  мучаться с  установкой , не ползать в дебрях,  как  и  что  и куда  установить. Большая  просьба специалистам обратите внимание проблеме с  драйверами для  видео карты AGP  1024 mb Power Color ATI  AG4670 1GBK3-P  AX4670 DDR3 DVI/TVORTL .  Хочу опробовать финальную  версию Ковчега надеюсь  в нем не  будет проблем.


Еще один интерестный  факт хочу добавить. Не могу установить Ubuntu 9.10 , что с Live CD , что при установке на жесткий  диск  на начальном  этапе установки и загрузки черный экран  и белая  стрелочка и все , на  этом процесс весь  заканчивается.  А в виртуальной машине Sun VM  устанавливается ОС так же можно работать в Live CD .  Видимо в виртуальной машине Sun VM  есть все необходимые  драйвера.  Но работать  в виртуальной  машине  не удобно . Медленно.
« Последнее редактирование: 01.11.2009 10:14:03 от kibanovalexandr »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Проблема с видеокартой.
« Ответ #1 : 01.11.2009 11:12:49 »
Проблема с видеокартами ATI уже не один год существует .
Трудно сказать когда  появятся нормальные драйвера, но скорей всего  не в этом году, а может и не в следующем.

PS А на виртуальной машине стоят драйвера для карты, которую эмулирует виртуальная машина.

Drool

  • Гость
Re: Проблема с видеокартой.
« Ответ #2 : 01.11.2009 12:34:04 »
При использовании GNU/Linux в сторону ATi лучше вообще не смотреть. Никогда.

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 371
ALTLinux 5.0 и ATI Radeon X1600
« Ответ #3 : 01.11.2009 17:21:51 »
Скачал с офсайта дрова под линукс для своей видюхи но при установке выдаёт ощыпку:

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.29-std-def-alt3; make sure that the version is being
correctly set by --iscurrentdistro

Есть какие нибудь идеи??

Drool

  • Гость
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #4 : 01.11.2009 17:24:26 »
Есть какие нибудь идеи??

Есть. Продолжать ставить дрова с оффсайта, если есть желание разнести графическую систему в дребезги.

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 371
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #5 : 01.11.2009 17:35:19 »
А что посоветуйте?

Drool

  • Гость
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #6 : 01.11.2009 17:37:20 »
А что посоветуйте?

1. Использовать те дрова, которые идут в дистрибутиве.
2. Обновить ядро вместе с ядерными модулями из более нового/свежего репозитория (искать по слову update-kernel)
3. Выбросить ATi нафиг, если хотите пользоваться линуксом.

Mario_z

  • Гость
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #7 : 01.11.2009 17:54:01 »
Как уже попробовавший и не единожды разнесший ОС, по этой и не только по этой причние, полностью подтверждаю слова старшего товарища по форуму.  :D
Предлагаю почитать мой опус Обновление системы. Подробное описание для новичков! для ускорения процесса обучения правильному обновлению ALT.

Оффлайн kibanovalexandr

  • Завсегдатай
  • *
  • Сообщений: 16
    • Email
Re: Проблема с видеокартой.
« Ответ #8 : 01.11.2009 18:17:42 »
Дааа.. Такого мало можно  было  ожидать , что  для  целого семейства  видеокарт нет драйверов в Линуксе. Знать бы все  это в начале, можно  было бы  правильно подобрать  видеокарту. Не ATI , а NVDIA. С NVDIA в большинстве случаев нет  таких проблем как с  ATi ?

Оффлайн dk

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
Re: Проблема с видеокартой.
« Ответ #9 : 01.11.2009 18:23:25 »
Дааа.. Такого мало можно  было  ожидать , что  для  целого семейства  видеокарт нет драйверов в Линуксе. Знать бы все  это в начале, можно  было бы  правильно подобрать  видеокарту. Не ATI , а NVDIA. С NVDIA в большинстве случаев нет  таких проблем как с  ATi ?

Вообще-то, такое плачевное положение дел с ATI известно всем более-менее опытным пользователям Linux. Да и вам перед приобретением оборудования следовало бы поинтересоваться, насколько оно хорошо поддерживается в Linux.

Nvidia в Linux поддерживается отлично.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 608
Re: Проблема с видеокартой.
« Ответ #10 : 01.11.2009 20:10:42 »
Проблема с видеокартами ATI уже не один год существует .
Трудно сказать когда  появятся нормальные драйвера, но скорей всего  не в этом году, а может и не в следующем.
Угу.
А может никогда:
http://opennet.ru/opennews/art.shtml?num=24052

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 371
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #11 : 01.11.2009 20:11:33 »
Mario_z кстати спасибо за статью!!! Обновил ядро но толку нет,

Drool

  • Гость
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #12 : 01.11.2009 20:21:23 »
Обновил ядро но толку нет,

Так может начать с того, что не так?

Оффлайн nik

  • Давно тут
  • **
  • Сообщений: 516
  • PuppyRus Linux & ALT Linux
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #13 : 01.11.2009 22:17:08 »
Стандартный драйвер fglrx работает ни со всеми карточками на чипе Ати. Если боитесь разнести систему, то используйте свободный драйвер, по крайней мере он заработал у меня на карточках, где не заработал fglrx. Если вы на 100% уверены, что драйвер из дистрибутива не работает с вашей карточкой, а вам хочется поиграть в 3D игры, то удалите модуль ядра fglrx и fglrx_glx, установите исходники ядра и заголовки месы. Тогда может и что нибудь и получится. Для Х1600 лучше брать не последние драйвера, а каталист 8.12
PS. А лучше покажите /var/log/Xorg.0.log
« Последнее редактирование: 01.11.2009 22:20:45 от nik »

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 371
Re: ALTLinux 5.0 и ATI Radeon X1600
« Ответ #14 : 02.11.2009 01:34:31 »
Эх собачька с диском в зубах, я с компами ужэ более 14 лет и повидал всё!!! (тем кто будет галдеть то я и в чечне был чтоб не орали на меня малолетние гады), всегда процы амд были дешэвле и производительнее интэл, и видеокаарты такжэ, я просто найду чела и воткну ему свою