Автор Тема: "хотелки". Обращение к разработчикам.  (Прочитано 199678 раз)

Оффлайн alexxcompany

  • Давно тут
  • **
  • Сообщений: 198
  • Иногда шаг вперед - есть результат пинка в зад
    • Email
GIMP версии 2.8.
Единственное что раньше меня  отталкивало от GIMPа это "многооконность" (неудобно иметь кучу окон при работе с несколькими изображениями). Теперь Однооконный режим появился.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 762
    • Домашняя страница
    • Email
GIMP версии 2.8.
Уже в Sisyphus. Летом появится стабильный бранч p7, куда он и попадёт.
Андрей Черепанов (cas@)

Оффлайн varalt

  • Давно тут
  • **
  • Сообщений: 996
    • Email
GIMP версии 2.8.
Уже в Sisyphus. Летом появится стабильный бранч p7, куда он и попадёт.
Летом? Вы имеете ввиду лето 2012 года или 2013?

Оффлайн ps1h

  • Давно тут
  • **
  • Сообщений: 418
    • Нихрена не работает!
]Уже в Sisyphus. Летом появится стабильный бранч p7, куда он и попадёт.
Т.е. летом ждать альтлинукс 7 ?

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 016
    • Email
Т.е. летом ждать альтлинукс 7 ?
Вряд ли... скорей всего просто перейти нужно будет с p6 на p7... как, например, с p5 на p6...
Сноси Винду, переходи на Линукс ! :)

Оффлайн sasa

  • Давно тут
  • **
  • Сообщений: 1 152
Хочу, чтоб была возможность установить заголовочные файлы, gcc, и прочее, что требуется для компиляции сторонних программ, с помощью одной команды (наподобие update-kernel).
А то каждый раз приходится вспоминать заново что это такое и с чем его едят... :)
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 762
    • Домашняя страница
    • Email
Хочу, чтоб была возможность установить заголовочные файлы, gcc, и прочее, что требуется для компиляции сторонних программ, с помощью одной команды (наподобие update-kernel).
А то каждый раз приходится вспоминать заново что это такое и с чем его едят... :)
apt-get install rpm-buildСодержит всё необходимое для сборки, кроме заголовочных файлов.
Андрей Черепанов (cas@)

Оффлайн sasa

  • Давно тут
  • **
  • Сообщений: 1 152
Спасибо! Но вот самые непонятки постоянно с заголовочными файлами. Вот очень хотелось бы их тоже одной командой ставить. А то каждый раз на новом дистре или новом ядре одно и то же. Мне ведь не важно как они там называются, главное чтобы были :)
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 762
    • Домашняя страница
    • Email
Спасибо! Но вот самые непонятки постоянно с заголовочными файлами. Вот очень хотелось бы их тоже одной командой ставить. А то каждый раз на новом дистре или новом ядре одно и то же. Мне ведь не важно как они там называются, главное чтобы были :)
Ну вот как определить, какие именно заголовочные файлы нужны? Что вы будете собирать: приложения Qt, GTK+, KDE, Java, SDL или сотни других комбинаций? Именно для этого придуманы src.rpm, которые содержат зависимости на нужные пакеты для сборки. Можно установить через apt-get install пакет-....src.rpm, он развернётся в системный сборочный каталог и доустановит все зависимости. Иначе всё делайте ручками, если хотите самостоятельности.

Для справки: все пакеты *-devel в p6 занимают 1,7 ГБ. Предлагаете всем их ставить?
« Последнее редактирование: 28.05.2012 11:28:39 от Skull »
Андрей Черепанов (cas@)

Оффлайн sasa

  • Давно тут
  • **
  • Сообщений: 1 152
Спасибо, я неточно выразился.
Имею в виду файлы, которые устанавливаются вот этими командами:
apt-get install kernel-headers-<тип ядра> kernel-headers-modules-<тип ядра>
Хотя, сам уже вижу, что не так уж много надо набирать, довольно лаконичная команда. Вместе с apt-get install rpm-buildони должны решать проблему установки нужного мне VirtualBox-а :)
« Последнее редактирование: 28.05.2012 21:10:21 от sasa »
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 842
Есть ли шансы что streamripper вернётся в бранчи p6/t6?
Раньше был, из шестых веток вылетел.
Сизифный streamripper на p6 становится :
$ rpm -qa|grep streamr
streamripper-1.64.6-alt1

И даже работает:
$ streamripper http://tuner.country108.com:80 -o never -T -d ~/stream/
Connecting...
stream: COUNTRY 108 - Your Country Music Station!
server name: SHOUTcast/Linux v1.9.8
declared bitrate: 128
meta interval: 32768

^Ckipping...   ] Rodney Atkins - Take A Back Road [  129kb]
shutting down
bye..
« Последнее редактирование: 29.06.2012 21:10:16 от Speccyfighter »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 762
    • Домашняя страница
    • Email
Есть ли шансы что streamripper вернётся в бранчи p6/t6?
Скопировал из Сизифа, задание уже выполнено. Ждите с утра в бранче.
Андрей Черепанов (cas@)

Оффлайн unihorn

  • Давно тут
  • **
  • Сообщений: 354
В наших же текущих репах QtCurve слишком старый (а сейчас он далеко шагнул вперед), и, к примеру, в случае выставления градиентов как фона окон может крэшить систему и дельфина (ну не крэшить, а "красные карточки" с "отправить ошибку выдавать")...

Выложил src.rpm для нового QtCurve (версия KDE4 1 .8.12, и сопутствующие ей версии для
GTK2 и QT3): https://bugzilla.altlinux.org/show_bug.cgi?id=27481

Себе собирал на P6.

Там же, для пощупать и оценить, на всяк случай, выложил и нормальные rpm для P6 64бита (для KDE и GTK2 стилей).

Если это комуто интересно... То хотелось бы официально увидить в наших репах.

С Уважением.
« Последнее редактирование: 28.07.2012 18:30:22 от unihorn »
Мир ищу, где волки агнцам служат,
И нету слуг верней. Где слезы никого не душат. Не ведают смертей.

Оффлайн rxxrus

  • Давно тут
  • **
  • Сообщений: 359
  • AltLinux p?/Ubuntu 15.04
    • Email
Хочу Skype 4 (тот что для Федоры не ставится из за зависимостей).