Автор Тема: Откат на предыдущую версию пакета  (Прочитано 2528 раз)

Оффлайн karp

  • Давно тут
  • **
  • Сообщений: 65
Здравствуйте!
Как правильно откатиться на предыдущую версию пакета, чтобы ничего не сломать?
Проблема: сервер openvpn 2.5 не пускает клиентов с версий 2.3. Надо вернуться на 2.4.9. При попытке установить 2.4.9, apt разумно говорит, что самая последняя версия уже установлена. Подозреваю, что удаление текущей версии может привести к удалению настроек и пр. Конечно, всё можно забэкапить, но есть опасение что-то забыть.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 258
  • Учиться .... Телепатами не рождаются, ими ....
    • Email

Оффлайн karp

  • Давно тут
  • **
  • Сообщений: 65
Re: Откат на предыдущую версию пакета
« Ответ #2 : 05.01.2023 16:35:16 »
Да, спасибо!

Но в данном случае не помогло, есть подозрение, что изменилось что-то ещё (ssl?).

К счастью удалось настроить openvpn 2.5: в нём изменилась опция data-ciphers (было просто ciphers) и добавилась data-ciphers-fallback. Шаманство с ними позволило восстановить необходимую совместимость.