Автор Тема: nginx + nginx-module-njs  (Прочитано 878 раз)

Оффлайн al_tux

  • Начинающий
  • *
  • Сообщений: 21
nginx + nginx-module-njs
« : 13.07.2023 19:30:33 »
Всем привет.
Подскажите как установить модуль
Цитировать
nginx-module-njs

Пробую скаченную версию с сайта http://nginx.org/packages/rhel/7/x86_64/RPMS/
Из ветки 1.22.1 но получаю ошибки о зависимостях, установил libcrypto10 https://packages.altlinux.org/en/sisyphus/binary/libcrypto10/x86_64/files/2385693620829698398

[root@repo repo]#
[root@repo repo]# nginx -v
nginx version: nginx/1.22.1
[root@repo repo]#
/usr/lib/mc/extfs.d/rpm run /home/repo/nginx-module-njs-1.22.1+0.7.7-1.el7.ngx.x86_64.rpm INSTALL
Installing "/home/repo/nginx-module-njs-1.22.1+0.7.7-1.el7.ngx.x86_64.rpm"
ошибка: Неудовлетворенные зависимости:
        libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
        libcrypto.so.10(libcrypto.so.10)(64bit) нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
        libedit.so.0()(64bit) нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
        nginx-r1.22.1 нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
[root@repo repo]#
[root@repo lib64]# ls -l /lib64/libcrypto.so.10
lrwxrwxrwx 1 root root 19 апр 17  2019 /lib64/libcrypto.so.10 -> libcrypto.so.1.0.2r
[root@repo lib64]#

Пакет libedit отсутствовал в репозитарии, скачал и поставил.
https://packages.altlinux.org/en/sisyphus/binary/libedit/x86_64/files/

А вот зависимости libcrypto.so.10 + другая версия nginx nginx-r1.22.1
Непонятно как решить.

[root@repo repo]# /usr/lib/mc/extfs.d/rpm run /home/repo/nginx-module-njs-1.22.1+0.7.7-1.el7.ngx.x86_64.rpm INSTALL
Installing "/home/repo/nginx-module-njs-1.22.1+0.7.7-1.el7.ngx.x86_64.rpm"
ошибка: Неудовлетворенные зависимости:
        libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
        libcrypto.so.10(libcrypto.so.10)(64bit) нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64
        nginx-r1.22.1 нужен для nginx-module-njs-1:1.22.1+0.7.7-1.el7.ngx.x86_64

Подскажите как установить модуль
Цитировать
nginx-module-njs