Автор Тема: Первый выпуск стартеркитов p10 (20210805)  (Прочитано 3368 раз)

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 546
  • antohami@
Здравствуйте

Готов первый выпуск стартеркитов на базе нового бранча p10
i586, x86_64, aarch64 и armh.
Официальный выпуск бранча ожидается только на следующей неделе.
Обновление до p10 до этого момента крайне не рекомендуется.
Нетерпеливым же предлагаю попробовать стартовые наборы ;-)

Изменения:

- Обновлена доверенная цепочка для загрузки на UEFI Secure Boot силами nikel@.
  Так что образы должны грузиться до 2031 года на Secure Boot, если конечно в grub
  не найдут до этого времени новую уязвимость;

- Доступен новый стартеркит с окружением рабочего стола Deepin из дружественного Китая,
  собранное и почти доведённое до ума силами lvol@, за что ему огромное спасибо.
  Собраны iso образы для x86_64 и aarch64, а также образ rootfs для Raspberry Pi 4;

- Для i586 больше не собираются стартеркиты: сinnamon, enlightenment, sever-sysv;

- Для aarch64 теперь собираются iso-образы: cinnamon, deepin, kde5, lxqt, mate, xfce,
  builder, rescue, server-systemd;

- Вместо архивов rootfs теперь образы img.xz, которые уже содержат загрузчики для
  Raspberry Pi 3 и 4. Для других одноплатников нужно устанавливать u-boot при помощи
  alt-rootfs-installer;

- ядро std-def 5.10.54, un-def 5.12.19;

- make-initrd 2.19.1

- xorg-server 1.20.11, Mesa 21.1.5

- systemd 249.1

- Firefox ESR 78.12, Chromium 92

- gtk4 4.2.1, gtk+3 3.24.29, qt 5.15.2

- kde5: 5.84.0 / 5.22.3 / 21.0.4.

- cinnamon 5.0.3;

- enlightenment 0.24.2

- gnome 40.2

- gnustep 1.28, WindowMaker 0.95.9

- icewm 2.6.0

- lxqt 0.17.0

- mate 1.24.1

- xfce 4.16.3

- server: samba 4.14.6, php 7.4.21, apache 2.4.48, maridb 10.4.20, postgresql 11.12

* Известные проблемы:

- enlightenment не реагирует на устройства ввода при запуске сеанса wayland через
  lightdm-gtk-greeter (ALT bug 40244);

- В инсталяторе не работает форматирование в xfs (ALT bug 39567)

* Engineering

За компанию собрался Engineering на p10.
На этот раз в двух ипостасях: live и инсталятор с одинаковым набором инженерного ПО:
https://www.altlinux.org/Engineering

А также cnc-rt - лайв с реал-тайм ядром на основе lxqt
и программным ЧПУ LinuxCNC для x86_64. В образ также включены реал-тайм тесты:

https://www.altlinux.org/Realtime

* Ссылки:

- http://altlinux.org/starterkits
- http://altlinux.org/starterkits/Download
- http://nightly.altlinux.org/p10/
- http://nightly.altlinux.org/p10-aarch64/
- http://nightly.altlinux.org/p10-armh/
- http://mirror.yandex.ru/altlinux-starterkits/ (в данный момент ведёт на p9)
- Инструкция по записи rootfs:
  https://www.altlinux.org/Write/rootfs
- Инструкция по запуску в qemu образов rootfs (aarch64, armh):
  https://www.altlinux.org/Regular/arm#Запуск_в_QEMU

* Торренты:

- i586, x86_64:

http://torrent.altlinux.org/gettorrent.php?info_hash=6a4afcb80eb705dd24ae9a979825f49a9993394d

- aarch64:

http://torrent.altlinux.org/gettorrent.php?info_hash=adeea88a15404325243b5557b6ca3f2df356bd01

* Собрано с использованием mkimage-profiles из тега p10-20210805:
http://git.altlinux.org/people/antohami/packages/mkimage-profiles.git?p=mkimage-profiles.git;a=tag;h=refs/tags/p10-20210805
« Последнее редактирование: 06.08.2021 18:19:17 от Антон Мидюков »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Спасибо, Антон.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Из образов alt-p10-xfce-sysv удалён пакет xfce4-clipman-plugin

Причина, потенциальная угроза безопасности xfce-sysv:
Неотключаемое и неудаляемое автокопирование выделения в буфер выделения clipman версии 1.6.2.

Но помните, что и в этом случае, в X-сессии xfce сохраняется автокопирование выделенного в буфер консоли. И возможна вставка выделенного по Shift+Insert в терминал xfce4-terminal, без явного копирования выделенного в буфер консоли. Будьте осторожны.

С удалением clipman из образа, связано и изменение в пакете xfce4-regular, сделанное Антоном Мидюковым, - пакет xfce4-clipman-plugin убран из зависимостей в пакете xfce4-regular:
# apt-cache show xfce4-regular | grep Changelog -A2 | head -n 3
Changelog:
 * Пн авг 02 2021 Anton Midyukov ... 4.16-alt2
 - regular: Drop xfce4-clipman

Желающие пользоваться GUI-менеджером буфера обмена, могут установить из репозитория пакет xfce4-clipman-plugin или пакет parcellite.
Parcellite, мощный гибкий менеджер буфера обмена. Но помните, что при открытом окне настроек parcellite, копирование выделения в его буфер, хоткеем или опцией, привводит к зависанию parcellite и невозможности закрыть его окно настроек. С необходимостью пересылки сигнала SIGTERM его процессу, для завершения работы parcellite.. И необходимостью последующего нового запуска parcellite.


Известные баги:

- Неизменяемый значёк power-manager в трее, независимо от выбранной темы иконок. Причина неизвестна.
- Чрезвычайно редкое и рандомное сваливание X-сов в чёрный экран на выходе из suspend. Замечено на графике BDW GT2. Общесистемное. X-сервер. От видеодрайвера не зависит. Логи не оставляет. Не влияет на сессии в tty.
- Ядерный баг #203709 компонента network-wireless-intel на ядрах 5.1+.

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 546
  • antohami@
Но помните, что при открытом окне настроек parcellite, копирование выделения в его буфер, хоткеем или опцией, привводит к зависанию parcellite и невозможности закрыть его окно настроек

Вот, кстати, ни разу не попадал с этим :-) А багу то повесьте, пожалуйста.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Но помните, что при открытом окне настроек parcellite, копирование выделения в его буфер, хоткеем или опцией, привводит к зависанию parcellite и невозможности закрыть его окно настроек

Вот, кстати, ни разу не попадал с этим :-) А багу то повесьте, пожалуйста.

Подожду пока.
Когда получу устойчиво:

Перед тем как начал писать багрепорт, получил два-три раза отказ закрытия окна настроек и отказ открытия падающего окна истории по ЛКМ. (По ПКМ на parcellite в трее, падающее окно открывалось.) Копирование выделенного в буфер, при предварительно очищеном буфере, из xfce4-terminal по ПКМ Копировать. Процесс parcellite завершал через Диспетчер задач, с последующим его запуском. Начал писать багрепорт. Написал его до половины. Ещё раз повторил несколько раз. И не могу воспроизвести.

Оффлайн ARHAN

  • Завсегдатай
  • *
  • Сообщений: 1 031
  • kde-p10,mate-p10 xfce-p10
 ;-)Спасибо.Будем пробовать.
Век живи, век учись.

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 138
Не обновляется...
# apt-repo set p10
...
# apt-get update
...
# apt-get dist-upgrade
...
2903 будет обновлено, 239 новых установлено, 12 пакетов будет заменено, 19 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B/2492MB архивов.
После распаковки потребуется дополнительно 1210MB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                                                                                                             #################################################################################################### [100%]
        installing package i586-libwine-1:6.12.1-alt1.i586 needs 81MB on the / filesystem
        installing package libsox-fmt-pulseaudio-14.4.2-alt4.x86_64 needs 80MB on the / filesystem
        installing package pipewire-libs-0.3.31-alt1.x86_64 needs 86MB on the / filesystem
        installing package kf5-kdoctools-5.84.0-alt1.x86_64 needs 91MB on the / filesystem
        installing package libtinfo-devel-6.2.20210123-alt1.x86_64 needs 86MB on the / filesystem
        installing package libncurses-devel-6.2.20210123-alt1.x86_64 needs 91MB on the / filesystem
        installing package python3-dev-3.9.6-alt1.x86_64 needs 89MB on the / filesystem
...
        installing package branding-alt-starterkit-notes-p10-alt1.noarch needs 728MB on the / filesystem
        installing package appstream-data-20190919-alt1.noarch needs 746MB on the / filesystem
        installing package altlinux-mime-defaults-0.436-alt1.noarch needs 729MB on the / filesystem
E: Ошибка во время исполнения транзакции
# df -h
Файловая система Размер Использовано  Дост Использовано% Cмонтировано в
udevfs             961M          96K  961M            1% /dev
runfs              976M         1,2M  975M            1% /run
/dev/sda1           16G          12G  3,3G           79% /
tmpfs              976M            0  976M            0% /dev/shm
tmpfs              4,0M            0  4,0M            0% /sys/fs/cgroup
tmpfs              976M            0  976M            0% /tmp
/dev/sda5           64G          31G   34G           49% /home
tmpfs              196M          32K  196M            1% /run/user/474
tmpfs              196M          32K  196M            1% /run/user/500

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 223
    • Домашняя страница
    • Email
Очищайте диск: journalctl --vaciuum-time=1d
Андрей Черепанов (cas@)

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 138
Очищайте диск: journalctl --vaciuum-time=1d
там 3300MB свободно, а "потребуется дополнительно 1210MB" ... пакеты скачены, их загрузка уже не нужна.

Оффлайн ARHAN

  • Завсегдатай
  • *
  • Сообщений: 1 031
  • kde-p10,mate-p10 xfce-p10
deepin ,попробовал поставить,все встало нормально,но wifi c телефона не удалось подключить,по usb без проблем работает. Может в лайф версии чего то не хватает,или там  немного по другому надо,менеджер входа в инет не знаком этот мне.Отличается от нашего стандартного.
Век живи, век учись.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 223
    • Домашняя страница
    • Email
Очищайте диск: journalctl --vaciuum-time=1d
там 3300MB свободно, а "потребуется дополнительно 1210MB" ... пакеты скачены, их загрузка уже не нужна.
Учитывайте ещё полный объём установленных пакетов. С p9 apt сначала ставит оптом, потом удаляет оптом, а не обновляет каждый пакет.
Андрей Черепанов (cas@)

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 138
Очищайте диск: journalctl --vaciuum-time=1d
там 3300MB свободно, а "потребуется дополнительно 1210MB" ... пакеты скачены, их загрузка уже не нужна.
Учитывайте ещё полный объём установленных пакетов. С p9 apt сначала ставит оптом, потом удаляет оптом, а не обновляет каждый пакет.
и зачем это? Чтобы 2х больше места требовалось впустую?

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Не обновляется...

Конечно. Из 16-ти гигов в корне, свободно только 3.3.
Попытайтесь сделать обновление через жо объездом:
Обновлять систему не целиком, а крупными самыми тяжёлыми группами через reinstall, - DE, браузур и т.д. Очищая кеш apt после каждого обновления группы. А потом, в конце, когда крупные группы пакетов будут обновлены и останется мелочь, выполнить dist-upgrade. Но нужно учитывать, что на каждой свежей версии, код пухнет. И система тоже будет пухнуть по дисковому после каждого dist-upgrade.

Как пример, обновление DE в xfce-sysv не используя dist-upgrade:
# apt-get reinstall $(rpm -qa --qf '%{NAME}\n' | grep ^xfce)

Например в p10-xfce-sysv самые тяжёлые пакеты, это:
- Показать информацию по всем установленным пакетам
- grep-нуть в выводах Пакет и Размер (в распакованном)
- grep-нуть мегабайты и имя пакета
$ aptitude show ~i | grep 'Пакет\|^Размер' | grep M$ -B1
Пакет: libopenblas
Размер в распакованном виде: 18,8M
--
Пакет: iso-codes
Размер в распакованном виде: 19,6M
--
Пакет: libgtk+2-locales
Размер в распакованном виде: 19,9M
--
Пакет: pandoc
Размер в распакованном виде: 101M
--
Пакет: menu-messages
Размер в распакованном виде: 11,9M
--
Пакет: xorg-dri-swrast
Размер в распакованном виде: 79,7M
--
Пакет: grub-common
Размер в распакованном виде: 12,1M
--
Пакет: libva-intel-media-driver
Размер в распакованном виде: 36,8M
--
Пакет: libmozjs78
Размер в распакованном виде: 12,3M
--
Пакет: python3-base
Размер в распакованном виде: 33,3M
--
Пакет: cracklib-words
Размер в распакованном виде: 19,0M
--
Пакет: coreutils
Размер в распакованном виде: 17,7M
--
Пакет: xorg-dri-radeon
Размер в распакованном виде: 27,8M
--
Пакет: gdcm
Размер в распакованном виде: 10,1M
--
Пакет: icon-theme-adwaita
Размер в распакованном виде: 21,7M
--
Пакет: gnome-icon-theme
Размер в распакованном виде: 10,3M
--
Пакет: util-linux
Размер в распакованном виде: 11,7M
--
Пакет: llvm11.0-libs
Размер в распакованном виде: 77,4M
--
Пакет: glibc-locales
Размер в распакованном виде: 235M
--
Пакет: grub-efi
Размер в распакованном виде: 41,2M
--
Пакет: qt5-translations
Размер в распакованном виде: 13,0M
--
Пакет: libjavascriptcoregtk4
Размер в распакованном виде: 25,7M
--
Пакет: vim-common
Размер в распакованном виде: 25,0M
--
Пакет: xorg-dri-intel
Размер в распакованном виде: 19,7M
--
Пакет: kernel-modules-drm-std-def#2:5.10.53-alt1:p10+280755.100.1.1@1627305499
Размер в распакованном виде: 43,9M
--
Пакет: samba-libs
Размер в распакованном виде: 12,1M
--
Пакет: kernel-image-std-def#2:5.10.53-alt1:p10+280755.100.1.1@1627305872
Размер в распакованном виде: 265M
--
Пакет: firefox-esr
Размер в распакованном виде: 207M
--
Пакет: gdm2.20
Размер в распакованном виде: 11,6M
--
Пакет: libsuitesparse
Размер в распакованном виде: 62,9M
--
Пакет: firmware-linux
Размер в распакованном виде: 532M
--
Размер в распакованном виде: 397k
Пакет: libSM
--
Пакет: libgs
Размер в распакованном виде: 68,1M
--
Пакет: guile22
Размер в распакованном виде: 44,9M
--
Пакет: libqt5-gui
Размер в распакованном виде: 10,3M
--
Пакет: libopencv4.5
Размер в распакованном виде: 33,2M
--
Пакет: libavcodec58
Размер в распакованном виде: 15,6M
--
Пакет: librsvg
Размер в распакованном виде: 10,4M
--
Пакет: cpp10
Размер в распакованном виде: 27,2M
--
Пакет: NetworkManager-daemon
Размер в распакованном виде: 14,1M
--
Пакет: poppler-data
Размер в распакованном виде: 12,1M
--
Пакет: libgtk+3
Размер в распакованном виде: 36,3M
--
Пакет: libx265-199
Размер в распакованном виде: 16,4M
--
Пакет: libicu69
Размер в распакованном виде: 34,4M
--
Пакет: grub-pc
Размер в распакованном виде: 15,1M
--
Пакет: libwebkit2gtk
Размер в распакованном виде: 60,1M
--
Пакет: samba-common-libs
Размер в распакованном виде: 10,2M
--
Пакет: gnupg2
Размер в распакованном виде: 10,8M

Онлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 138
Не обновляется...
Конечно. Из 16-ти гигов в корне, свободно только 3.3.
Попытайтесь сделать обновление через жо объездом:
А зачем мне держать пустое место "про запас"? Можно конечно удалить пол-системы, а потом вернуть обратно. Я так понимаю альтовцы хотят чтобы ещё гигабайт стал свободен.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Не обновляется...
Конечно. Из 16-ти гигов в корне, свободно только 3.3.
Попытайтесь сделать обновление через жо объездом:
А зачем мне держать пустое место "про запас"?

Это не ко мне. Я такие вещи не задвигаю. Альты этим взяли за горло пользователей маленьких SSD.
И на моей памяти, например установка альтов в условиях жёстких ограничений на дисковое, это не первый случай. Первым был, когда парень на форуме попросил помощи установки на ноутбук с внутренним флеш-накопителем в 4 гига.
Мой метод выше, это объезд этой жопы. Когда свободное дисковое корня оставляет желать лучшего и на него жёсткий лимит.
Но более лучший метод в этой ситуации по-быстрому, это переносить /usr в какую-то другую файловую.

Я так понимаю альтовцы хотят чтобы ещё гигабайт стал свободен.

От системы и её наполнения зависит. Но и с гигабайтом свободного может и не повезти. :-)