Автор Тема: Обновление сервера ALT до p10  (Прочитано 315 раз)

Оффлайн NecroJoke

  • Завсегдатай
  • *
  • Сообщений: 453
    • Email
Добрый день, давненько у меня функционирует заббикс на альте, решил переехать на p10 (на p9 был переезд ранее), как и положено использовал инструкцию https://www.altlinux.org/Update/p10 следовал ей четко. После обновления не стартутет postgres11
cat /etc/*release
ALT 8.2 Server
ALT 8.2 Server
NAME="ALT Server"
VERSION="10.0"
ID=altlinux
VERSION_ID=10.0
PRETTY_NAME="ALT Server 10.0 (FalcoRusticolus)"
ANSI_COLOR="1;33"
CPE_NAME="cpe:/o:alt:server:10.0"
BUILD_ID="ALT Server 8.2 (december)"
HOME_URL="https://basealt.ru/"
BUG_REPORT_URL="https://bugs.altlinux.org/"
ALT 8.2 Server
ALT 8.2 Server
Начат процесс запуска юнита postgresql.service.
янв 13 12:18:14 glx-zabbix.glx.local pg_ctl[3162]: 2022-01-13 12:18:14.170 +07 [3162] ВАЖНО:  загрузить библиотеку "/usr/lib64/pgsql/pg_partman_bgw.so" не удалось: /usr/lib64/pgsql/pg_partman_bgw.so: undefined symbol: pg_snprintf
янв 13 12:18:14 glx-zabbix.glx.local pg_ctl[3162]: 2022-01-13 12:18:14.170 +07 [3162] СООБЩЕНИЕ:  система БД выключена
янв 13 12:18:14 glx-zabbix.glx.local pg_ctl[3160]: pg_ctl: не удалось запустить сервер
янв 13 12:18:14 glx-zabbix.glx.local pg_ctl[3160]: Изучите протокол выполнения.
янв 13 12:18:14 glx-zabbix.glx.local systemd[1]: postgresql.service: Control process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit postgresql.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
янв 13 12:18:14 glx-zabbix.glx.local systemd[1]: postgresql.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit postgresql.service has entered the 'failed' state with result 'exit-code'.
янв 13 12:18:14 glx-zabbix.glx.local systemd[1]: Failed to start PostgreSQL database server.
также при попытке поставить 13 и 12 версию получаю:
# apt-get install postgresql13
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  postgresql13: Требует: libpq.so.5()(64bit) (>= set:le9HtsjCw06LDDfITzNjIzZo7waIz2zyvdPbuNGZ3iZz1HoJZ0yqubHEJLbXuEmSZoeBf8Dh15BreHzTSlIOqhIbamP5MdFzRwZkdU0omAPGjstE85Qij39mMSjqWKZvrpaCB14B6QyapX1r2FtdI1Naug1f3W2yu36Nej52kyFqyrzXR7wvxczDJXR7BCdt4QPKRps0lZeE0)
E: Извините, `битые' пакеты
Конечно кэш обновлял и clean делал, но пакеты битые. Откатился на точку восстановления, снова проделал инструкцию по обновлению, к сожалению не помогло. Прошу сообщество посоветовать что можно предпринять.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 165
    • Домашняя страница
    • Email
Re: Обновление сервера ALT до p10
« Ответ #1 : 13.01.2022 08:36:54 »
Не до конца обновили. Покажите вывод apt-get dist-upgrade.
Переход на 13 версию потребует создание дампа на 11 и его восстановление на 13.
Андрей Черепанов (cas@)

Оффлайн NecroJoke

  • Завсегдатай
  • *
  • Сообщений: 453
    • Email
Re: Обновление сервера ALT до p10
« Ответ #2 : 13.01.2022 10:48:55 »
Не до конца обновили. Покажите вывод apt-get dist-upgrade.
Переход на 13 версию потребует создание дампа на 11 и его восстановление на 13.
Обновлено до конца, apt-get dist-upgrade показывает 0 пакетов к обновлению. Попробовал поставить 14 версию, установилась и чудом ставится начали и 12 и 13. Вернулся к 11, сервер запускается. Но с существующей базой требует два пакета дополнительно, один из которых pg_partman, и вот потом появляется первоначальная ошибка. Может pg_partman 11 неверно собран в p10?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 165
    • Домашняя страница
    • Email
Re: Обновление сервера ALT до p10
« Ответ #3 : 13.01.2022 13:15:29 »
Не до конца обновили. Покажите вывод apt-get dist-upgrade.
Переход на 13 версию потребует создание дампа на 11 и его восстановление на 13.
Обновлено до конца, apt-get dist-upgrade показывает 0 пакетов к обновлению. Попробовал поставить 14 версию, установилась и чудом ставится начали и 12 и 13. Вернулся к 11, сервер запускается. Но с существующей базой требует два пакета дополнительно, один из которых pg_partman, и вот потом появляется первоначальная ошибка. Может pg_partman 11 неверно собран в p10?
Там могут быть сохранённые пакеты. По pg_partman на bugs.altlinux.org. На Sisyphus, пожалуйста.
Андрей Черепанов (cas@)