Автор Тема: Проблема при создании виртуальной машины в Opennebula  (Прочитано 275 раз)

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6
Добрый день, возникли проблемы с разворачиванием ВМ с OpenNebula. В логе создания ВМ находится следующее:

Wed May  4 19:15:54 2022 [Z0][VM]: New state is ACTIVE
Wed May  4 19:15:54 2022 [Z0][VM]: New LCM state is PROLOG
Wed May  4 19:17:44 2022 [Z0][VM]: New LCM state is BOOT
Wed May  4 19:17:45 2022 [Z0][VMM]: Generating deployment file: /var/lib/one/vms/9/deployment.0
Wed May  4 19:17:45 2022 [Z0][VMM]: Successfully execute transfer manager driver operation: tm_context.
Wed May  4 19:17:45 2022 [Z0][VMM]: Successfully execute network driver operation: pre.
Wed May  4 19:17:46 2022 [Z0][VMM]: Command execution fail: cat << EOT | /var/tmp/one/vmm/kvm/deploy '/var/lib/one//datastores/0/9/deployment.0' '10.0.2.15' 9 10.0.2.15
Wed May  4 19:17:46 2022 [Z0][VMM]: error: Failed to create domain from /var/lib/one//datastores/0/9/deployment.0
Wed May  4 19:17:46 2022 [Z0][VMM]: error: внутренняя ошибка: процесс завершил работу во время подключения к монитору: 2022-05-04T14:17:46.431483Z qemu-system-x86_64: The -accel and "-machine accel=" options are incompatible
Wed May  4 19:17:46 2022 [Z0][VMM][E]: Could not create domain from /var/lib/one//datastores/0/9/deployment.0
Wed May  4 19:17:46 2022 [Z0][VMM]: ExitCode: 255
Wed May  4 19:17:46 2022 [Z0][VMM]: Failed to execute virtualization driver operation: deploy.
Wed May  4 19:17:46 2022 [Z0][VMM][E]: Error deploying virtual machine: Could not create domain from /var/lib/one//datastores/0/9/deployment.0
Wed May  4 19:17:46 2022 [Z0][VM]: New LCM state is BOOT_FAILURE

SSH настроен верно, хосты видны в интерфейсе, ядро и все дистрибутивы обновлены, проблемы возникают при создании ВМ. Используется OpenNebula 5.10.5 на ОС Альт Образование 10.1, запущенной на Virtual Box, вложенная виртуализация включена. Можете помочь с решением данной проблемы?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 936
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Такой баги ещё нет ?
https://packages.altlinux.org/ru/sisyphus/srpms/opennebula/issues/
Если нет, то заведите.

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6
Есть какие-нибудь решения данной проблемы?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 936
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Спросите в багзиле

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6
Я вроде написал туда, но ответа за несколько дней не последовало

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 936
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Ссылку дайте на багу в багзиле

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6
Ссылку дайте на багу в багзиле

Можете подсказать, баг оформлен верно, а то уже несколько дней ответов нет

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 165
    • Домашняя страница
    • Email
Ссылку дайте на багу в багзиле

Можете подсказать, баг оформлен верно, а то уже несколько дней ответов нет
Верно. Ждите, надо воспроизводить. Через техподдержку Альт Сервер Виртуализации было бы быстрее. А так — ждать мейнтейнера.
Андрей Черепанов (cas@)

Оффлайн origamiko

  • Начинающий
  • *
  • Сообщений: 6
Также проверил на Alt Сервер Виртуализации 10.0 в качестве сервера управления и сервера виртуализации, проблема не изменилась