Автор Тема: как настроить завершение работы системы и почему перестали крутиться ютубролики  (Прочитано 16307 раз)

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 1 001
Может попробовать переустановить с заранее подключенном кабеле сети.
При таком варианте он сразу все обновления скачает и установит. А еще русификацию и, если согласитесь, несвободные кодеки (вроде mp3).

Но последняя проблема вызвана не этим. Это либо проявление бага, либо признак проблемного диска.

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
видимо ошибки остались потому что первый пункт переустановки пытался сохранить файлы пользователя.
выбрал второй пункт - форматирование и новая установка.
При установке выход в сеть по кабелю была - заметил проверку зеркал.
Галочку обновлять системне файлы при установке не выбрал.
Хочу контролировать этот процесс.
Сейчас этим займусь.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
[sudo] пароль для reja:
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://ru.archive.ubuntu.com/ubuntu xenial InRelease         
Hit:3 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease 
Hit:4 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease
Get:5 http://ru.archive.ubuntu.com/ubuntu xenial/main Translation-ru [411 kB]
Get:6 http://ru.archive.ubuntu.com/ubuntu xenial/restricted Translation-ru [2 604 B]
Get:7 http://ru.archive.ubuntu.com/ubuntu xenial/universe Translation-ru [1 153 kB]
Get:8 http://ru.archive.ubuntu.com/ubuntu xenial/multiverse Translation-ru [83,6 kB]
Получено 1 650 kБ за 2с (642 kБ/c)                                     
*** Error in `appstreamcli': double free or corruption (!prev): 0x08e5a218 ***
======= Backtrace: =========
/lib/i386-linux-gnu/libc.so.6(+0x67257)[0xb7265257]
...

https://askubuntu.com/questions/943463/library-corruption-error-during-apt-get-update
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822317
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822363

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
по первому пункту...
https://askubuntu.com/questions/943463/library-corruption-error-during-apt-get-update
sudo apt-get purge libappstream3
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут УДАЛЕНЫ:
  appstream* gnome-software* libappstream3*
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 3 пакетов, и 465 пакетов не обновлено.
После данной операции, объём занятого дискового пространства уменьшится на 1 634 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 157203 файла и каталога.)
Удаляется gnome-software (3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2) …
Вычищаются файлы настройки пакета gnome-software (3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2) …
Удаляется appstream (0.9.4-1) …
Вычищаются файлы настройки пакета appstream (0.9.4-1) …
rmdir: не удалось удалить '/var/cache/app-info/': Каталог не пуст
Удаляется libappstream3:i386 (0.9.4-1) …
Обрабатываются триггеры для libglib2.0-0:i386 (2.48.0-1ubuntu4) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для gnome-menus (3.13.3-6ubuntu3) …
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu5) …
Обрабатываются триггеры для mime-support (3.59ubuntu1) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
//////////////
sudo apt install --reinstall libappstream3
[sudo] пароль для barbos:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  libappstream3
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 465 пакетов не обновлено.
Необходимо скачать 110 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 379 kB.
Get:1 http://ru.archive.ubuntu.com/ubuntu xenial-updates/main i386 libappstream3 i386 0.9.4-1ubuntu3 [110 kB]
Получено 110 kБ за 0с (420 kБ/c)       
Выбор ранее не выбранного пакета libappstream3:i386.
(Чтение базы данных … на данный момент установлено 157156 файлов и каталогов.)
Подготовка к распаковке …/libappstream3_0.9.4-1ubuntu3_i386.deb …
Распаковывается libappstream3:i386 (0.9.4-1ubuntu3) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
Настраивается пакет libappstream3:i386 (0.9.4-1ubuntu3) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
« Последнее редактирование: 16.01.2018 15:09:52 от vidron »

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
вроде пошло
sudo apt-get update
Hit:1 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease                                         
Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease                                           
Hit:4 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease                                       
Чтение списков пакетов… Готово
.....
До этого выдавал ошибку системы
...................................................
sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Пакеты, которые будут оставлены в неизменном виде:
  libdrm-amdgpu1 libdrm2 libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libinput10 libmirclient9 libwayland-egl1-mesa libxatracker2 linux-generic linux-headers-generic
  linux-image-generic mesa-vdpau-drivers python3-software-properties python3-update-manager software-properties-common software-properties-gtk update-manager update-manager-core update-notifier
  update-notifier-common
Пакеты, которые будут обновлены:
  accountsservice adwaita-icon-theme apparmor apport apport-gtk apt apt-transport-https apt-utils base-files bash bash-completion bind9-host binutils bluez bluez-cups bluez-obexd brltty brltty-x11
  bsdutils ca-certificates command-not-found
.......
................
whoopsie wpasupplicant xbrlapi xdg-utils xfce4-weather-plugin xfonts-utils xinit xserver-common xserver-xorg-core xserver-xorg-video-amdgpu xserver-xorg-video-intel xul-ext-ubufox zlib1g
обновлено 442, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 23 пакетов не обновлено.
Необходимо скачать 396 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 205 MB.
Хотите продолжить? [Д/н]
//////////////////////////////////////////////////////////////
Обрабатываются триггеры для initramfs-tools (0.122ubuntu8.10) …
update-initramfs: Generating /boot/initrd.img-4.4.0-21-generic
Обрабатываются триггеры для ca-certificates (20170717~16.04.1) …
Updating certificates in /etc/ssl/certs...
17 added, 42 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Обрабатываются триггеры для resolvconf (1.78ubuntu5) …
................
и все это заняло минут 30 и даже более ..........
Странно, ведь раньше с этого диска все стало, а сейчас нет.
Диск целый, царапин и пятен на нем нет...
« Последнее редактирование: 16.01.2018 16:00:35 от vidron »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
вроде пошло
sudo apt-get update
...
Хотите продолжить? [Д/н]

Угу. В каждом линукс лежит своя коробочка с тараканами.
Вы их сначала выпустили, потом переловили и затолкнули обратно :-)

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
Угу. В каждом линукс лежит своя коробочка с тараканами.
Вы их сначала выпустили, потом переловили и затолкнули обратно :-)
:-))
если б не ваша помощь, плюнул бы и ставил что нибудь другое
русификация в лисице восстановилась, а вот это настораживает

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
Странно выглядит
 sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
[sudo] пароль для barbos:
Пол:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Сущ:2 http://ru.archive.ubuntu.com/ubuntu xenial InRelease                         
Сущ:3 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease                                   
Сущ:4 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease                                 
Получено 102 kБ за 0с (108 kБ/c)                                                                     
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Пакеты, которые будут оставлены в неизменном виде:
  libdrm-amdgpu1 libdrm2 libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libinput10 libmirclient9 libwayland-egl1-mesa libxatracker2 linux-generic linux-headers-generic
  linux-image-generic mesa-vdpau-drivers python3-software-properties python3-update-manager software-properties-common software-properties-gtk update-manager update-manager-core update-notifier
  update-notifier-common
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 23 пакетов не обновлено.
...........
...............       15 минут установок
.......
но ведь обновление уже прошло
откуда эти новые пакеты ?

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 9 001
Прошу всё же перенести решение проблем убунты на ресурсы сообщества убунты (хоть на форум, хоть в соцсети). Здесь специалистов по убунте вы вряд ли найдёте.
Ну и см. https://forum.altlinux.org/index.php?topic=40203.0

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
а вот это настораживает

Это вам решать, нужен ли вам этот appstreamcli
https://www.freedesktop.org/software/appstream/docs/api/re22.html
https://www.freedesktop.org/wiki/Distributions/AppStream/
https://www.freedesktop.org/software/appstream/docs/
https://github.com/ximion/appstream

Что касается меня, я прощаю нехватку функционала и пытаюсь обойти это доступными средствами. Но никогда и никому не прощаю багов в релизах. По моим критериям, всё что забажено, к релизу не пригодно.


Угу. В каждом линукс лежит своя коробочка с тараканами.
Вы их сначала выпустили, потом переловили и затолкнули обратно :-)
:-))
если б не ваша помощь, плюнул бы и ставил что нибудь другое

Не разбрасывайтесь затрачивая усилия впустую. Из массы проблем выбирайте самую важную и доводите её до конца. И опыт со временем придёт сам. Не торопите события, всему своё время.
Устанавливая пачки линуксов, до конца или хотя бы на половину, вы не узнаете ни один из них. Максимум что можно держать в поле зрения и понимать, это пару из них. Но на бОльшее у вас не хватит ни сил, ни времени.


Про apt:
Эта страница Убунту
http://help.ubuntu.ru/wiki/apt

ссылается на apt-howto проекта debian
https://www.debian.org/doc/manuals/apt-howto/
https://www.debian.org/doc/manuals/apt-howto/ch-apt-get.ru.html

Обновление системы описано и в debian
9.1.2 apt-get и apt-cdrom
https://www.debian.org/doc/manuals/debian-faq/ch-uptodate.ru.html

Кратко об особенностях команды upgrade
https://www.debian.org/doc/manuals/debian-faq/ch-pkgtools.ru.html#s-apt-get

В debian существует неплохой контроль ошибок входящих пакетов - apt-listbugs
В Убунту мне помнится его разломали где-то в году 2009-ом. А зря. Полезная вещь.

Что такое зависимости в Unix-подобных:
Представьте что вы мысленно вырвали дерево с корнем и перевернули вверх тормашками.
Остановите взгляд на произвольной развилке веток:
вот это и есть зависимости.
В бинарных Линукс вы не можете произвольно взять ветку и "обновить" её, не разломав дерево целиком.
Отличие debian и debian-подобных от rpm-базированных линукс в том, что в первых существует понятие необязательных зависимостей. Но если хочется меньше проблем, то все зависимости должны быть обработаны. А обрабатываются они через dist-upgrade/full-upgrade в зависимости от пакетного менеджера.
« Последнее редактирование: 16.01.2018 17:57:05 от Speccyfighter »

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
Прошу всё же перенести решение проблем убунты на ресурсы сообщества убунты
я там уже зарегистрировался и возможно там буду решать вопросы по Убунте.
Хотя, в данном случае, решалась проблема Линукса на основе Убунты.
Кроме того, для меня, этот ресурс роднее. Тем более что на домашнем стационарном компе стоит АльЛинукс.
Да и подобная информация пользователям АльтЛинукса будет полезна:
В бинарных Линукс вы не можете произвольно взять ветку и "обновить" её, не разломав дерево целиком.
Отличие debian и debian-подобных от rpm-базированных линукс в том, что в первых существует понятие необязательных зависимостей. Но если хочется меньше проблем, то все зависимости должны быть обработаны. А обрабатываются они через dist-upgrade/full-upgrade в зависимости от пакетного менеджера.

Это вам решать, нужен ли вам этот appstreamcli
я даже не знаю что это такое.
Просто выскочило окно с этим предупреждением
думал это системная приблуда ... :-)
« Последнее редактирование: 16.01.2018 18:09:23 от vidron »

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 9 001
я там уже зарегистрировался и возможно там буду решать вопросы по Убунте.
Хотя, в данном случае, решалась проблема Линукса на основе Убунты.
Это не имеет значения. У любого линукса есть разработчики, сборщики, пользователи. Никто кроме этих самых людей вам конкретнее не скажет про систему, потому что участники данного форума с большой долей вероятности её просто в глаза не видели и дел с ней не имели. А ссылки с информацией по использованию программ конкретной системы вы и сами могли бы найти в интернете без проблем. Зачем засорять этими ссылками непрофильный форум, если они есть в сети ? В правилах написано про недопустимость флуда. В некоторой степени я раскаиваюсь в том, что разрешил темы по другим дистрибутивам здесь. Воды много, а конкретики по системам крайне мало. И всё это никак не полезно сообществу альт линукс в целом.
Кроме того, для меня, этот ресурс роднее. Тем более что на домашнем стационарном компе стоит АльЛинукс.
Вот и обсуждайте тут вопросы альт линукса, а другие дистрибутивы обсуждайте всё же в их сообществах, т.к. они ближе к теме, чем пользователи этого форума. Это только виндовс можно обсуждать на любом ресурсе в интернете, потому что он везде одинаковый.

Оффлайн Dmytro

  • Мастер
  • ***
  • Сообщений: 1 001
sudo apt-get upgrade
.....
обновлено 442, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 23 пакетов не обновлено.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
.....
...............       15 минут установок
.......
но ведь обновление уже прошло
откуда эти новые пакеты ?

и все это заняло минут 30 и даже более ..........
Странно, ведь раньше с этого диска все стало, а сейчас нет.
А Вы уверены, что раньше все обновлялось?
update - обновление базы пакетов (сведений о пакетах, доступных для установки)
upgrade - обновление установленных пакетов, не приводящее к установке новых или удалению имеющихся пакетов (например, если в новой версии программу из 1 пакета разделили на 2, такой пакет не обновится)
dist-upgrade - обновление, включающее установку новых, удаление существующих пакетов.


если б не ваша помощь, плюнул бы и ставил что нибудь другое
русификация в лисице восстановилась, а вот это настораживает
Windows?  ;-)

Ubuntu - один из самых простых для новичка дистрибутивов. Плюс документации много, в том числе русскоязычной. С другими легче не будет.

Выберите любой дистрибутив, который работает на Вашем железе (пусть и не из коробки) и осваивайте.

Прошу всё же перенести решение проблем убунты на ресурсы сообщества убунты
я там уже зарегистрировался и возможно там буду решать вопросы по Убунте.
Хотя, в данном случае, решалась проблема Линукса на основе Убунты.
Кроме того, для меня, этот ресурс роднее. Тем более что на домашнем стационарном компе стоит АльЛинукс.

Там, реально, больше шансов помощь получить.

Из отвечавших Вам в этой теме никто постоянно Ubuntu не использует. У меня, например, она была основной системой в 2011-2014 годах... Пришлось вспоминать, чем тамошний репозиторий отличается от Альтовского. Для меня это хорошо, т.к. Ubuntu рассматриваю в качестве запасного варианта, если что нужное в Альте работать откажется. А для Вас - потеря времени.
« Последнее редактирование: 16.01.2018 18:04:10 от Dmytro »

Оффлайн vidron

  • Завсегдатай
  • *
  • Сообщений: 177
Это не имеет значения.
намек понятен ...
просто трудно остановиться сразу, моментально.
  Большое спасибо Speccyfighter и Dmytro за помощь в решении моих проблем.
Для меня в этой теме много не просто полезного, а очень важного для понимания.
Первый раз получил достаточно удачное объяснение команд линукса на конкретном примере.
« Последнее редактирование: 16.01.2018 18:59:59 от vidron »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
просто трудно остановиться сразу, моментально.

Чаще интересуйтесь askubuntu.com при поисках в гугл.
Ресурс правда англоязычный, но там толковые парни отвечают. Воды почти ноль и всё по-сути.
Многие ответы можно найти там.
Ну и ресурсы вопросов и ответов unix.stackexchange.com и stackoverflow.com тоже лишними не будут при поиске в гугл, - трепаться впустую там не принято.