Автор Тема: Нет звука в наушниках под ALT Starterkit 10 (Hypericum)  (Прочитано 1447 раз)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Установил ОС. Встроенная звуковая карта. Под Windows 10 звук в наушниках есть (причём автоматом, диск не требуется). А здесь нету. Во вложениях скриншоты ОС и мат. платы. Заранее спасибо.
« Последнее редактирование: 10.10.2023 21:50:04 от GrishaDm »

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 1 175
Что за звуковая? Что выдаёт команда:
inxi -Axxx
Возможно на ядре un-def  уже есть поддержка вашей звуковухи
Обновить ядро:
su -
apt-get update
update-kernel -t un-def
после чего перезагрузиться уже с новым ядром

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Звуковая во вложении. Ядро обновил, но звук не появился.
« Последнее редактирование: 10.10.2023 22:32:57 от GrishaDm »

Оффлайн toreonify

  • Давно тут
  • **
  • Сообщений: 77
Возможно, что я придираюсь и вы это проверяли, но на третьем скриншоте выбрано устройство вывода "линейный выход", а не "наушники".
Также, отключите остальные устройства вывода, выбрав у них в "профиле" "выключено" (или что-то аналогичное), чтобы остались только наушники и тем самым они автоматически использовались после включения системы.

Либо, поставьте pavucontrol и настройте все там, там есть "устройство по умолчанию".

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Разумеется, я проверял все варианты. Кстати, выключить отдельно "Headphones встроенное аудио" и "Line Out встроенное аудио"нельзя: включаешь/выключаешь одно из них - то же происходит и с другим. pavucontrol поставить пытался, но не получается. В итоге так и не смог установить его из командной строки, но получилось из Synaptic. Проверил - звука нет в наушниках, хотя пытается программа туда что-то послать. Под Виндовс в них же - звук есть.
« Последнее редактирование: 11.10.2023 15:41:24 от GrishaDm »

Оффлайн toreonify

  • Давно тут
  • **
  • Сообщений: 77
pavucontrol поставить пытался, но не получается.
Выполните apt-get update перед установкой, чтобы обновить список пакетов. Тогда должен установиться.

И для проверки прикрепите вывод pactl list sinks и aplay -l

З.Ы. сегодня сам боролся со звуком, но оказалось, что одна программа заняла звуковую карту и не отдавала ее PulseAudio. Такое, кстати, встречается при использовании timidity.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Ошибка подключения.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Установил SysInfo под Windows - показывает встроенную звуковую карту на чипе VIA VT1708S_0
Снимок экрана - HardInfo под Linux.
Скриншот 1 - SysInfo Detector Pro под Windows.
Скриншот 2 - панель управления под Windows (там 6 устройств, из которых 1 выделено зелёным значком - оно откликается на стереонаушники и нормально проверяется, определяется всё автоматом на виндовс 10).
« Последнее редактирование: 26.11.2023 00:14:18 от GrishaDm »

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
pavucontrol - зависает при запуске
pulseaudio - выдаёт ошибку
alsa-sof-force установка из rpm-пакета не поддерживается
[a@lureenvoy ~]$ su -
Password:
[root@lureenvoy ~]# epm -i /home/a/Загрузки/settings-alsa-sof-force-1.0-alt1.src.rpm
ERROR: Installation of a source packages (like '/home/a/Загрузки/settings-alsa-sof-force-1.0-alt1.src.rpm') is not supported.  (you can discuss the epm 3.62.2-alt1 problem in Telegram: https://t.me/useepm)
Подскажите рабочий мануал по настройке звука? Что ещё можно сделать?

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 723
  • Дмитрий/Dmitry/德米特里/दिमित्री
[root@lureenvoy ~]# epm -i /home/a/Загрузки/settings-alsa-sof-force-1.0-alt1.src.rpm
Устанавливать надо rpm - т.е. бинарник, а не src.rpm - исходник. Отсюда и ошибка при установке.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Действительно, noarch установился.
Пытаюсь запустить alsamixer - "узел выключен". Поиск не находит такой ошибки.

Оффлайн Nicom

  • Завсегдатай
  • *
  • Сообщений: 671
Судя по картинке
https://forum.altlinux.org/index.php?action=dlattach;topic=48118.0;attach=31337;image
у вас звук через HDMI идёт.

Откуда у вас столько выходов HDMI, как на картинке? https://forum.altlinux.org/index.php?action=dlattach;topic=48118.0;attach=31171;image

В pauvcontrol отключите вывод через HDMI.
Или в alsamixer нажмите кнопку "F6" и посмотрите чтобы каналы на всех устройствах, кроме default0, были выключены (MM), отключаются кнопкой "m".

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Откуда у вас столько выходов HDMI, как на картинке?
Такая встроенная звуковая карта (их 2 там, одна аналоговая, другая цифровая, многоканальные).
pavucontrol и alsamixer у меня не запускаются.
[root@lureenvoy ~]# alsamixer
cannot open mixer: Узел выключен

Оффлайн Nicom

  • Завсегдатай
  • *
  • Сообщений: 671
Из какого дистрибутива ставили систему?

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 331
Из какого дистрибутива ставили систему?
Альт Стартеркит 10 Гиперикум - выше есть скриншот же.
« Последнее редактирование: 09.06.2024 07:53:19 от GrishaDm »