Автор Тема: FMXLinux (Delphi 12.1)  (Прочитано 400 раз)

Оффлайн vpnc

  • Начинающий
  • *
  • Сообщений: 5
FMXLinux (Delphi 12.1)
« : 16.05.2024 00:23:22 »
Добрый день!

не получается запускать проекты скомпилированные в Delphi 12.1 / FMXLinux в "Альт Образование" 10.2
ошибки при запуске:

./myapp: /lib64/libc.so.6 version 'GLIBC_2.34' not found (required by ./myapp)
./myapp: /lib64/libc.so.6 version 'GLIBC_2.33' not found (required by ./myapp)

проекты созданные в предыдущих версиях фреймворка работают. Я так понимаю в системе установлен glibc 2.32.
Можно откуда-то установить 2.34?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 957
    • Домашняя страница
    • Email
Re: FMXLinux (Delphi 12.1)
« Ответ #1 : 16.05.2024 11:49:37 »
Только перейдя на нестабильный Sisyphus или дождаться p11.
Андрей Черепанов (cas@)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 345
Re: FMXLinux (Delphi 12.1)
« Ответ #2 : 16.05.2024 14:04:45 »
Может глупый вопрос - но подскажите, если знаете: почему до сих пор выбирают Delphi, а не, скажем, Free/Object Pascal и Lazarus? Что-то не может наша отечественная IDE? Или есть много программ, написанных на той, и они не совместимы? Попытался поиском найти - есть ли в Delphi инструменты тестировщика - и понял, что 1 компания пишет IDE и по сути там ничего такого нету. Однако всё равно выбирают Delphi. Кто-то в России работает на пиндосов? Я знаю и учебных заведениях его проходят, и в НИИ некоторых на нём пишут.
Из ранних продуктов Borland самым, на мой взгляд, перспективным для быстрого входа был турбобейсик (и книга-справочник по нему идеально написана Торховым). Но он, увы, заглох ещё в ДОСе. Паскаль же, наоборот, успешно развился. И Delphi, на удивление, остался.

Оффлайн vpnc

  • Начинающий
  • *
  • Сообщений: 5
Re: FMXLinux (Delphi 12.1)
« Ответ #3 : 16.05.2024 16:24:41 »
Только перейдя на нестабильный Sisyphus или дождаться p11.

спасибо за информацию!



Оффлайн vpnc

  • Начинающий
  • *
  • Сообщений: 5
Re: FMXLinux (Delphi 12.1)
« Ответ #4 : 04.06.2024 22:57:56 »
по FMXLinux, проблема решается перекомпиляцией проекта с SDK от Linux cо старой версией GLIBC, например Ubuntu 20.04 (Glibc 2.29). После этого проект получается запускать в Альт.