Автор Тема: Какие пакеты нужны для GUI KDE5?  (Прочитано 635 раз)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Попытался поставить KDE5 под ALT Starterkit 10 (Hypericum). Сама платформа вроде стоит, но не появилось ни пунктов в меню, ни GUI.
Запускаю kde5 в терминале и... ничего. Хэлп у неё не работает в этой версии.
Не подскажете, кто знает - какие пакеты должны быть установлены для запуска GUI KDE5?
[a@lureenvoy ~]$ kde5 --help
exec: help not available in this version
[a@lureenvoy ~]$

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #1 : 16.05.2024 23:30:28 »
apt-get install kde5-big

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #2 : 17.05.2024 05:28:55 »
Спасибо. Установил и в меню "Системные" появился "Discover". Но похоже проблема решена не полностью. Установил пару приложений там. В меню не появляются. Работают некорректно.
Приведу пример с игрой Bovo (наверно ещё что-то надо установить какую-нибудь доску наподобие xboard или что-то где-то включить?). Установил. В меню не появилась. Нашёл поиском, запускаю - GUI есть - игры самой нет (см. вложение). При нажатии "Начать игру" ничего не происходит.
« Последнее редактирование: 17.05.2024 05:39:51 от GrishaDm »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 956
    • Домашняя страница
    • Email
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #3 : 17.05.2024 06:35:26 »
Спасибо. Установил и в меню "Системные" появился "Discover". Но похоже проблема решена не полностью. Установил пару приложений там. В меню не появляются. Работают некорректно.
Приведу пример с игрой Bovo (наверно ещё что-то надо установить какую-нибудь доску наподобие xboard или что-то где-то включить?). Установил. В меню не появилась. Нашёл поиском, запускаю - GUI есть - игры самой нет (см. вложение). При нажатии "Начать игру" ничего не происходит.
Из flathub установлена?
Андрей Черепанов (cas@)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #4 : 17.05.2024 18:26:06 »
Установлена из меню Discover. Причём не когда-то там, а вот прямо сейчас - установил, перезагрузился - пытаюсь запустить и... ничего. И точно также несколько приложений других тоже попробовал.
« Последнее редактирование: 17.05.2024 18:28:43 от GrishaDm »

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #5 : 17.05.2024 21:14:31 »
Установлена из меню Discover. Причём не когда-то там, а вот прямо сейчас - установил, перезагрузился - пытаюсь запустить и... ничего. И точно также несколько приложений других тоже попробовал.
Из под той графической оболочки, которая шла со Стартеркитом - тоже не запускаются?

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #6 : 18.05.2024 02:13:06 »
А как её там запустить?
Скажем, Bovo  не появилась в меню. А Pentobi установил в Discover и появилась в меню Starterkit, запускается. Правда я не силён в играх и проверить не могу - работает ли корректно.
То есть я хочу сказать, что есть какие приложения KDE5, которые в Discover устанавливаются, а в меню Альлинукса не появляются, при запуске их из командной строки - работают некорректно, переустановка из Discover не помогает.
Предположу, что что-то где-то либо не доустановлено, либо не включены какие-то настройки.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #7 : 18.05.2024 14:19:26 »
А как её там запустить?
При запуске системы, на этапе выбора пользователя и ввода пароля. Если, конечно, графических оболочек установлено несколько.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #8 : 07.06.2024 22:27:14 »
Ещё несколько программ установилось из Discover, но не появились в меню. От чего это вообще зависит? Некоторые даже поиском искал - не нашёл.
Если нет описания этой панели управления - наверно остаётся только тестировать методом "чёрного ящика". Подключать файловый сканер и смотреть при установке - что и куда пишется. А потом искать разницу - в каких случаях корректно устанавливается, а в каких - нет.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #9 : 07.06.2024 22:45:20 »
Ещё несколько программ установилось из Discover, но не появились в меню. От чего это вообще зависит?
Может зависеть от того, какие графические оболочки установлены и от их настроек.

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 503
  • ненужная строка
    • Найдётся всё
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #10 : 10.06.2024 15:50:13 »
Предположу, что что-то где-то либо не доустановлено, либо не включены какие-то настройки.
KDE не запущен.

Или запускайте:
Код: (bash) [Выделить]
kde5 bovo
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #11 : 10.06.2024 16:41:18 »
kde5 bovo
Спасибо. Так действительно работает. А почему в меню операционки не появляется и нельзя запустить просто "bovo"? Одни программы, установленные из меню "Discover", появляется ярлык в меню операционки и запускаются, а другие - нет и запускаются только вот так (и то не факт что все, это ещё надо проверить). От чего это зависит и есть ли возможность как-то узнать это до установки и повлиять не это?
« Последнее редактирование: 11.06.2024 01:21:44 от GrishaDm »

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #12 : 10.06.2024 16:45:24 »
KDE не запущен.
[a@lureenvoy ~]$ kde5
[a@lureenvoy ~]$ bovo
bash: bovo: команда не найдена
А в таком варианте он тоже не запущен?
Также не менее интересен вот такой вариант - GUI игры запускается, а сама игра нет (попробуйте начать там новую игру):
[a@lureenvoy ~]$ kde5
[a@lureenvoy ~]$ /usr/lib/kf5/bin/bovo
« Последнее редактирование: 10.06.2024 16:56:49 от GrishaDm »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 299
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #13 : 10.06.2024 19:16:05 »
В запущенном сеансе KDE должно быть:

$ echo $PATH
/var/cache/ruby/gemie/bin:/home/writer/bin:/usr/bin:/bin:/usr/local/bin:/usr/games:/usr/lib/kf5/bin:/usr/lib/kf5/bin:/usr/lib/kf5/bin

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Re: Какие пакеты нужны для GUI KDE5?
« Ответ #14 : 11.06.2024 01:15:09 »
У меня почему-то не было. Пришлось добавить export PATH="$PATH:/usr/lib/kf5/bin" из-под юзера и из-под root. Кстати почему он у вас 3 раза?