Автор Тема: Невозможно получить http://ftp.altlinux.org/pub/distributions/ALTLinux/p10/branc  (Прочитано 1014 раз)

Оффлайн NickM

  • Завсегдатай
  • *
  • Сообщений: 596
Уважаемые, здравствуйте!

Кто в теме, что бы это значило?

Ошибку увидел сегодня.

# apt-get update
Получено: 1 http://ftp.altlinux.org p10/branch/x86_64 release [4223B]
Получено: 2 http://ftp.altlinux.org p10/branch/noarch release [2844B]
Получено: 3 http://ftp.altlinux.org p10/branch/x86_64-i586 release [1665B]
Получено 8732B за 0s (116kB/s).
Найдено http://ftp.altlinux.org p10/branch/x86_64/classic pkglist
Найдено http://ftp.altlinux.org p10/branch/x86_64/classic release
Найдено http://ftp.altlinux.org p10/branch/noarch/classic pkglist
Найдено http://ftp.altlinux.org p10/branch/noarch/classic release
Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic pkglist
Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  libwayland-client libwayland-cursor libwayland-egl
3 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 6661B/47,8kB архивов.
После распаковки потребуется дополнительно 4128B дискового пространства.
Продолжить? [Y/n] y
Получено: 1 http://ftp.altlinux.org p10/branch/x86_64/classic libwayland-egl 4:18.1.0-alt1:p10+286499.200.7.1@1641898396 [6661B]
Получено 1B за 0s (30B/s).
Невозможно получить http://ftp.altlinux.org/pub/distributions/ALTLinux/p10/branch/x86_64/RPMS.classic/libwayland-egl-18.1.0-alt1.x86_64.rpm  Несовпадение размера
E: Получить некоторые архивы невозможно. Попробуйте ввести команду apt-get update или добавить параметр --fix-missing.

Сервер из starterkit'ов, ранее был обновлен с p9 до p10:
# cat /etc/os-release
NAME="starter kit"
VERSION="p10 (Hypericum)"
ID=altlinux
VERSION_ID=p10
PRETTY_NAME="ALT Starterkit (Hypericum)"
ANSI_COLOR="1;33"
CPE_NAME="cpe:/o:alt:starterkit:p10"
HOME_URL="http://en.altlinux.org/starterkits"
BUG_REPORT_URL="https://bugs.altlinux.org/"
BUILD_ID="starter kit p10 (Hypericum)"

Вопрос вызывает конечно не сама ошибка, а слово "wayland" в пакете, ведь у Меня сервер изначально был установлен без DE/ WM.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 689
  • Sunny 273 RUS crew
Много кто сейчас может хотеть какие-нибудь графические библиотеки. apt-cache whatdepends покажет, кто их хочет.

Оффлайн NickM

  • Завсегдатай
  • *
  • Сообщений: 596
Хмм, что-то действительно имеется:

# apt-cache whatdepends libwayland-egl | grep -i gtk
  libwxGTK3.1-gl-3.1.5-alt1:p10+282388.200.1.1@1628625830
  snes9x-gtk-1.60-alt2:sisyphus+228891.100.1.1@1556879701
  libwebkit2gtk-2.32.4-alt1:p10+284327.2740.7.2@1632434256
  libgtk4-4.4.1-alt1:p10+289899.1600.6.1@1638978473
  libgtk+3-3.24.31-alt1:p10+292094.300.4.2@1640364392

# rpm -qa | grep -i gtk
gtk-update-icon-cache-3.24.31-alt1.x86_64
gtk+3-themes-incompatible-3.20-alt3.noarch
libgtk+2-locales-2.24.33-alt1.noarch
libgtk+3-schemas-3.24.31-alt1.noarch
libgtk+3-3.24.31-alt1.x86_64
libgtk+3-gir-3.24.31-alt1.x86_64
libgtk+2-2.24.33-alt1.x86_64

Хмм, в установленных оказался как минимум следующий:
libgtk+3-3.24.31-alt1