Автор Тема: Помогите разобраться с зависимостями для Postgres 10 на 9-ю платформу  (Прочитано 295 раз)

Оффлайн amambrozii

  • Начинающий
  • *
  • Сообщений: 2
Добрый день всем.

Помогите, пожалуйста, разобраться с зависимостями для Postgres 10. Пытаюсь поставить на 9-ю платформу.
Дистрибутив от 1С содержит несколько rpm, которые по очередности пакетов, насколько я понимаю,
требуют сначала поставить postgresql10-1c-libs-10.19-2.el7.x86_64.rpm
Но когда начинаю его ставить
rpm -i postgresql10-1c-libs-10.19-2.el7.x86_64.rpm

выдает
error: Failed dependencies:
        libcrypto.so.10(libcrypto.so.10)(64bit) is needed by postgresql10-1c-libs-10.19-2.el7.x86_64
        libssl.so.10(libssl.so.10)(64bit) is needed by postgresql10-1c-libs-10.19-2.el7.x86_64
        openssl-libs >= 1.0.2k is needed by postgresql10-1c-libs-10.19-2.el7.x86_64

а скачать принудительно из репозитория - не знаю где их взять, везде есть libcrypto.so.10()(64bit)
но его уже поставил. есть  libssl.so.10()(64bit) - его тоже поставил.

Еще потом вспомнил, что есть еще apt-get, но он таких тоже не находит, например
apt-get install 'libcrypto.so.10(libcrypto.so.10)(64bit)'
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package libcrypto.so.10(libcrypto.so.10)(64bit)

Собственно, подозреваю, что эти зависимости надо как-то по-другому устранить, но не пойму как.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 1 422
  • Дмитрий/Dmitry/德米特里/दिमित्री
выдает
error: Failed dependencies:
        libcrypto.so.10(libcrypto.so.10)(64bit) is needed by postgresql10-1c-libs-10.19-2.el7.x86_64
        libssl.so.10(libssl.so.10)(64bit) is needed by postgresql10-1c-libs-10.19-2.el7.x86_64
        openssl-libs >= 1.0.2k is needed by postgresql10-1c-libs-10.19-2.el7.x86_64
А у Вас версии этих пакетов совпадают c версиями в выводе?

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 1 422
  • Дмитрий/Dmitry/德米特里/दिमित्री
Собственно, подозреваю, что эти зависимости надо как-то по-другому устранить, но не пойму как.
Можно попробовать перепаковать Postgres 10
https://docs.altlinux.org/ru-RU/alt-workstation/9.2/html/alt-workstation/epm--chapter.html
« Последнее редактирование: 05.04.2022 18:59:43 от gosts 87 »

Оффлайн amambrozii

  • Начинающий
  • *
  • Сообщений: 2
А у Вас версии этих пакетов совпадают c версиями в выводе?
я не могу понять, где эти пакеты скачать - у меня их нет.

Можно попробовать перепаковать Postgres 10
Спасибо, попробую.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 1 422
  • Дмитрий/Dmitry/德米特里/दिमित्री
я не могу понять, где эти пакеты скачать - у меня их нет.
Обычно все зависимости подгружаются вместе с устанавливаемым пакетом, но бывают и случаи, когда что-то не устанавливается. Например, пакет для Федоры вряд-ли встанет в Альт.
https://www.altlinux.org/RPM-repair

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 839
Но когда начинаю его ставить
rpm -i postgresql10-1c-libs-10.19-2.el7.x86_64.rpm
устанавливать сторонние (не из репозитория, а отдельным файлом) пакеты лучше с помощью apt-get, чтобы подтянул зависимости при необходимости:
apt-get install ./postgresql10-1c-libs-10.19-2.el7.x86_64.rpm./ перед именем файла обязательно (при условии, что он лежит в текущем каталоге, либо указать полный путь), чтобы apt-get понял, что это локальный файл, а не имя пакета из репозитория

ЗЫ. Не помню, насчет p9, но в p10 есть готовая сборка postgres с патчами для 1С : пакет postgresql13-1C
Попробуйте на p9 поискать:  apt-cache search postgres 1c
« Последнее редактирование: 05.04.2022 21:19:27 от Александр Ерещенко »

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 1 422
  • Дмитрий/Dmitry/德米特里/दिमित्री
ЗЫ. Не помню, насчет p9, но в p10 есть готовая сборка postgres с патчами для 1С : пакет postgresql13-1C
Для p10 - есть: https://packages.altlinux.org/ru/p10/srpms/postgresql13-1C/
Для p9 - нет. Можно попросить, чтобы собрали.
« Последнее редактирование: 05.04.2022 21:46:53 от gosts 87 »