Автор Тема: etoken  (Прочитано 4825 раз)

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 354
etoken
« : 24.02.2013 12:52:05 »
Подскажите пожалуйста, совместим ли "обычный"  usb eToken от aladdin c simply linux?

Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 088
  • Кто ищет, тот найдёт.
Re: etoken
« Ответ #1 : 24.02.2013 13:09:18 »

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 354
Re: etoken
« Ответ #2 : 24.02.2013 13:17:32 »
Эту новость я как раз видел.. У меня "простой" етокен, не ГОСТ-овский..
Что нужно установить чтобы система его "увидела"?


Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 088
  • Кто ищет, тот найдёт.
Re: etoken
« Ответ #3 : 24.02.2013 13:24:40 »
А чем ГОСТовский отличается от не ГОСТовского ? По-моему, и в том и другом случае нужно ПО, которое позволяет использовать данное оборудование в любой системе.

Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 088
  • Кто ищет, тот найдёт.
Re: etoken
« Ответ #4 : 24.02.2013 13:30:49 »
На сайте открыл первый попавшийся не ГОСТовский токен http://www.aladdin-rd.ru/catalog/etoken/anywhere/details. Поддержка linux, как и macos там значится. А ваш токен какой ?

Оффлайн sb

  • Мастер
  • ***
  • Сообщений: 8 088
  • Кто ищет, тот найдёт.
Re: etoken
« Ответ #5 : 24.02.2013 13:34:51 »
Другими словами, разработчик должен заявлять совместимость с той или иной ОС и предоставлять ПО для использования (если необходимо). Для вашего варианта токена что-нибудь указано на сайте производителя ?

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 354
Re: etoken
« Ответ #6 : 24.02.2013 13:37:46 »
А какое нужно установить ПО на symplyLinux?
Под windows я использую PKI клиент,  скачанный  с сайта аладдин. В списке поддерживаемых linux дистрибутивов на сайте аладдин, альлинукс отсутствует. На сайте альтлинукса заявлена совместимость.

У меня - eToken PRO Java non def ISD
Набор драйверов и дополнительных утилит, обеспечивающий работу с электронными ключами eToken.
Поддерживаемые операционные системы:
Red Hat Enterprise 5.2 (32/64-бит);
CentOS 5.2 (32/64-бит);
SUSE Linux Enterprise 10.3 (32-бит);
Fedora 9 (32-бит);
Ubuntu 9.04 (32-бит).

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 160
  • Sunny 273 RUS crew
Re: etoken
« Ответ #7 : 24.02.2013 13:38:10 »
Эту новость я как раз видел.. У меня "простой" етокен, не ГОСТ-овский..
Вот тут есть кое-что про eToken:
http://www.altlinux.org/Alfabank_eToken

Что касается новости, на сколько вижу, там упоминается Альт Линукс СПТ. Надо бы уточнить, за счёт чего достигнута совместимость, и попало ли соответствующее ПО в публичные репозитарии.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 768
    • Домашняя страница
    • Email
Re: etoken
« Ответ #8 : 24.02.2013 14:05:40 »
А какое нужно установить ПО на symplyLinux?
pkiclient-*.rpm для вашей архитектуры и то, что он попросит. Правда, после его установки перестают запускаться программы Qt (кроме клиента eToken) на Linux, но это уже мелочи, правда?
Андрей Черепанов (cas@)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 768
    • Домашняя страница
    • Email
Re: etoken
« Ответ #9 : 24.02.2013 14:07:15 »
Надо бы уточнить, за счёт чего достигнута совместимость, и попало ли соответствующее ПО в публичные репозитарии.
pcsc-lite как платформа есть в репозитории. А pkiclient (собственно библиотека и обвязка) является проприетарным и потому распространяется производителем.
Андрей Черепанов (cas@)

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 160
  • Sunny 273 RUS crew
Re: etoken
« Ответ #10 : 24.02.2013 14:58:52 »
А pkiclient (собственно библиотека и обвязка) является проприетарным и потому распространяется производителем.
То есть, в плане pkiclient, написанное на wiki актуально ? Или, всё же, у них появилась сборка rpm-ки, которая не ломает ПО на qt4 ?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 16 768
    • Домашняя страница
    • Email
Re: etoken
« Ответ #11 : 24.02.2013 15:20:44 »
Надо удалить файл из /etc/ld.so.conf.d/
Андрей Черепанов (cas@)

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 6 160
  • Sunny 273 RUS crew
Re: etoken
« Ответ #12 : 24.02.2013 15:43:05 »
Надо удалить файл из /etc/ld.so.conf.d/
Если его просто удалить, перестают работать gui-приложения для токена (из этой же rpm-ки ставятся), которые с этими старыми библиотеками собраны. Вообще, они не всегда нужны, но, если нужны, надо враперами их обкладывать, как на wiki написано.