Автор Тема: Поддержка NVIDIA в разных дистрибутивах [решено]  (Прочитано 8297 раз)

Оффлайн Centuriones

  • Завсегдатай
  • *
  • Сообщений: 157
  • Инженегр
ruslandh, отдельное спасибо за то что возитесь со мной, может бытья увижу свет в конце тоннеля...

Вот что выдает мне команда

[root@host-118 ~]# rpm -qa | grep nvidia
nvidia_glx_185.18.36-185.18.36-alt71
nvidia_glx_173.14.20-173.14.20-alt54
nvidia_glx_common-185.18.36-alt71
nvidia_glx_96.43.13-96.43.13-alt44
kernel-modules-nvidia-std-def-185.18.36-alt2.132638.14
[root@host-118 ~]#

Извините за наглость, можно объяснить на пальцах как сделать так чтобы при выборе в acc проприетарного драйвера все работало (нормально стартовал x-сервер)и изображение не смещалось?
Для вашей видеокарты в случае применения проприетарных драйверов - очень проблематично. Есть две серии legacy-драйверов: 71хх и 96хх. Вам нужны драйвера, обычно обозначаемые как 71хх, когда по вашему выводу у вас самые "слабые" - 96.43.13, обозначаемые 96хх. Здесь их просто-напросто нет. Ваши драйвера вот эти: http://www.nvidia.ru/object/linux_display_ia32_71.86.13_ru.html
Вот список видеокарт, поддерживаемых ими:
GeForce 3 series: Ti, Ultra, GTS/Pro
GeForce 256 series: 256, 256 DDR
TNT / TNT2 series: RIVA TNT, RIVA TNT2 Model 64/Model 64 Pro, Aladdin TNT2, RIVA TNT2/TNT2 PRO, RIVA TNT2 Ultra
Riva 128 PCI series: Riva 128/128ZX
Riva 128 AGP series: Riva 128 AGP
Vanta series: Vanta/Vanta LT
Quadro 2 Pro series: Quadro2 Pro
(Вашу видеокарту я выделил).

А вот что поддерживают драйвера серии 96хх (в вашем случае 96.43.13):
GeForce 4 MX series: MX 420, MX 4000, MX 440SE (AGP 8X), MX 440-SE, MX Integrated GPU, MX 460, MX 420 (AGP 8X), MX 440 (AGP 8X), MX 440
Quadro NVS series: NVS 295, NVS 420, NVS 50, NVS 290, NVS 440, NVS 285, NVS 280, NVS 450, NVS 210, NVS 55/280 PCI
Quadro 4 Go series: 500 GoGL, 550 XGL, 700 GoGL
Quadro 2 Go series: MXR/EX/Go
GeForce 4 Ti series: Ti 4200, Ti 4800 SE, Ti 4800, Ti 4200 (AGP 8X), Ti 4600, Ti 4400
GeForce 2 series: Ti 200, GeForce3, Ti 500
Quadro 2 MXR series: Quadro2 MXR/EX/Go

Вашей видеокарты NVIDIA Riva TNT2 Model 64 / Model 64 Pro здесь нет.
Иными словами: у вас выход только в использовании драйверов "nv", но не будет поддержки OpenGL и 3D, или устанавливать их самостоятельно из Сизифа (они там есть).

Вам нужно вот это: http://sisyphus.ru/ru/srpm/nvidia_glx_src_71.86.11 или это: http://sisyphus.ru/ru/srpm/nvidia_glx_src_71.86.13

Проконсультируйтесь, как их правильно установить оттуда (не буду советовать, т.к. с из Сизифа сам никогда не делал установок).

P.S. Чуть не забыл: поищите их через Синаптик. Может они есть в бранче.
P.P.S. Честно говоря, когда заходит вопрос о драйверах, то всегда вначале надо выяснять: а какие драйвера нужны для моего железа и выяснить это на сайте производителя.
« Последнее редактирование: 27.03.2010 14:12:44 от Centuriones »
«Programming is like sex: one mistake and you have to support it for the rest of your life.» (C) Rickard Andersson, PunBB Developer.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 764
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
nvidia_glx_71.86.11 - требует, что-бы модуль был ядра 71.86.11, а он, как я понял, уже не собирается (чисто технически).

ne_spit

  • Гость
Цитировать
устанавливать их самостоятельно из Сизифа (они там есть).

Вам нужно вот это: http://sisyphus.ru/ru/srpm/nvidia_glx_ или это: http://sisyphus.ru/ru/srpm/nvidia_glx_src_71.86.13

Проконсультируйтесь, как их правильно установить оттуда (не буду советовать, т.к. с из Сизифа сам никогда не делал установок).
Собственно говоря я сам додумался до этого, и сразу же вспомнив про эту тему, поспешил сюда - ну и немножко опоздал, устанавливал так:
1. Подключил Сизиф - http://forum.altlinux.org/index.php/topic,2531.msg69196.html#msg69196
2. Удалил лишние и ненужные nvidia_glx_ - при удалении сразу же и удалились ненужные модули ядра.
3. Установил nvidia_glx_71.86.11 - при установке вручную добавил загрузку нужного модуля. Всё делал через Synaptic - искал там на буквы nvidia, точно не помно как называется, вроде бы kernel-modules-nvidia-glx-71
4. Вышел их Х
5.  emacs /etc/X11/xorg.conf от root
6. Cменил в секции Drivers nv на nvidea
7. Запустил Х-ы. Честно сказать я тут даже перестраховался и вообще перезагрузился.
8. Для проверки вошёл в acc и проверил - драйвер загружен правильно.
9. Утилита nvidia-bug-report.sh перестала сообщать о проблемах совместимости разных версий драйверов и о сообщение об ошибке (EE) исчезло.


Но самое подлое тут в том, что игры как были медленные, так и остались так-же медленные.
Super Tux 2 на 4.1 летал на ура, а на p5 дико тормозит.

Из-за чего теперь могут "тормозить" игрушки?
« Последнее редактирование: 27.03.2010 16:36:22 от ne_spit »

ne_spit

  • Гость
# rpm -qa | grep nvidia
nvidia_glx_common-195.36.15-alt77
nvidia_glx_71.86.13-71.86.13-alt44
kernel-source-nvidia-718611-71.86.11-alt43.qa1
nvidia-settings-190.53-alt1
nvidia_glx-devel-195.36.15-alt77
nvidia-settings-devel-190.53-alt1
nvidia-xconfig-190.53-alt1
nvidia_glx_71.86.11-71.86.11-alt43.qa1

Меня вот эти строчки чего то смущают nvidia_glx_common-195.36.15-alt77

nvidia-settings-190.53-alt1
nvidia_glx-devel-195.36.15-alt77
nvidia-settings-devel-190.53-alt1
nvidia-xconfig-190.53-alt1
Может быть их удалить надо?

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Ну что ж... Отрицательный результат - тоже результат... :-( И даже отсутствие результата - тоже результат. :-)
Именно с 71 серией драйверов я и пытался экспериметировать.
А вот и обещанный копипаст с Альт Линукс LiveCD 4.0.2

[root@localhost ~]# rpm -qa | grep nvidia
kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10
nvidia_glx_common-100.14.19-alt40
nvidia-xconfig-1.0-alt8
nvidia-settings-100.14.19-alt1
nvidia_glx_71.86.01-71.86.01-alt36
nvidia_glx_96.43.01-96.43.01-alt35
[root@localhost ~]#

При этом все замечательно работает!
Неужели нечто подобное нельзя сделать в пятой версии? Или все-таки можно, но очень сложно?

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Упс. Пока писал сообщение - появился ответ от ne_spit.
Спасибо за информацию. Сечас попробую...

ne_spit

  • Гость
Подожди, yar007 . подожди. Может быть надо по этому типу просто сделать?
# rpm -qa | grep nvidia
kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10
nvidia_glx_common-100.14.19-alt40
nvidia-xconfig-1.0-alt8
nvidia-settings-100.14.19-alt1
nvidia_glx_71.86.01-71.86.01-alt36
nvidia_glx_96.43.01-96.43.01-alt35

Удалить всё и поставить как в 4.1? Как думаешь?

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
 :D
Поздно.....
Начал уже делать по твоему пути... Но в сизифе не оказалось модуля kernel-modules-nvidia-glx-71....
Что дальше не знаю... Кстати, модуля 
kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10 как в 4.1 там тоже нет :-(

Тупик?

ne_spit

  • Гость
:D
Поздно.....
Начал уже делать по твоему пути... Но в сизифе не оказалось модуля kernel-modules-nvidia-glx-71....
Что дальше не знаю... Кстати, модуля  
kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10 как в 4.1 там тоже нет :-(

Тупик?
Значит сделал чего-то неправильно, к примеру вот же у меня как
# rpm -qa | grep nvidia
kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10
nvidia_glx_common-100.14.19-alt40
nvidia-xconfig-1.0-alt8
nvidia-settings-100.14.19-alt1
nvidia_glx_71.86.01-71.86.01-alt36
nvidia_glx_96.43.01-96.43.01-alt35

По поводу kernel-modules-nvidia-glx-71... - сейчас посмотрел там оказывается kernel_source. Вообщем если проще то надо удалить все левые, и поставить все правильные, с поиском по nvidia/
« Последнее редактирование: 27.03.2010 17:26:27 от ne_spit »

ne_spit

  • Гость
Интересно, что будет если из репозитария 4.1 поставить  и другие пакеты для nvidia как в 4.1?
« Последнее редактирование: 27.03.2010 17:24:42 от ne_spit »

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Дык модуля kernel-modules-nvidia-std-smp-100.14.19-alt3.132626.10 - там тоже нет. А без него, я так понмаю, работать не будет.
 ???

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
Извините за, может быть, глупый вопрос: а может из kernel-source можно сделать kernel-module ?

ne_spit

  • Гость
Устанавливал отсюда?
Цитировать
это: http://sisyphus.ru/ru/srpm/nvidia_glx_src_71.86.11 или это: http://sisyphus.ru/ru/srpm/nvidia_glx_src_71.86.13
Или по этой инструкции - http://forum.altlinux.org/index.php/topic,2531.msg69196.html#msg69196?

Вот так сделал - http://fly.osdn.org.ua/~drool/branch_4.1_i586.png?
« Последнее редактирование: 27.03.2010 17:48:01 от ne_spit »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 764
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Обычно все три модуля входят пакет  старшей версии.

Оффлайн yar007

  • Завсегдатай
  • *
  • Сообщений: 60
    • Email
нет. Все делал через синаптик. Но ведь по этим ссылкам тоже нет kernel-modules, правда? А без них, как я уже предположил выше, работать не будет.