Автор Тема: Не работает Блютус на регулярке с КДЕ4  (Прочитано 3977 раз)

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
В "Параметрах системы" --> "Блютус" - надпись - "Адаптеры Bluetooth не найдены."

Регулярка отсюда https://forum.altlinux.org/index.php?topic=36963.msg292726#msg292726

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
Продублировал сообщение о недостатке в багзилле https://bugzilla.altlinux.org/show_bug.cgi?id=32449

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 760
    • Домашняя страница
    • Email
На регулярки и не клались bluez pulseaudio-bluez
И не запускалась служба bluetooth
И rfkill надо смотреть на предмет софтового или железного lock.
Андрей Черепанов (cas@)

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
На регулярки и не клались bluez pulseaudio-bluez
И не запускалась служба bluetooth
И rfkill надо смотреть на предмет софтового или железного lock.
Глянул с Синаптике, bluez уже установлен (может, подтянул его при первоначальной доустановке пакетов к регулярке), pulseaudio-bluez только что установил; как запустить службу bluetooth?

По rfkill вот такой вывод:
[root@localhost ~]# rfkill
Usage:  rfkill [options] command
Options:
        --version       show version (0.5)
Commands:
        help
        event
        list [IDENTIFIER]
        block IDENTIFIER
        unblock IDENTIFIER
where IDENTIFIER is the index no. of an rfkill switch or one of:
        <idx> all wifi wlan bluetooth uwb ultrawideband wimax wwan gps fm nfc

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 760
    • Домашняя страница
    • Email
Документацию по ОС и командам читать лень? :)

service bluetooth start
rfkill list
Андрей Черепанов (cas@)

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
service bluetooth start
rfkill list
Похоже, взлетело:

[root@localhost ~]# service bluetooth start
[root@localhost ~]# rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
[root@localhost ~]#

Спасибо, сейчас гляну, стартанёт ли после перезагрузки.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Что-то с блютуз точно не так. У меня есть внешний адаптер и веюнутренний. Если вставить внешний адаптер, то сразу все работает, можно его убирать и работать с внутренним. А без этого - не работает.  Хотя никаких модулей ядра внутренний адаптер не требует - все тот-же usb - блютуз.

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
Что-то с блютуз точно не так. У меня есть внешний адаптер и веюнутренний. Если вставить внешний адаптер, то сразу все работает, можно его убирать и работать с внутренним. А без этого - не работает.  Хотя никаких модулей ядра внутренний адаптер не требует - все тот-же usb - блютуз.
Заковыристо. У меня попроще - "service bluetooth start" от рута - и работает. Только после перезагрузки не стартует. Смотрю на системный монитор, там после вручную запущенного блютуса есть 3 процесса. Думаю, какой из этих 3 скриптов прописывать в автозагрузке ("Запуск и завершение" в Параметрах системы), так как просто "service bluetooth start" прописать не получается, выскакивает "service bluetooth start" не является абсолютным путём."
« Последнее редактирование: 29.08.2016 21:02:34 от Иволгин »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Ну это через systemd enable делай. У меня стартует, но толку мало.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
ps мне картика с телефона не видна.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 760
    • Домашняя страница
    • Email
chkconfig bluetooth on

Читайте документацию!
Андрей Черепанов (cas@)

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
Рецидив проблемы в осеннем стартерките с КДЕ4, на этот раз не работает
service bluetooth startРаньше (в регулярке) после команды сразу появлялся значок в лотке, сейчас - тишина.

По rfkill вывод такой:
[root@localhost ~]# rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
Блютуса нет.

По автостарту,
chkconfig bluetooth on
включал, не стартует после перзагрузки.

Пакеты bluez, pulseaudio-bluez установлены.

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 989
    • Email
А что в зимнем?
--
Michael Shigorin

Оффлайн Иволгин

  • Давно тут
  • **
  • Сообщений: 238
А что в зимнем?
В зимнем всё норм, спасибо.