Автор Тема: Canon LBP 3010 в alt linux 64 bit  (Прочитано 6845 раз)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Canon LBP 3010 в alt linux 64 bit
« : 24.11.2011 20:45:17 »
Добрый день!
Установил себе на компьютер Alt Linux Kdesctop 6.0 64 bit и возникла проблема по подключению принтера LBP 3010 к этой системе.
Раньше работал под убунтой, там был специальный скрипт для установки этого принтера. Нет ли чего подобного для Alt Linux ?
Или в ручную как установить с учетом особенностей 64 bit-ой системы?

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #1 : 25.11.2011 07:57:19 »
Добрый день!
Установил себе на компьютер Alt Linux Kdesctop 6.0 64 bit и возникла проблема по подключению принтера LBP 3010 к этой системе.
Раньше работал под убунтой, там был специальный скрипт для установки этого принтера. Нет ли чего подобного для Alt Linux ?
Или в ручную как установить с учетом особенностей 64 bit-ой системы?
1. http://www.canon.ru/Support/Consumer_Products/products/printers/Laser/i-SENSYS_LBP3010.aspx?type=download&page=1
На 64-bit есть RPM - пробуйте.

2. Через модуль в ЦУС->Печать.
3. Или через браузер http://localhost:631.
Сноси Винду, переходи на Линукс ! :)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #2 : 25.11.2011 17:22:02 »
Добрый день!
Установил себе на компьютер Alt Linux Kdesctop 6.0 64 bit и возникла проблема по подключению принтера LBP 3010 к этой системе.
Раньше работал под убунтой, там был специальный скрипт для установки этого принтера. Нет ли чего подобного для Alt Linux ?
Или в ручную как установить с учетом особенностей 64 bit-ой системы?
1. http://www.canon.ru/Support/Consumer_Products/products/printers/Laser/i-SENSYS_LBP3010.aspx?type=download&page=1
На 64-bit есть RPM - пробуйте.

2. Через модуль в ЦУС->Печать.
3. Или через браузер http://localhost:631.

RPM скачал, установил, но вот как дальше настраивать не знаю

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #3 : 25.11.2011 17:28:07 »
RPM скачал, установил, но вот как дальше настраивать не знаю
2. Через модуль ЦентрУправленияСистемой->Печать.
3. Или через браузер http://localhost:631.
Возможно, что-то появилось в меню...
Сноси Винду, переходи на Линукс ! :)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #4 : 25.11.2011 17:43:07 »

Возможно, что-то появилось в меню...
[/quote]
Сейчас еще раз попробовал переустановить эти пакеты через консоль и выяснилось, что ругается на зависимость и ищет libpopt.so.0, где можно скачать?

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #5 : 25.11.2011 17:47:25 »
Цитировать
Возможно, что-то появилось в меню...
Сейчас еще раз попробовал переустановить эти пакеты через консоль и выяснилось, что ругается на зависимость и ищет libpopt.so.0, где можно скачать?

скачал popt-1.14-2rt.x86_64.rpm установил, в этом пакете должна содержаться libpopt.so.0, но её по прежнему не находит установщик?


Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #6 : 25.11.2011 17:47:58 »
Сейчас еще раз попробовал переустановить эти пакеты через консоль и выяснилось, что ругается на зависимость и ищет libpopt.so.0, где можно скачать?
Приводите вывод сюда. Полностью!
Сноси Винду, переходи на Линукс ! :)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #7 : 25.11.2011 17:49:17 »
Приводите вывод сюда. Полностью!

[root@comp-phenom-ii-8250c0 ~]# rpm -ivh /home/udjin/Загрузки/CAPT_Printer_Driver_for_Linux_V220_uk_EN/64-bit_Driver/RPM/cndrvcups-capt-2.20-1.x86_64.rpm
ошибка: неудовлетворенные зависимости:
        libpopt.so.0   нужен для cndrvcups-capt-2.20-1
[root@comp-phenom-ii-8250c0 ~]#

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #8 : 25.11.2011 17:51:17 »
[root@comp-phenom-ii-8250c0 ~]# rpm -ivh .../cndrvcups-capt-2.20-1.x86_64.rpm
ошибка: неудовлетворенные зависимости:
        libpopt.so.0   нужен для cndrvcups-capt-2.20-1
[root@comp-phenom-ii-8250c0 ~]#
Во-первых:
apt-get install <ваш пакет RPM>
Сноси Винду, переходи на Линукс ! :)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #9 : 25.11.2011 17:52:16 »
Цитировать
Во-первых:
apt-get install <ваш пакет RPM>

apt-get install /home/udjin/Загрузки/CAPT_Printer_Driver_for_Linux_V220_uk_EN/64-bit_Driver/RPM/cndrvcups-capt-2.20-1.x86_64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано cndrvcups-capt для '/home/udjin/Загрузки/CAPT_Printer_Driver_for_Linux_V220_uk_EN/64-bit_Driver/RPM/cndrvcups-capt-2.20-1.x86_64.rpm'
You might want to run `apt-get --fix-broken install' to correct these:
Следующие пакеты имеют неудовлетворенные зависимости:
  cndrvcups-capt: Требует: libpopt.so.0 но пакет не может быть установлен
  libpopt: Вытесняет: popt
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #10 : 25.11.2011 17:55:41 »
apt-get install .../cndrvcups-capt-2.20-1.x86_64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Ответ на поверхности:
Цитировать
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
Сноси Винду, переходи на Линукс ! :)

Оффлайн udjin1981

  • Начинающий
  • *
  • Сообщений: 7
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #11 : 25.11.2011 18:00:55 »
[root@comp-phenom-ii-8250c0 ~]# apt-get install /home/udjin/Загрузки/CAPT_Printer_Driver_for_Linux_V220_uk_EN/64-bit_Driver/RPM/cndrvcups-capt-2.20-1.x86_64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано cndrvcups-capt для '/home/udjin/Загрузки/CAPT_Printer_Driver_for_Linux_V220_uk_EN/64-bit_Driver/RPM/cndrvcups-capt-2.20-1.x86_64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  cndrvcups-capt: Требует: libpopt.so.0 но пакет не может быть установлен
[b]E: Извините, `битые' пакеты[/b]


очень странно, файлы скачаны с офф. сайта

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #12 : 30.11.2011 20:53:46 »
Смотрите в этой статье: http://unixforum.org/index.php?s=9747883e51c10482a824238a693c39b7&showtopic=16544&st=180&p=1063415&#entry1063415
Все хорошо расписано. Если что-то непонятно - спрашивайте здесь.
Сам скоро буду устанавливать такой принтер на Simply Linux 6 32-bit, потом могу отписаться.
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Сноси Винду, переходи на Линукс ! :)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 093
    • Email
Re: Canon LBP 3010 в alt linux 64 bit
« Ответ #14 : 02.12.2011 12:40:11 »
Ну, вот ;)
Сейчас установил на два компьютера принтер Canon LBP 3010B на Simply Linux 6.0.0. Расписывать что обозначает та, или иная команда не буду, все есть в приведенных выше ссылках, да и в интернете много чего есть по этому поводу. Так что напишу просто команды, которые давал в терминале. Может пригодится для тех, кто не захочет разбираться во всем этом, а просто возьмет готовый вариант, т.е. новичкам.

Предварительно я скачал с сайта драйвера версии 2.20.

apt-get install cndrvcups-common-2.20-1.i386.rpm
apt-get install cndrvcups-capt-2.20-1.i386.rpm
service cups restart
/usr/sbin/lpadmin -p LBP3010 -m CNCUPSLBP3050CAPTK.ppd -v ccp://localhost:59687 -E
/usr/sbin/ccpdadmin -p LBP3010 -o /dev/usb/lp0
Далее нужно подправить файл /etc/modprobe.d/blacklist-cups, закомментировать строку
#blacklist usblpА в этом файле /etc/init.d/ccpd, нужно где-н. вначале вставить эти строки
# ccpd          Canon Printing for CUPS
# chkconfig:    2345 65 35
# description:  Canon Printing for CUPS
# processname:  ccpd
# config:       /etc/ccpd.conf
Все, потом ещё дать две команды
service ccpd start
chkconfig ccpd on

После этого перезагрузиться.

Теперь можно сделать ваш принтер устройством для печати по умолчанию. Заходим ЦентрУправленияСистемой->Печать. Правой кнопкой по принтеру и выбираем использовать по умолчанию. Подтвердить, нажав ОК. Все.

На 64-bit думаю все точно также делается, только RPM нужно брать из папки 64-bit.
« Последнее редактирование: 28.07.2012 19:52:33 от berkut_174 »
Сноси Винду, переходи на Линукс ! :)