Автор Тема: Установка драйверов для принтера Pantum P2207  (Прочитано 1284 раз)

Оффлайн zemlykov

  • Начинающий
  • *
  • Сообщений: 1
Перечитал здесь много, в wiki. Как только не пробовал ставить и запускать, разнес файлы из архива, выполнял установку из папки терминалом. Название в списке к установке отображается, модель можно выбрать (конкретно моего нет), на значке восклицательный знак. Драйвера самсунга пробовал. Решение проблемы видимо не будет. Принтер другой покупать дорого, буду другой linux ставить. Альт образование 9
« Последнее редактирование: 09.11.2021 12:58:25 от zemlykov »

Оффлайн klark973

  • Завсегдатай
  • *
  • Сообщений: 660
  • Неспящий саппорт
Не поверите, но драйвер Pantum P2207 (RPM для Альт 9) выложен на сайте производителя!  :-)
To moan or to solve -- that is the question!

Оффлайн igorigor76

  • Завсегдатай
  • *
  • Сообщений: 645
Не поверите, но драйвер Pantum P2207 (RPM для Альт 9) выложен на сайте производителя!  :-)
Сегодня искал не нашел. Только deb. Можете дать ссылку.

Оффлайн predator2018

  • Давно тут
  • **
  • Сообщений: 89
Трудами гугла всезнающего https://disk.yandex.ru/d/I9_ToUAyLs-2OA
« Последнее редактирование: 06.09.2022 15:38:46 от predator2018 »

Оффлайн igorigor76

  • Завсегдатай
  • *
  • Сообщений: 645
Спасибо!!! Завтра буду пробовать.

Оффлайн igorigor76

  • Завсегдатай
  • *
  • Сообщений: 645
P9, X86_64
Цитировать
Installing "/opt/pantum-drivers-cups-1.1.74-1.el7.x86_64.rpm"
ошибка: Неудовлетворенные зависимости:
   avahi-libs нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   cups(x86-64) нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   dbus-libs нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   gnutls нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   keyutils-libs нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   libjpeg.so.8()(64bit) нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   libjpeg.so.8(LIBJPEG_8.0)(64bit) нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   libusbx нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   lz4-libs нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   nettle нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   pcre2 нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   qpdf нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
   xz-libs нужен для pantum-drivers-cups-1.1.74-1.el7.x86_64
2 или 3 пакета нашлись. Остальные нет.
Установил с параметром --nodeps (какой-то пакет пришлось удалять, конфликтовал).

Принтер заработал.
« Последнее редактирование: 07.09.2022 12:35:43 от igorigor76 »

Оффлайн predator2018

  • Давно тут
  • **
  • Сообщений: 89
Установил с параметром --nodeps (какой-то пакет пришлось удалять, конфликтовал).

Принтер заработал.
Хорошо что есть параметр --nodeps :-D
В реале в разных дистрибутивах названия одних и тех же или аналогичных бинарных пакетов могут отличаться. Часть пакетов, как я понимаю нужны для косметического оформления работы принтера.... можно обходиться и веб интерфейсом cups.
В идеале конечно нужен родной пакет,  а не от RHELа  или хотя бы исходники, но я их так же не нашёл. В результатах поиска находился некий ресурс на github, но живым его найти не удалось.