Автор Тема: Bumblebee: отображается только часть экрана [решено]  (Прочитано 6086 раз)

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 303
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
$ apt-cache search intel | grep i586 | grep dr
i586-libdrm - Userspace interface to kernel DRM service
i586-libdrm-poulsbo - Direct Rendering Manager runtime library (for Poulsbo)
i586-libdrm-poulsbo-devel - Direct Rendering Manager development package
i586-libva-driver-intel - VDPAU-based backend for VA API
i586-xorg-dri-intel - Intel DRI driver
i586-xorg-drv-intel - Intel integrated graphics chipsets

Оффлайн Hoblin

  • Давно тут
  • **
  • Сообщений: 32
    • Email
Так, у меня другая картина. Это у вас p7 или сизиф?

$ apt-cache search xorg-dri
xorg-dri-intel - Intel DRI driver
xorg-dri-swrast - Mesa software rendering libraries
xorg-dri-radeon - ATI RADEON DRI driver
i586-xorg-dri-swrast - Mesa software rendering libraries

Подключены p7-репы: x86_64, x86_64-i586, noarch

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 32 303
  • Учиться .... Телепатами не рождаются, ими ....
    • Email


Оффлайн Hoblin

  • Давно тут
  • **
  • Сообщений: 32
    • Email
Да. Багнутый репозиторий (локальное зеркало). Включил стандартные репозитории из alt.list и установил пакет.
Запуск через primusrun заработал. Судя по тому, что всё стало запускаться, работает не в режиме слайд-шоу и ноут стал греться, nvidia работает!

Большое спасибо всем за участие, терпение и помощь!

Может быть, недостающий пакет i586-xorg-dri-intel должен вытягиваться примусом при установке? Или это специфика работы моей карточки? Стоит багу повесить?
« Последнее редактирование: 29.06.2015 16:24:41 от Hoblin »

Оффлайн БарсSc

  • alt linux team
  • ***
  • Сообщений: 1 089
  • Intel_i7/nVidia_Optimus, AMD Ryzen 3 2200
Может, подскажете что-нибудь про механику работы primus'а?

В какой момент он должен переключать видеокарту, почему этого может не происходить? Почему glxinfo, glxgears и часть игрушек работают так, как будто всё хорошо?(см. update)

Что касается самой ошибки, то драйвер i965 находится в xorg-dri-intel, но 32-битного пакета я не нашёл, так что
ibGL error: dlopen /usr/lib/X11/modules/dri/i965_dri.so failed (/usr/lib/X11/modules/dri/i965_dri.so: cannot open shared object file: No such file or directory)вполне ожидаемо, при условии, что драйвер зачем-то примусу нужен.

Update: вот так запускается RogueLegacy:
libGL: OpenDriver: trying /usr/lib64/X11/modules/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib64/X11/modules/dri/i965_dri.so
С какой картой оно работает в итоге, интересно...
Сама технология оптимус на этом построена, обработкой графики занимается нвидиа, а выводом на экран интел.

Может быть, недостающий пакет i586-xorg-dri-intel должен вытягиваться примусом при установке? Или это специфика работы моей карточки? Стоит багу повесить?
Повешайте, чтоб не забылось, я добавлю в зависимости primus-а на выходных.
« Последнее редактирование: 29.06.2015 16:41:22 от BarsSc »

Оффлайн Hoblin

  • Давно тут
  • **
  • Сообщений: 32
    • Email
Повешайте, чтоб не забылось, я добавлю в зависимости primus-а на выходных.

Повесил

Оффлайн БарсSc

  • alt linux team
  • ***
  • Сообщений: 1 089
  • Intel_i7/nVidia_Optimus, AMD Ryzen 3 2200
Добавил в инструкцию необходимые пакеты для запуска 32-х разрядных приложений через primus.