Автор Тема: проблема при переносе ALT K 8.2 на другой раздел  (Прочитано 547 раз)

Оффлайн lhome

  • Начинающий
  • *
  • Сообщений: 8
    • Email
Большой привет всем.
Попробовал перенести ALT K 8.2 на более быстрый жесткий диск (на том же компьютере).
Вроде рутинная операция. На той же машине установлен дебиан, загружаюсь в него, копирую (cp -a) файлы с раздела альта на нужный раздел, поправляю указания на разделы в fstab у нового альта, запускаю на дебьяне grub, он находит все три ядра, делаю grub-install, перезагружаюсь, в меню видны все три системы.
Дальше непонятки. Дебьян и исходный альт грузятся нормально. Вместо нового альта (в меню grub помечен как альт на другом разделе) почему-то грузится альт с исходного раздела.  Тогда прописываю в дебьяне lilo.config и устанавливаю загрузчик lilo. По-прежнему дебьян и исходный альт грузятся нормально, но новый альт зависает в самом начале на двух пингвинах. Может дело в том, что исходный альт был установлен в раздел ext4, а был скопирован в раздел ext3? Меняю ext3 на ext4 (tune2fs -O extents,uninit_bg,dir_index <девайс раздела>) с соответствующими поправками в файлах fstab у трех систем. Обновляю lilo. Перезагрузки так же: дебьян и исходный альт работают, скопированный зависает на двух пингвинах. Может быть, надо initrd пересобрать в копии альта? Из интереса попробовал, не получилось, если дело в нем, то как его правильно пересобрать.
Спасибо за внимание!


П.С.
На всякий случай вот фрагмент из lilo.conf дебьяна :

# вот это копия, зависает на пингвинах:
image="/mnt/pool/boot/vmlinuz"
        label="alt_sda6"
        initrd="/mnt/pool/boot/initrd.img"
        root="UUID=ae611b81-a0b7-4e9f-a2b7-a31c4d4c6bea" #/dev/sda6
        addappend="quiet"
        read-only

# Исходный альт, в нем все пучком:
image="/mnt/40Gb/boot/vmlinuz"
        label="alt_sdb1"
        initrd="/mnt/40Gb/boot/initrd.img"
        root="UUID=471da9b2-0211-4003-a65f-a8cf1967896d" #/dev/sdb1
        addappend="quiet"
        read-only
« Последнее редактирование: 28.09.2017 10:40:14 от lhome »