Автор Тема: Почему нет реакции на обратную связь, в частности по обновлению libreoffice  (Прочитано 2138 раз)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 165
    • Домашняя страница
    • Email
А я из чего, по-вашему, делал?
Андрей Черепанов (cas@)

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 678
  • Sunny 273 RUS crew
Остальные, при этом не настолько критичны. Альт позиционируется как система для школ... Так почему один из основных пакетов вечно приходится месяцами выпрашивать на обновление?
И да, если причина на сейчас - название функций по-русски, то это странная причина для немедленного обновления. Вот если бы эксплоит какой нашёлся с запуском исполняемого файла, это вот было бы серьёзно.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 678
  • Sunny 273 RUS crew
И я написал какие там проблемы. Пока ничего не изменилось. Проблемы остались. Что от меня ещё нужно?
Напишите мейнтейнеру пакета напрямую. Обрисуйте положение дел и объясните, что ситуация критическая.
Тут ещё беда в том, что новому LO могут требоваться какие-то новые библиотеки, Ява, Питон какой-нибудь и т.п., которых нет в p8, а прямой бакпорт их из Сизифа поломает кучу других пакетов. В такой ситуации обновление будет просто неподъёмным. В Сизифе условно допустимо сделать разлом временный, а вот в стабильном бранче это сильно хуже.

Оффлайн tema

  • alt linux team
  • ***
  • Сообщений: 2 068
    • Email
И да, если причина на сейчас - название функций по-русски, то это странная причина для немедленного обновления. Вот если бы эксплоит какой нашёлся с запуском исполняемого файла, это вот было бы серьёзно.
Я в отдельной теме потом, если интересно опишу подробно почему это критично вот прямо сейчас. Это связано именно с внедрением. Всё продолжается отсюда: https://forum.altlinux.org/index.php?topic=40245.0
Правда с офисом я и раньше предвидел, что будут аргументы, поэтому уже давно прошу об этом обновлении. Но вот сейчас прямо уже получены бумажки, которые всю мою нескольколетнюю работу по внедрению пустят псу под хвост. Есть люди, которые начали просто пробивать возможность установки виндов без оглядки на все постановления и им удаётся найти поддержку в департаментах. Я пока держусь, но если через месяц от ФАС придёт конкретный ответ, что всё подтверждено, то у меня просто не будет аргументов. Я даже не могу сказать, что могу обучать детей формулам в электронной таблице по учебникам по ФГОС, т.к. там просто нет русских названий функций. Не говоря уже про всё остальное. Но пока это один из камней преткновения. С остальными я, возможно, справлюсь. С бухгалтерией я справился с помощью wine от Виталия Липатова (спасибо ему!)

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 678
  • Sunny 273 RUS crew
Есть люди, которые начали просто пробивать возможность установки виндов без оглядки на все постановления и им удаётся найти поддержку в департаментах.
То есть, они привязались именно прямо к русскоязычным функциям ? А им нельзя про ГОСТ в ответ написать ? Правда, MSO, вроде как, это тоже поддерживает... В смысле OpenDocument. Не знаю только, на сколько хорошо.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 953
Посмотрел на сизифную либру:
$ libreoffice5.4 --version
LibreOffice 5.4.2.2.0 40m0(Build:2)
На вид всё отлично. Можно из неё сделать task? Я его поставлю на компьютеры и проверю

В теории сизифная либра src.rpm должна в p8 собраться,
$ rpm -ba --target i586 ~/RPM/SPECS/libreoffice.spec
Платформы для сборки: i586
Сборка для платформы i586
ошибка: неудовлетворенные зависимости сборки:
        ant нужен для LibreOffice-5.4.2.2-alt1
        apache-commons-httpclient нужен для LibreOffice-5.4.2.2-alt1
        apache-commons-lang нужен для LibreOffice-5.4.2.2-alt1
        bsh нужен для LibreOffice-5.4.2.2-alt1
        cppunit-devel нужен для LibreOffice-5.4.2.2-alt1
        flex нужен для LibreOffice-5.4.2.2-alt1
        gcc-c++ нужен для LibreOffice-5.4.2.2-alt1
        git-core нужен для LibreOffice-5.4.2.2-alt1
        gperf нужен для LibreOffice-5.4.2.2-alt1
        gst-plugins1.0-devel нужен для LibreOffice-5.4.2.2-alt1
        hunspell-en нужен для LibreOffice-5.4.2.2-alt1
        imake нужен для LibreOffice-5.4.2.2-alt1
        kde4libs-devel нужен для LibreOffice-5.4.2.2-alt1
        libGConf-devel нужен для LibreOffice-5.4.2.2-alt1
        libGLEW-devel нужен для LibreOffice-5.4.2.2-alt1
        libabw-devel нужен для LibreOffice-5.4.2.2-alt1
        libbluez-devel нужен для LibreOffice-5.4.2.2-alt1
        libcdr-devel нужен для LibreOffice-5.4.2.2-alt1
        libclucene-core-devel нужен для LibreOffice-5.4.2.2-alt1
        libcmis-devel нужен для LibreOffice-5.4.2.2-alt1
        libcups-devel нужен для LibreOffice-5.4.2.2-alt1
        libdbus-glib-devel нужен для LibreOffice-5.4.2.2-alt1
        libetonyek-devel нужен для LibreOffice-5.4.2.2-alt1
        libexpat-devel нужен для LibreOffice-5.4.2.2-alt1
        libexttextcat-devel нужен для LibreOffice-5.4.2.2-alt1
        libfreehand-devel нужен для LibreOffice-5.4.2.2-alt1
        libglm-devel нужен для LibreOffice-5.4.2.2-alt1
        libgtk+2-devel нужен для LibreOffice-5.4.2.2-alt1
        libgtk+3-devel нужен для LibreOffice-5.4.2.2-alt1
        libharfbuzz-devel нужен для LibreOffice-5.4.2.2-alt1
        libhunspell-devel нужен для LibreOffice-5.4.2.2-alt1
        libhyphen-devel нужен для LibreOffice-5.4.2.2-alt1
        libjpeg-devel нужен для LibreOffice-5.4.2.2-alt1
        liblangtag-devel нужен для LibreOffice-5.4.2.2-alt1
        liblcms2-devel нужен для LibreOffice-5.4.2.2-alt1
        libldap-devel нужен для LibreOffice-5.4.2.2-alt1
        liblpsolve-devel нужен для LibreOffice-5.4.2.2-alt1
        libmspub-devel нужен для LibreOffice-5.4.2.2-alt1
        libmwaw-devel нужен для LibreOffice-5.4.2.2-alt1
        libmythes-devel нужен для LibreOffice-5.4.2.2-alt1
        libneon-devel нужен для LibreOffice-5.4.2.2-alt1
        libnss-devel нужен для LibreOffice-5.4.2.2-alt1
        libodfgen-devel нужен для LibreOffice-5.4.2.2-alt1
        liborcus-devel нужен для LibreOffice-5.4.2.2-alt1
        libpoppler-cpp-devel нужен для LibreOffice-5.4.2.2-alt1
        libredland-devel нужен для LibreOffice-5.4.2.2-alt1
        libsane-devel нужен для LibreOffice-5.4.2.2-alt1
        libvigra-devel нужен для LibreOffice-5.4.2.2-alt1
        libvisio-devel нужен для LibreOffice-5.4.2.2-alt1
        libwpd10-devel нужен для LibreOffice-5.4.2.2-alt1
        libwpg-devel нужен для LibreOffice-5.4.2.2-alt1
        libwps-devel нужен для LibreOffice-5.4.2.2-alt1
        libxslt-devel нужен для LibreOffice-5.4.2.2-alt1
        mdds-devel нужен для LibreOffice-5.4.2.2-alt1
        pentaho-reporting-flow-engine нужен для LibreOffice-5.4.2.2-alt1
        perl-Archive-Zip нужен для LibreOffice-5.4.2.2-alt1
        postgresql-devel нужен для LibreOffice-5.4.2.2-alt1
        python3-dev нужен для LibreOffice-5.4.2.2-alt1
        xorg-cf-files нужен для LibreOffice-5.4.2.2-alt1
        libavahi-devel нужен для LibreOffice-5.4.2.2-alt1
        libpagemaker-devel нужен для LibreOffice-5.4.2.2-alt1
        boost-signals-devel нужен для LibreOffice-5.4.2.2-alt1
        libe-book-devel нужен для LibreOffice-5.4.2.2-alt1
        junit нужен для LibreOffice-5.4.2.2-alt1
        java-1.8.0-openjdk-devel нужен для LibreOffice-5.4.2.2-alt1
        libgtk+3-gir-devel нужен для LibreOffice-5.4.2.2-alt1
        libCoinMP-devel нужен для LibreOffice-5.4.2.2-alt1
        libzmf-devel нужен для LibreOffice-5.4.2.2-alt1
        libstaroffice-devel нужен для LibreOffice-5.4.2.2-alt1
        libepoxy-devel нужен для LibreOffice-5.4.2.2-alt1
        libmysqlcppconn-devel нужен для LibreOffice-5.4.2.2-alt1
        libmysqlclient-devel нужен для LibreOffice-5.4.2.2-alt1
        libtelepathy-devel нужен для LibreOffice-5.4.2.2-alt1
        doxygen нужен для LibreOffice-5.4.2.2-alt1
        libxmlsec1-nss-devel нужен для LibreOffice-5.4.2.2-alt1
        libgpgme-devel нужен для LibreOffice-5.4.2.2-alt1
$ rpm -qa|grep rpm|grep 'build\|macros'
rpm-macros-alterator-4.25-alt1.M80P.1
rpm-build-4.0.4-alt101.M80P.1
rpm-build-xdg-0.2-alt1
rpm-build-python-0.36.8-alt1
rpm-build-gir-0.7.2-alt3
rpm-macros-alternatives-0.4.5-alt1.1
rpm-macros-fillup-1.42-alt6.qa1
rpm-build-perl-0.84-alt9.M80P.1
librpmbuild-4.0.4-alt101.M80P.1

но у меня все системы 32 бит, - 64 не соберётся.

И жрёт оно под сборку как не в себя:
$ cat lo-build-depends.txt|awk '{print $1}' > lo-build-depends-pkgs.txt
# apt-get install $(</home/user/hlam/lo-build-depends-pkgs.txt)
...
0 будет обновлено, 368 новых установлено, 1 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 170MB/172MB архивов.
После распаковки потребуется дополнительно 799MB дискового пространства.
Продолжить? [Y/n] n
Прервано.
« Последнее редактирование: 10.11.2017 03:02:54 от Speccyfighter »