Автор Тема: Ошибка при установке Альт Образование 8.2 х64 на новый компьютер (и уже на 10.1)  (Прочитано 23776 раз)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 019
P.S. Для эксперимента на рабочей системе Альт-Образование обновился до сизифа, но ядро там меньше 4.15.

Там Skull подсказывает про более новое ядро.
У вас на фото идёт строка сообщения:
Не могу смонтировать корневую файловую систему на неизвестном блочном устройстве(0,0)

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
un-def там 4.17

Сделал так (в другом порядке не получилось):
  • установил 8.0
  • обновился и перешёл на ядро un-def
  • обновился до 8.2 и обновил ядро
  • перешел на сизиф
  • обновился и обновил ядро до 4.17
  • установил xorg-drv-amdgpu (изначально не было)

На 4.17 не загружается рабочий стол, даже с принудительными командами (xdriver=vesa nomodeset). Одна "мазня" на экране.
На предыдущей версии ядра включается, но только в графическом режиме (при загрузке "мазня" на экране, консоли потом такие же)

Попробовал перед загрузкой задать xdriver=amdgpu - не помогло.
Может еще чего-то не хватает для работы amdgpu?
Может mesa нужна? Как ее установить?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 651
    • Домашняя страница
    • Email
Mesa (libGL) уже стоит. И обновлена с переходом на Sisyphus.
Параметр ядра xdriver читается только установщиком. Для смены драйвера надо менять в Центре управления системой.
Андрей Черепанов (cas@)

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
Для смены драйвера надо менять в Центре управления системой
Пробовал загружаться в предыдущее ядро 4.14.61 (автоматом идет vesa) и выставлять в ЦУСе amdgpu. Потом загружаюсь в новом ядре 4.17.14 (не грузится ничего - виснет в самом начале).

Такое ощущение, что не только с процессором (видео) проблема, а с чипсетом тоже: WiFi не подключается, а в recovery mode журнал показывает ошибки драйверов (см.фото).

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 651
    • Домашняя страница
    • Email
Для смены драйвера надо менять в Центре управления системой
Пробовал загружаться в предыдущее ядро 4.14.61 (автоматом идет vesa) и выставлять в ЦУСе amdgpu. Потом загружаюсь в новом ядре 4.17.14 (не грузится ничего - виснет в самом начале).

Такое ощущение, что не только с процессором (видео) проблема, а с чипсетом тоже: WiFi не подключается, а в recovery mode журнал показывает ошибки драйверов (см.фото).
На новое ядро переходите с помощью update-kernel ? Учтите, не все модули собраны под него.
Лог использования amdgpu надо в /var/log/Xorg.0.log смотреть.
Андрей Черепанов (cas@)

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
На новое ядро переходите с помощью update-kernel ?

Именно так (другой способ еще не знаю).

Оффлайн scodal

  • Начинающий
  • *
  • Сообщений: 1
проц тоже райзер 3 и ошибка та же, раньше линуксом не пользовались, пришло письмо от минсвязи 27го декабря, типо устанавливайте ПО с реестра, раз эта версия ОС не работает , то какую операционку качать из реестра? раз по этой поддержки нет)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 651
    • Домашняя страница
    • Email
altlinux.org/Regular
Но это не в реестре. Можно обновить ядро до сизифного un-def.
Андрей Черепанов (cas@)

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 203
какую операционку качать из реестра? раз по этой поддержки нет)
Calculate  ;-D там в portage много чего хорошего есть...
Но там будут проблемы с cryptopro...

Оффлайн NickM

  • Завсегдатай
  • *
  • Сообщений: 822
какую операционку качать из реестра? раз по этой поддержки нет)
Calculate  ;-D там в portage много чего хорошего есть...
Но там будут проблемы с cryptopro...

и с многим еще чем, все же Gentoo не каждый разработчик поддерживает...

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
Наконец-то дождался Р9.

На Р9 проблем с драйверами нет. Все работает.  :-)

Решено!

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
Проблема возродилась после замены материнской платы на одном из моноблоков.
Новая мать: GA-A320M-H (биос обновлен)
Остальное железо перекочевало в нее.
Ни-в-какую по-хорошему не хотело ставиться Альт Образование 10.
С учетом предыдущих граблей удалось установить ее при подстановке в параметры загрузки с флешки "xdriver=vesa nomodeset"

После установки загрузка графики не идет - черный экран.

После некоторых экспериментов, получилось загрузить моноблок, только когда в файл grub.cfg добавили волшебное словечко "nomodeset" в конец нужной строки.
Видео автоматом определяется так: см.фото (как не пытался поменять, возвращается к этому виду)

По итогу моноблок, как бы, работает.
Грузится в графику, можно обновляться, но после простоя более 20 минут - намертво виснет графический экран (всякие заставки и отключения монитора убраны): мышка двигается, но кнопки и клавиатура не работают. Хотя, можно переключиться в другой экран терминала, где все Оk!
Если включить ютуб - оно показывает без проблем часами.

Подскажите, куда копать?
« Последнее редактирование: 22.09.2022 10:50:54 от OlegBB »

Оффлайн Антон Мидюков

  • alt linux team
  • ***
  • Сообщений: 4 986
  • antohami@
Ядро un-def устанавливать пробовали?

update-kernel -t un-def
reboot

Если из p10 также плохо, то из Сизифа:
apt-repo set sisyphus
apt-get update
update-kernel -t un-def
apt-repo set p10
apt-get update
reboot

Оффлайн буратино-42

  • Давно тут
  • **
  • Сообщений: 61
но после простоя более 20 минут - намертво виснет графический экран (всякие заставки и отключения монитора убраны)

Здесь две старейшие проблемы Альта.

1. невозможность отключения входа в режим энергосбережения монитора.
2. невозможность выхода из этого режима.

Первую проблему решить легче:

 надо, кроме панели настроек (дисплей, хранитель, менеджер питания),
  вручную выключить DPMS
   командой xset:
      xset s off
      xset -dpms
   и убедиться что DPMS отключено, командой
      xset q
   если это сработает
    (т.е. через 20 мин монитор не выключится)
     то прописать эти команды в файл выполняющийся при загрузке ОС.

Пример для дистрибутива Альт Симпли:
 
  https://forum.altlinux.org/index.php?topic=44503.msg354748

Оффлайн OlegBB

  • Давно тут
  • **
  • Сообщений: 110
Ядро un-def устанавливать пробовали?
Ничего не помогает:
- попробовал поменять ядро на un-def, в т.ч. из Сизифа;
- полностью перешел на Сизиф.

Официальная документация к материнской плате (когда ничего не помогает, наконец-то начинаешь ее читать) прямо говорит, что поддержки линукса и ему подобных НЕТ!  :-o

Будем работать над самой большой проблемой - моноблок при бездействии виснет.
На очереди манипуляции по советам от буратино-42.

P.S. Заметил, что запуск перешел на "runlevel=2" (мелькает эта строчка при запуске и это, вроде бы, однопользовательский режим). Пока не понял, как это произошло, но есть один плюс: при переходе в Ctrl+Alt+F2 и каких-то действиях в этой консоли, графический экран уходит в блокировку (а уже не висит намертво!). При возвращении в графику можно ввести пароль пользователя и продолжить работу.
« Последнее редактирование: 24.09.2022 15:11:47 от OlegBB »