Автор Тема: hp probook 470 G0 включается при закрывании крышки.  (Прочитано 485 раз)

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 332
    • Email
Ноутбук hp probook 470 G0 прекрасно работал на starterkit p9 mate. Потребовалось обновить браузеры, добавить памяти и заменить HDD на SSD, соответственно, обновить систему.

После установки starterkit p10 mate началось странное поведение при питании от батареи.

Выглядит это так. Открываем крышку, запускаем кнопкой питания, загружается система, хоть даже до DM, нажимаем кнопку питания и ноутбук нормально завершает работу системы и выключается, но при закрывании крышки он сам включается через пару секунд с закрытой крышкой.
Если сразу открыть крышку и выключить его кнопкой питания на экране POST, то он перестаёт реагировать на закрытие крышки.
Если это не отследить, то он просто вырабатывает всю энергию из батареи и отключается.
Если ноутбук включается и выключается при подключённом адаптере питания, то такого поведения не наблюдается.
Понимаю, что кто-то чего-то куда-то записывает в железо, но не понимаю кто и куда.

Перепробовал всё что нашёл.
Изменения в файле /etc/systemd/logind.conf, параметры раскомментированы и приведены к виду HandleLidSwitch=ignore, HandleLidSwitchExternalPower=poweroff, HandleLidSwitchDocked=poweroff, LidSwitchIgnoreInhibited=yes
Изменения в файле /etc/UPower/UPower.conf, параметр IgnoreLid=on
Не нашёл каталога /etc/acpi/

Теперь вопросы (уже не актуальны).
1) В какую сторону нынче стоит копать, кто сейчас управляет поведением Lid сенсора?
2) Как вообще отключить отслеживание системой состояния Lid сенсора?
« Последнее редактирование: 29.12.2022 20:12:13 от Nicom »

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 332
    • Email
Видимо придётся отковыривать магнит в крышке ноутбука, чтобы вообще небыло никакой реакции на закрытие/открытие. Жаль.

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 332
    • Email
Проблема оказалась не в Lid сенсоре, просто включение совпадало с закрытием крышки.
После выковыривания магнита решил проверить и не закрыл крышку, а ноутбук всё равно включился.

Если ноутбук загрузился до экрана логина, или произведён вход в графическую оболочку, и его выключить, неважно каким из способов, хоть через меню, хоть кнопкой питания, через 3 секунды после отключения он самостоятельно включается. И так по кругу.
Если выключить его кнопкой питания на этапе POST или в меню GRUB, то повторного включения не происходит.

Полагаю, что при загрузке системы, или при её завершении, стартует какая-то служба, которая чего-то записывает в железо, от чего ноутбук и включается сам.

В какую сторону копать?

Оффлайн trs

  • Давно тут
  • **
  • Сообщений: 282
Полагаю, что при загрузке системы, или при её завершении, стартует какая-то служба, которая чего-то записывает в железо, от чего ноутбук и включается сам.

В железо пишет драйвер (в Виндосе они называются «служба режима ядра», да). В р10 ядро как раз обновилось, в этой версии совершенно случайно могли что-то сломать. Так что может быть есть смысл попробовать установить ещё более новое ядро, un-def. Так же может быть дело в ACPI - по смыслу оно как раз «...Power Interface», но конкретнее пока не могу сказать. Иногда помогают шаманства из разряда добавить в параметры ядра acpi_osi="!Windows 2012" acpi_osi=Linux. В специфичных для HP драйверах (hp-wmi) не вижу ничего на тему wake. Полагаю, Вы перед отковыриванием магнитика и без советов посмотрели dmesg и journalctl -e и ничего интересного там не нашли.

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 332
    • Email
может быть есть смысл попробовать установить ещё более новое ядро, un-def.
Не помогло.
Иногда помогают шаманства из разряда добавить в параметры ядра acpi_osi="!Windows 2012" acpi_osi=Linux.
Тоже никакого влияния не оказало.
Вы перед отковыриванием магнитика и без советов посмотрели dmesg и journalctl -e и ничего интересного там не нашли.
К сожалению, я специализируюсь на ремонте электроники. Мне многое непонятно в выводе dmesg, да, там были какие-то сообщения от ACPI говорящие об ошибках, но и на других компьютерах я тоже увидел нечто подобное. Проблема, как оказалось, возникает не только при питании от аккумулятора, но и при питании от адаптера.

Спасибо Вам за проявленное внимание к проблеме, но, я должен сегодня увезти ноутбук к родственникам в другой населённый пункт. Сначала думал вернуть Starterkit p9, но решил попробовать свежий SimplyLinux, на нём, как оказалось, проблема не возникает.
К сожалению я не смогу продолжить поиск проблемы.

Спасибо и с Новым Годом!