Автор Тема: Ошибка обновления Рабочая станция 10.1  (Прочитано 1032 раз)

dango_

  • Гость
Полезно. С десяток пакетов вычистил, но они никаким боком ...
А если в лоб командой удаления без учета зависимостей:
rpm -e --nodeps yelp
Также см.:Команды_RPM
А потом:
apt-get reinstall mate-user-guide
чтобы скрипты дернули по зависимости установку yelp.

Оффлайн ovk

  • Давно тут
  • **
  • Сообщений: 134
Пробую:
root@ovk-pc lib]# rpm -e --nodeps yelp
[root@ovk-pc lib]# apt-get reinstall mate-user-guide
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
You might want to run `apt-get --fix-broken install' to correct these:
Следующие пакеты имеют неудовлетворенные зависимости:
  gparted: Требует: yelp
  mate-user-guide: Требует: yelp
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
[root@ovk-pc lib]# apt-get -f install
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Исправление зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  yelp
Следующие НОВЫЕ пакеты будут установлены:
  yelp
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 327 не будет обновлено.
Необходимо получить 0B/739kB архивов.
После распаковки потребуется дополнительно 2284kB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
1: yelp-40.3-alt1.1                     ################################# [100%]
Завершено.
[root@ovk-pc lib]# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Ошибка
Следующие пакеты имеют неудовлетворенные зависимости:
  mate-user-guide: Требует: yelp
E: Ошибка. Процедура pkgProblemResolver::Resolve вызвала остановку. Это может быть вызвано сохраняемыми пакетами.
[root@ovk-pc lib]# apt-get reinstall mate-user-guide
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
0 будет обновлено, 0 новых установлено, 1 пакетов будет переустановлено, 0 пакетов будет удалено и 327 не будет обновлено.
Необходимо получить 0B/9427kB архивов.
После распаковки потребуется дополнительно 0B дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Подготовка...                           ################################# [100%]
Обновление / установка...
1: mate-user-guide-1:1.26.1-alt1        ################################# [100%]
Завершено.
[root@ovk-pc lib]# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Ошибка
Следующие пакеты имеют неудовлетворенные зависимости:
  mate-user-guide: Требует: yelp
E: Ошибка. Процедура pkgProblemResolver::Resolve вызвала остановку. Это может быть вызвано сохраняемыми пакетами.
Попробую заморозить обновление mate-user-guide
Не получилось: Следующие пакеты имеют неудовлетворенные зависимости:
  mate-user-guide: Требует: yelp
E: Решить проблему невозможно. Вы потребовали сохранить пакеты с нарушенными зависимостями.
Пока больше идей нет. Надо изучать матчасть, как все это работает.

dango_

  • Гость
Пока больше идей нет. Надо изучать матчасть, как все это работает.
Пока да. Возможно, или сам способ не правилен, или не этот пакет ключевой.
А насчет матчасти вопрос: в каком месте сломалось?
Единственное, что общего у решивших проблему это удаление ключевого пакета.

Оффлайн ovk

  • Давно тут
  • **
  • Сообщений: 134
Если верить Синаптику, в системе у меня стоит последняя версия пакета mate-user-guide, от 14 июня, в репозитории эта же версия, при этом все работает, а обновление дистрибутива блокируется. Бред. Буду ждать, пока Иноземцев (Shrek) новую версию выпустит.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 8 143
E: Ошибка. Процедура pkgProblemResolver::Resolve вызвала остановку. Это может быть
Ещё два варианта.
1. Как эта фраза на английском выглядит? Если её погуглить.
2. А в /etc/apt/* ничего дополнительного на hold не поставлено?
В общем что-то странное.

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 787
  • Дмитрий/Dmitry/德米特里/दिमित्री

Оффлайн ovk

  • Давно тут
  • **
  • Сообщений: 134
1. Как эта фраза на английском выглядит? Если её погуглить.
2. А в /etc/apt/* ничего дополнительного на hold не поставлено?
По 1 смотрел, опять все ссылается на замороженные пакеты. Проверил конфиги - таких нет. Собственно, ставил на hold когда-то драйвер 304 нвидиа, пока он работал, и вчера mate-user-guide, но все убрал
https://forum.altlinux.org/index.php?topic=8284.0
Это касается сбоев после установки пакетов с игнорированием зависимостей, я до вчерашнего дня это не делал, кроме того apt-get --fix-broken install должен | исправляет эту ситуацию. Кроме того, в моем случае требуемый пакет в системе установлен. Вопрос к Знатокам: как проверяется наличие в системе нужного пакета - скриптом из пакета или из пакетного менеджера? Куда делается запрос - к базе или по адресу из устанавливаемого пакета?