Автор Тема: Странное поведение mount в разных дистрибутивах Альт рабочая станция 10  (Прочитано 724 раз)

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 429
Исходные данные:
КД AD: Альт СП 8 (c9f2)
Файловый сервер: Альт сервер 9.2
АРМ: Альт рабочая станция К 10.2 введена в домен, групповые политики включены.

Файловый сервер (smb.conf):
[global]
security = ads
realm = MIAC35.LOCAL
workgroup = MIAC35
netbios name = MLXFS1
template shell = /bin/bash
kerberos method = system keytab
wins support = no
winbind use default domain = yes
winbind enum users = no
winbind enum groups = no
template homedir = /home/MIAC35.LOCAL/%U
        idmap config * : range = 200000-2000200000
        idmap config * : backend = sss

machine password timeout = 0
server min protocol = NT1
client min protocol = NT1

printing = cups
printcap name = cups
load printers = no
cups options = raw

vfs objects = acl_xattr
inherit owner = yes
inherit acls = yes
inherit permissions = yes

[data]
    guest ok = no
    path = /share/data
    browseable = yes
    read only = no

Права:
# getfacl /share/data
getfacl: Removing leading '/' from absolute path names
# file: share/data
# owner: administrator
# group: domain\040admins
user::rwx
group::---
group:domain\040users:r-x
group:admin:rwx
mask::rwx
other::---

# getfacl /share/data/exchange/
getfacl: Removing leading '/' from absolute path names
# file: share/data/exchange/
# owner: administrator
# group: domain\040admins
# flags: ss-
user::rwx
group::rwx
group:samba:rwx
group:admin:rwx
group:monitoring:rwx
mask::rwx
other::---
default:user::rwx
default:group::rwx
default:group:samba:rwx
default:group:admin:rwx
default:group:monitoring:rwx
default:mask::rwx
default:other::---

Рабочая станция:

Доменный пользователь:
# id ant
uid=774401281(ant) gid=774400513(domain users) группы=774400513(domain users),774401110(statist),774401105(samba),100(users),36(vmusers),442(usershares),80(cdwriter),22(cdrom),81(audio),477(video),19(proc),83(radio),444(camera),71(floppy),498(xgrp),499(scanner),14(uucp),463(vboxusers),465(fuse),488(vboxadd),487(vboxsf)

Открываю Dolphin по пути: ~/net.drives/data/exchange/
Создаю каталог (с именем 12) - норм
Создаю пустой файл (qwe.txt) - норм
Открываю файл редактором и записываю в него данные - норм
Копирую любой файл с локального диска в ~/net.drives/data/exchange/ - норм
А вот при попытке скопировать имеющийся (например qwe.txt) в любой каталог (например 12) приводит к созданию пустого файла и зависанию операции (в уведомлениях значится что идет копирование 0% и всё)

autofs монтирует данную шару так:
//mlxfs1/data on /run/media/ant/drives/data type cifs (rw,relatime,vers=3.1.1,sec=krb5,cruid=774401281,cache=strict,username=root,uid=0,noforceuid,gid=0,noforcegid,addr=172.16.130.2,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,cifsacl,noperm,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=60,actimeo=1,closetimeo=1)

Далее в Konsole:
Удалил файл 0-го размера в 12

$ cp qwe.txt 12/
Убито

И ещё раз:
$ cp qwe.txt 12/
cp: переписать '12/qwe.txt'? y

Всё, процесс завис.

$ ps aux | grep qwe
ant        10730  0.0  0.0   6480   832 pts/1    D+   15:21   0:00 cp -i qwe.txt 12/

Килл не помогает:
$ kill 10730
$ ps aux | grep qwe
ant        10730  0.0  0.0   6480   832 pts/1    D+   15:21   0:00 cp -i qwe.txt 12/

Эксперимент проводился как на реальном так и виртуальном железе, результат один.
На Simply Linux 10.2 данная проблема не воспроизводится.
Разбаньте в телеге шакалы!!!

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 429
Выполнение на симпли и рабочей станции:
mount //mlxfs1/data /mnt -o rw,sec=krb5,cifsacl,noperm
Приводит к таким же результатам (На симпли копирование норм, на рабочей станции нет)
Разбаньте в телеге шакалы!!!

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 952
    • Домашняя страница
    • Email
Регрессия в ядре. Используйте старое или ядро un-def.
Андрей Черепанов (cas@)

Оффлайн KALIBR-10

  • Давно тут
  • **
  • Сообщений: 429
Регрессия в ядре. Используйте старое или ядро un-def.
После смены ядра на 5.10.198-std-def-alt1 проблема исчезла. До этого было ядро 6.1.72-un-def-alt1
Разбаньте в телеге шакалы!!!