Автор Тема: Установка wine-vanila 1.4 на p7  (Прочитано 1792 раз)

Оффлайн guzanovmax

  • Давно тут
  • **
  • Сообщений: 153
    • Email
Установка wine-vanila 1.4 на p7
« : 29.01.2014 10:53:43 »
Приветствую всех.
Дистрибутив Кентавр 7.0.
Задача: Нужно установить wine 1.4 для работы с NanoCAD. При запуске NanoCAD с помощью wine 1.7.5, который лежит в репах p7, не работают файловые диалоги. На форуме NanoCAD это подтверждается (т.е. нужен wine именно 1.4).

Я скачал версию wine 1.4 c "ftp://updates.etersoft.ru/pub/Etersoft/Wine-vanilla/1.4.0/ALTLinux/p6/" но не могу его установить:

Спойлер
[root@mts-sobolev wine-vanila-p6]# apt-get install *.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libwine-vanilla для 'libwine-vanilla-1.4.0-alt0.M60P.1.i586.rpm'
Выбрано libwine-vanilla-gl для 'libwine-vanilla-gl-1.4.0-alt0.M60P.1.i586.rpm'
Выбрано libwine-vanilla-twain для 'libwine-vanilla-twain-1.4.0-alt0.M60P.1.i586.rpm'
Выбрано wine-gecko для 'wine-gecko-1.4-alt0.M60P.1.i586.rpm'
Выбрано wine-vanilla для 'wine-vanilla-1.4.0-alt0.M60P.1.i586.rpm'
Следующие НОВЫЕ пакеты будут установлены:
  libwine-vanilla libwine-vanilla-gl libwine-vanilla-twain wine-gecko
  wine-vanilla
0 будет обновлено, 5 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 38,2MB архивов.
После распаковки потребуется дополнительно 143MB дискового пространства.
...
Хочет ставить и ставит версию 1.7.5 из р7. Посоветуйте, пожалуйста, как поставить wine-vanila 1.4

Спасибо

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Установка wine-vanila 1.4 на p7
« Ответ #1 : 29.01.2014 11:44:49 »
Удалить вручную wine 1.7.5, отключить официальные репозитории и обновить индексы.
Андрей Черепанов (cas@)

Оффлайн guzanovmax

  • Давно тут
  • **
  • Сообщений: 153
    • Email
Re: Установка wine-vanila 1.4 на p7
« Ответ #2 : 29.01.2014 11:55:59 »
Удалить вручную wine 1.7.5, отключить официальные репозитории и обновить индексы.
Удалить вручную я понимаю так: Полностью удалить пакеты wine через synaptic и папку .wine в домашней директории? Поправьте, если не прав
При таком подходе при последующем апгрейде системы (dist-upgrade) произойдет обновление wine до версии 1.7.5?
« Последнее редактирование: 29.01.2014 11:58:11 от guzanovmax »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Установка wine-vanila 1.4 на p7
« Ответ #3 : 29.01.2014 12:07:51 »
При таком подходе при последующем апгрейде системы (dist-upgrade) произойдет обновление wine до версии 1.7.5?
Если отключили основные репозитории, то и обновляться нечему.
Если их вернули, то поставьте *wine* на Hold в /etc/apt/apt.conf (как это сделано с kernel).
Андрей Черепанов (cas@)

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
Re: Установка wine-vanila 1.4 на p7
« Ответ #4 : 29.01.2014 12:15:13 »
При таком подходе при последующем апгрейде системы (dist-upgrade) произойдет обновление wine до версии 1.7.5?

Дополняя Skull'а:
При установленном wine v1.4 да.
Линки на инструкции hold:
http://www.altlinux.org/Hold
Hold пакета (Заблокировать версию пакета)

Оффлайн guzanovmax

  • Давно тут
  • **
  • Сообщений: 153
    • Email
Re: Установка wine-vanila 1.4 на p7
« Ответ #5 : 29.01.2014 15:18:14 »
К сожалению не ставится. Вот такая трабла:
[root@mts-sobolev wine-vanila-p6]# apt-get install *.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libwine-vanilla для 'libwine-vanilla-1.4.0-alt0.M60P.1.i586.rpm'
Выбрано libwine-vanilla-gl для 'libwine-vanilla-gl-1.4.0-alt0.M60P.1.i586.rpm'
Выбрано wine-gecko для 'wine-gecko-1.4-alt0.M60P.1.i586.rpm'
Выбрано wine-vanilla для 'wine-vanilla-1.4.0-alt0.M60P.1.i586.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  wine-vanilla: Требует: wine-gecko (= 1.4)
E: Извините, `битые' пакеты

Странно, ведь пакет wine-gecko присутствует

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 495
    • Домашняя страница
    • Email
Re: Установка wine-vanila 1.4 на p7
« Ответ #6 : 29.01.2014 15:26:26 »
А wine-gecko более новой версии не установлен?
Ставьте через rpm -Uvh *.rpm --oldpackage
Андрей Черепанов (cas@)