Автор Тема: Опубликованы образы регулярных сборок с Samba AD DC  (Прочитано 24999 раз)

Оффлайн hrurg

  • Завсегдатай
  • *
  • Сообщений: 22
то есть очень может статься, что не работает?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 641
    • Домашняя страница
    • Email
Там сообщается, что smb.conf мешает. Если покопаться, то найти решение можно. Скорее всего, нюансы конфигурации. При provision же рекомендуется удалять smb.conf. Вы пока его перенесите куда-нибудь. И попробуйте решение найти самостоятельно.
Андрей Черепанов (cas@)

Оффлайн Alex Volkov

  • Завсегдатай
  • *
  • Сообщений: 15
Вышла очередная версия с багфиксами:
https://www.samba.org/samba/history/samba-4.2.3.html
Задание обновится?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 641
    • Домашняя страница
    • Email
Когда tdb обновят. Я вчера багу с запросом повесил и в Фейсбуке написал.
Если до пятницы не будет, только в конце августа.
Андрей Черепанов (cas@)

Оффлайн Alex Volkov

  • Завсегдатай
  • *
  • Сообщений: 15
на слово "багу" можно было бы и ссыль повесить для удобства отслеживания ;-)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 641
    • Домашняя страница
    • Email
на слово "багу" можно было бы и ссыль повесить для удобства отслеживания ;-)
https://bugzilla.altlinux.org/show_bug.cgi?id=31141

С телефона это было сделать проблематично :)
Андрей Черепанов (cas@)

Оффлайн GoodSoul

  • Завсегдатай
  • *
  • Сообщений: 10
    • Email
Задание с недавнего времени перестало работать. http://git.altlinux.org/repo/132256/

С чем это связано и как на 7 платформе теперь обновлять самбу?

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 712
  • Кто ищет, тот найдёт.
С чем это связано и как на 7 платформе теперь обновлять самбу?
https://www.altlinux.org/%D0%9A%D0%B0%D1%80%D0%BC%D0%B0%D0%BD%D1%8B

Оффлайн GoodSoul

  • Завсегдатай
  • *
  • Сообщений: 10
    • Email
ААА! Спасайте! Обновился пакет libldb до версии 1.1.21, а Самбе нужно 1.1.20. Домен сломался, школа висит...


Седьмая платформа.

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
Возьмите 1.1.20 из архива, если не найдётся в /var/cache/apt -- см. тж. вики.

PS: fly.osdn.org.ua закончился, altlinux-p7-server-samba4.iso переложены в беты стартеркитов.
« Последнее редактирование: 16.09.2015 17:28:02 от gvy »
--
Michael Shigorin

Оффлайн GoodSoul

  • Завсегдатай
  • *
  • Сообщений: 10
    • Email
Проблему решил.
cd /var/cache/apt/archives
rpm -Uvh --force --oldpackage libldb_1.1.20-alt0.M70P.1_x86%5f64.rpm
сругался на пакет libldb_1.1.21-alt0.M70P.1_x86%5f64.rpm
rpm -Uvh --nodeps --oldpackage libldb_1.1.20-alt0.M70P.1_x86%5f64.rpm
rpm -Uvh --oldpackage python-module-pyldb_1.1.20-alt0.M70P.1_x86%5f64.rpm

Все! Спасибо большо за оперативны ответ! Вы мой спаситель) Пока я этот пакет заблокировал.

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
--force не надо, требовался именно --oldpackage; на здоровье :-)

PS и --nodeps тоже, а вместо того одной строкой:

rpm -Uvh --oldpackage libldb_1.1.20-alt0.M70P.1_x86%5f64.rpm python-module-pyldb_1.1.20-alt0.M70P.1_x86%5f64.rpm
--
Michael Shigorin

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 641
    • Домашняя страница
    • Email
Пересоберу карманное задание.
Андрей Черепанов (cas@)

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
В связи с закрытием fly.osdn.org.ua сборки наконец перенесены куда положено: p7/beta, sisyphus/alpha.

PS: а в связи с попаданием такой самбы в p7 обновлена соответствующая сборка (до 20151001 с samba-DC-4.3.0-alt1.M70P.1).
« Последнее редактирование: 02.10.2015 00:19:22 от gvy »
--
Michael Shigorin

Оффлайн GoodSoul

  • Завсегдатай
  • *
  • Сообщений: 10
    • Email
И снова здравствуйте!

Опять проблема, при  попытке обновить самбу до последней версии из репозитория 7 платформы вылезает неудовлетворенная зависимость

gnome-session требует gnome-settings-daemon (>=3.0.0).

Как можно исправить эту неприятность? Пытаюсь поставить gnome-settings-daemon из Сизифа, он тянет кучу зависимостей - не рискнул.