Автор Тема: [20151104] Праздничное обновление :-)  (Прочитано 6314 раз)

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
Сегодняшний выпуск заслуживает отдельного анонса -- и, пожалуй, основан он будет на опеннетном "отчёте за год".

Краткая сводка изменений и исправлений с октября 2014 года:
  • добавился вариант kde5 (5.15.0 / 5.4.2 / 15.08.2);
  • сборка enlightenment с Enlightenment 0.20.0 beta и EFL 1.16.0 beta3 заменила e19;
  • cinnamon: 2.8.2;
  • gnome3: 3.18.0, расширен состав и добавлена сессия Flashback а-ля GNOME2 (выбор сессии в gdm требует наличия пароля у пользователя);
  • icewm: 1.3.11 (форк -githubmod), добавлены xpra/winswitch ("screen для X");
  • kde4: 4.14.13 / 15.08.2;
  • lxqt: обновлена до свежайшей 0.10.0;
  • mate: 1.10;
  • wmaker: 0.95.7;
  • xfce: 4.12.3;
  • rescue: добавлен режим с автоподнятием сети и sshd, расширен состав (в т.ч. средствами поддержки wifi и смарткарт);
  • реализована начальная поддержка методов ввода для вьетнамского, корейского и китайского языков в вариантах cinnamon и lxde;
  • улучшен набор шрифтов по умолчанию в десктопных образах.
Ранее публиковавшиеся на fly.osdn.org.ua предварительные сборки теперь систематизированы в подкаталогах:
  • alpha/, через который прошли наиболее изменившиеся сборки этой недели вместе с добавленной kde5 и где тестируются варианты leechcraft и server-samba4 (с samba-DC 4.3);
  • just/, где собираются "образы одного приложения" (например, FlightGear или links2).
Версии базовых пакетов (20151104):
  • Linux 4.1.12 (по умолчанию) / 4.2.5 (cinnamon, icewm, rescue);
  • systemd 226 / sysvinit 2.88 (gnustep, icewm, wmaker, rescue);
  • Mesa 10.5.5;
  • firefox 41.0.2 / seamonkey 2.38 (icewm, wmaker) / epiphany 3.18.0 (gnome3) / rekonq 2.4.2 (kde4) / qupzilla 1.8.8 (lxqt).
Данные образы собраны из коммита, протегированного как 20151104.

С праздником!
« Последнее редактирование: 04.11.2015 22:52:17 от gvy »
--
Michael Shigorin

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #1 : 04.11.2015 21:42:05 »
С праздником!
Спасибо :)

dango

  • Гость
Re: [20151104] Праздничное обновление :-)
« Ответ #2 : 05.11.2015 20:16:04 »
При попытке вызвать настройки Econnman выходит окно "Ошибка исполнения приложения" с сообщением "EConnMan неожиданно закончил исполнение. Не было сообщения ошибки".
Проверил на regular-enlightenment-latest-i586.iso от 20151104
Воспроизводится и в Live и в установленной системе в ВМ.
https://bugzilla.altlinux.org/show_bug.cgi?id=31444
В EconnMan в списке сетей Wi-Fi нет моей скрытой точки доступа.
А это пока притормозил. Может в настройках есть ручное подключение к скрытой точке доступа?
Помимо этого отметил еще моменты, когда система перестает реагировать на мышку и клавиатуру. Отмечено было в установленной в ВМ системе. Приходилось перезагружать ВМ.

dango

  • Гость
Re: [20151104] Праздничное обновление :-)
« Ответ #3 : 06.11.2015 06:09:18 »
https://bugzilla.altlinux.org/show_bug.cgi?id=31444
Читал. Обновился. EConnMan теперь открывается. Спасибо.

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 555
Re: [20151104] Праздничное обновление :-)
« Ответ #4 : 06.11.2015 12:38:29 »
Пробую в виртуалке разные образы из current (от 04.11.2015), по мере ознакомления с ними, появляются вопросы :

- образ с lxqt , при открытии подменю "Системные", в нём почему-то продублированы режимы Выход, Выключение и т.д. из подменю "Выход". Это так и задумано ?
« Последнее редактирование: 06.11.2015 12:43:45 от Balbes »

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 555
Re: [20151104] Праздничное обновление :-)
« Ответ #5 : 06.11.2015 12:58:30 »
- Образ с LXDE , в сборке включен пакет Qucs (подменю Образование). Такой софт в регулярке действительно необходим ?
  Так же в сборке три терминала. Это не избыточно ли ? Еще присутствует два индикатора сетей, это не будет путать пользователя ?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #6 : 06.11.2015 13:03:44 »
"Грузите апельсины бочками", т.е. я хотел сказать - вешайте баги.

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 555
Re: [20151104] Праздничное обновление :-)
« Ответ #7 : 06.11.2015 13:43:49 »
Это точно баги, а не "так и задумано" ?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #8 : 06.11.2015 20:39:26 »
Я думаю -  "так получилось"

Оффлайн gvy

  • alt linux team
  • ***
  • Сообщений: 988
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #9 : 09.11.2015 13:06:59 »
- Образ с LXDE, в сборке включен пакет Qucs (подменю Образование). Такой софт в регулярке действительно необходим ?
Также в сборке три терминала. Это не избыточно ли ? Еще присутствует два индикатора сетей, это не будет путать пользователя ?
Попробуй снести qucs -- его кто-то нужный тянул почём зря, причём это явно паразитная зависимость; помнится, багу вешал, исправления пока нет.

PS: о, ура, Илья добрался :-)

- образ с lxqt , при открытии подменю "Системные", в нём почему-то продублированы режимы Выход, Выключение и т.д. из подменю "Выход". Это так и задумано ?
Насколько понимаю -- да, так и задумано; спрошу на всякий апстрим.
« Последнее редактирование: 09.11.2015 13:09:20 от gvy »
--
Michael Shigorin

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 555
Re: [20151104] Праздничное обновление :-)
« Ответ #10 : 10.11.2015 13:02:13 »

PS: о, ура, Илья добрался :-)

Насколько понимаю -- да, так и задумано; спрошу на всякий апстрим.

Проверил регулярку LXDE, Qucs больше в образе нет, спасибо.

По lxqt - разработчикам наверное виднее, но подход весьма своеобразный и достаточно спорный.


Вопрос по Icewm :

При попытке запуска gparted через меню, получаю ошибку , при запуске из консоли от root-а, хоть и с руганью, но запускается.  Если в десктоп файл прописать запуск с gksu, то запускается в лайве нормально. Вешать багу ?



п.с. пакет gparted есть в регулярке icewm, а в остальных он почему-то отсутствует, хотя этот пакет был бы полезен во всех регулярках, где есть инсталляция на диск, с помощью этой программы можно подготовить диск к установке (передвинуть раздел, изменить размер и т.д.), может быть стоит его включить во все регулярки с инсталляцией ?

Оффлайн ASte

  • Мастер
  • ***
  • Сообщений: 1 426
Re: [20151104] Праздничное обновление :-)
« Ответ #11 : 10.11.2015 13:42:22 »
обязательно стоит включать. потому как без него нормально ssd не подготовить к инсталляции - с учетом неумения альтовского инсталлятора оптимально выравнивать разделы на ssd.

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #12 : 10.11.2015 13:47:48 »
gparted использует не su, а consolehelper, работа которого, в свою очередь определяется правилами (для gparted)  /etc/pam.d/gparted

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: [20151104] Праздничное обновление :-)
« Ответ #13 : 10.11.2015 13:54:30 »
обязательно стоит включать. потому как без него нормально ssd не подготовить к инсталляции

Ну, тогда стоит включать не именно gparted, а по обстоятельствам, приложения, использующие libparted.
Из тех, которые назову навскидку

  • Консольный parted
  • Gtk-ый gparted
  • qt-ый qtparted

Насчёт последнего, хорошо-бы взглянуть на их сайт - может там есть болнее свежие версии.

Оффлайн Balbes

  • Мастер
  • ***
  • Сообщений: 555
Re: [20151104] Праздничное обновление :-)
« Ответ #14 : 10.11.2015 14:41:49 »
gparted использует не su, а consolehelper, работа которого, в свою очередь определяется правилами (для gparted)  /etc/pam.d/gparted
Посмотрел, что прописано у gparted, Синаптика и qtparted в файлах /etc/pam.d/* - всё одинаковое, но Синаптик и  qtparted нормально запускаются, а gparted нет.

обязательно стоит включать. потому как без него нормально ssd не подготовить к инсталляции

Ну, тогда стоит включать не именно gparted, а по обстоятельствам, приложения, использующие libparted.
Из тех, которые назову навскидку

  • Консольный parted
  • Gtk-ый gparted
  • qt-ый qtparted

Насчёт последнего, хорошо-бы взглянуть на их сайт - может там есть болнее свежие версии.
По поводу консольного варианта в графической среде, Вы серьёзно ?

Попробовал qtparted (поставил из Сизифа), сравнение интерфейсов на скриншоте, к различиям можно привыкнуть, но при попытке сделать уменьшение размера - облом, функции изменения размера и перемещения не активны. Возможно не правильно что-то делаю, не настроил или еще что-то, но в gparted всё работает сразу.

п.с. В продолжение поведения gparted в лайв режиме регулярки
- при запуске из консоли рута или при запуске с иконки, где в свойствах запуска указано  gksu gparted, стартует с показом ошибки библиотеки, но потом работает , данные в разделе видны, разделы управляются (изменить, переместить)
- если в десктоп файл добавить gksu или /usr/bin/xdg-su -c , то gparted запускается и из меню, ошибку библиотеки не показывает, но и данные в разделе не видит, не даёт им управлять.
« Последнее редактирование: 10.11.2015 16:10:44 от Balbes »