Автор Тема: Установка. UEFI. Нет загрузчика  (Прочитано 21054 раз)

Оффлайн Anton Shevtsov

  • Давно тут
  • **
  • Сообщений: 46
Добрый день.
Так как стоит задача установить Альт на машины с Windows8. Решил потестить на виртуалке.
Итак поставив винду8, ставлю второй системой альт.

Загружаюсь с флешки


Хочу от основной системы откусить часть диска и поставить в него альт


Вот так выглядит диск после винды



Уменьшаю sda4 на 25Гб



Создаю разделы root/swap. Тип раздела basic data (как я понял его и надо)



Установка прошла. Куда ставить загрузчик. Выбор небогат, ставлю на диск


Хотя что-то типа EFI должно быть , согласно справке


Перегружась.. никакого выбора - только винда. В биосе что бы не ставишь - все равно винда)


На железном компе попробовал, тоже самое.. Но там есть момент если в биосе Windows Boot Manager сдвинуть в самый низ, и грузится с самого жесткого диска - то альтовый загрузчик есть. Но нет в нем винды))

Короче, ай нид хелп..
« Последнее редактирование: 31.10.2017 12:32:06 от ruslandh »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Установка. UEFI. Нет загрузчика
« Ответ #1 : 31.10.2017 12:33:23 »
Создаю разделы root/swap. Тип раздела basic data (как я понял его и надо)
Если вставляете рисунок с внешнего источника, применяйте параметры, ограничивающие их высоту и/или ширину, с тем, что-бы они не занимали всё пространство вашего поста, например так:
Код: [Выделить]


Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Установка. UEFI. Нет загрузчика
« Ответ #2 : 31.10.2017 12:35:07 »
Особенность разбиения диска
Цитировать
Для того, чтобы система правильно работала (в частности могла загрузиться) с UEFI, при ручном разбиении диска надо обязательно сделать точку монтирования /boot/efi, в которую нужно смонтировать vfat раздел с загрузочными записями. Если такого раздела нет, то его надо создать вручную. При разбивке жёсткого диска в автоматическом режиме такой раздел создаёт сам установщик.

Оффлайн Anton Shevtsov

  • Давно тут
  • **
  • Сообщений: 46
Re: Установка. UEFI. Нет загрузчика
« Ответ #3 : 31.10.2017 12:41:11 »
Особенность разбиения диска
Цитировать
Для того, чтобы система правильно работала (в частности могла загрузиться) с UEFI, при ручном разбиении диска надо обязательно сделать точку монтирования /boot/efi, в которую нужно смонтировать vfat раздел с загрузочными записями. Если такого раздела нет, то его надо создать вручную. При разбивке жёсткого диска в автоматическом режиме такой раздел создаёт сам установщик.

Я читал это. Максимум, что понял чтобы был раздел смонтированный в /boot/efi - таковым есть sda2

Оффлайн Anton Shevtsov

  • Давно тут
  • **
  • Сообщений: 46
Re: Установка. UEFI. Нет загрузчика
« Ответ #4 : 31.10.2017 13:47:25 »
вон оно чё михалыч!

/boot/efi надо несколько)) один для винды, один для альта.. короче, все получилось

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 30 553
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Установка. UEFI. Нет загрузчика
« Ответ #5 : 31.10.2017 13:57:15 »
в /boot/efi - таковым есть sda2
На фото не видно, что вы назначили разделу /dev/sda2 точку монтирования /boot/efi

Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #6 : 05.09.2018 07:11:29 »
У меня при установке SL p8 - таблица разделов GPT, загрузчик ставлю в созданный руками раздел /boot/efi, файловая система на разделе FAT 32 - почему-то не происходит загрузка системы. Пробовал еще этой весной, когда купил новый системный блок. SL не грузился. Доставил вторым дистрибутивом Ubuntu 18.04 LTS. Загрузчик, как и рекомендуется, также поставил в /boot/efi. Загрузчик Ubuntu ситуацию исправил - стал грузить и SL, и Ubuntu. Несколько дней назад снес Ubuntu. Переустановил SL. SL у меня почему-то грузится только при условии, если ставится не в специальный раздел для загрузчика /boot/efi, а вообще на sda. GParted раздел с загрузчиком не видит, естественно.
Руслан, если будет возможность, подскажите, пожалуйста, в чем я не прав.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Установка. UEFI. Нет загрузчика
« Ответ #7 : 05.09.2018 07:31:48 »
покажите вывод команды efibootmgr после загрузки с раздела

Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #8 : 05.09.2018 10:38:47 »
Я приношу свои извинения. С большого недосыпа у меня в голове возникла некая каша. Я некорректно изложил проблему. Излагаю еще раз.
При установке SL p8 с загрузочной флэшки в меню загрузки UEFI предлагаются следующие опции:
Generic Flash Disk 8.07
UEFI: Flash Disk 8.07
UEFI: Flash Disk 8.07 Partition 1
Можно выбрать либо второй, либо третий вариант - разницу я не почувствовал.
Затем создал раздел efi system partition размером 200-300 Мб с файловой системой FAT 32. В качестве точки монтирования назначил /boot/efi, но это не срабатывало  - SL не грузился.  В связи с тем, что у убунтовцев в сети много блогов и сайтов, где можно ознакомиться с подробными инструкциями по установке Ubuntu на UEFI, я согласно выложенным инструкциям установил Ubuntu в качестве второй системы. Загрузчик Ubuntu соответственно стал предлагать выбор между загрузкой Ubuntu и SL. Соответственно все нормально заработало. Кстати, пробовал и наоборот, но безуспешно.





Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #9 : 05.09.2018 10:46:44 »
покажите вывод команды efibootmgr после загрузки с раздела
Вот, пожалуйста:# efibootmgr
EFI variables are not supported on this system.


Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #10 : 05.09.2018 11:30:48 »
Возможно, я не совсем понял задачу. Мне нужно  опять снести систему, загрузчик которой стоит на /dev/sda, заново ее установить, создав раздел efi system partition с файловой системой FAT 32 и точкой монтирования /boot/efi?
Если я правильно припоминаю перипетии сегодняшних ночных экспериментов - в этом случае загрузка доходит до черного экрана со словом GRUB _ (нижнее подчеркивание или приглашение ввести команду при этом мигает).

Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #11 : 05.09.2018 12:01:16 »
Если для того, чтобы разобраться в данной проблеме, надо снести систему и установить по новой, я готов это сделать. Только подскажите, пожалуйста, надо ли это делать.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 679
Re: Установка. UEFI. Нет загрузчика
« Ответ #12 : 05.09.2018 12:52:03 »
Первый EFI  раздел (EFI System Partition) должен быть мегабайт под 300 в FAT32 и на нём должны быть флаги boot,esp
Второй раздел, это Microsoft Reserved Partition, мегабайт 16 не меньше и без файловой
Первый монтируется в /boot/efi что указывается на этапе разбивки
В BIOS должна быть включена загрузка UEFI
Secure boot должен быть выключен.

Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #13 : 05.09.2018 15:51:41 »
ервый EFI  раздел (EFI System Partition) должен быть мегабайт под 300 в FAT32 и на нём должны быть флаги boot,esp
Большое спасибо, Юра. Видимо, проблема в том, что я не указал флаги.

Оффлайн ABC

  • Давно тут
  • **
  • Сообщений: 369
Re: Установка. UEFI. Нет загрузчика
« Ответ #14 : 05.09.2018 15:54:31 »
Второй раздел, это Microsoft Reserved Partition, мегабайт 16 не меньше и без файловой
Не понятно, зачем Microsoft Reserved Partition.
Ubuntu грузилась сама и загружала SL без этого.