Автор Тема: [Решено] Удаление пакетов grub-customizer...  (Прочитано 20668 раз)

Оффлайн San

  • Давно тут
  • **
  • Сообщений: 655
Последнее обновление (по моей хронологии) удалит следующие пакеты: alterator-grub grub-customizer grub2-pc
Чем это будет заменено?
« Последнее редактирование: 06.07.2018 08:24:22 от San »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 578
Re: Удаление пакетов grub-customizer...
« Ответ #1 : 24.04.2018 19:34:43 »
В альтах слишком вольное обращение с именами пакетов:
# apt-cache show alterator-grub | grep '^Pack\|^Vers\|^Dep'
Package: alterator-grub
Version: 0.12-alt1
Depends: alterator (>= 4.7-alt5), alterator-l10n (>= 2.9-alt10), alterator-sh-functions (>= 0.6-alt1), alterator-hw-functions (>= 0.7.6-alt1), grub-pc (> 2.00-alt20), /bin/sh, /etc/sysconfig/i18n, /lib/ld-linux.so.2, coreutils, grep, grub-common, libc.so.6(GLIBC_2.0), libc.so.6(GLIBC_2.3.4), libdevmapper.so.1.00 (>= set:mioP51z8VRAJU7z51BVl02aaHDe4), libdevmapper.so.1.00(Base), libshell, rtld(GNU_HASH), sed
Package: alterator-grub
Version: 0.11-alt1
Depends: alterator (>= 4.7-alt5), alterator-l10n (>= 2.9-alt10), alterator-sh-functions (>= 0.6-alt1), alterator-hw-functions (>= 0.7.6-alt1), grub2-pc (> 2.00-alt20), /bin/sh, /etc/sysconfig/i18n, /lib/ld-linux.so.2, coreutils, grep, grub2-common, libc.so.6(GLIBC_2.0), libc.so.6(GLIBC_2.3.4), libdevmapper.so.1.00 (>= set:mioP51z8VRAJU7z51BVl02aaHDe4), libdevmapper.so.1.00(Base), libshell, rtld(GNU_HASH), sed
# apt-cache show grub-pc grub2-pc | grep '^Pack\|^Vers\|^Dep'
Package: grub-pc
Version: 2.02-alt2.M80P.1
Depends: grub-common (= 2.02-alt2.M80P.1), /usr/lib/rpm, rpmlib(PosttransFiletriggers)
Package: grub2-pc
Version: 2.00-alt21
Depends: grub2-common (= 2.00-alt21), /usr/lib/rpm, rpmlib(PosttransFiletriggers)
# apt-cache depends alterator-grub | head -n6
alterator-grub-0.12-alt1
  Требует: alterator >= 4.7-alt5
  Требует: alterator-l10n >= 2.9-alt10
  Требует: alterator-sh-functions >= 0.6-alt1
  Требует: alterator-hw-functions >= 0.7.6-alt1
  Требует: grub-pc > 2.00-alt20
# apt-get reinstall alterator-grub -s
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  grub-common grub-pc
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-grub
Следующие пакеты будут УДАЛЕНЫ:
  grub2-common grub2-pc
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-pc
1 будет обновлено, 2 новых установлено, 2 пакетов будет удалено и 11 не будет обновлено.
Inst alterator-grub [0.11-alt1] (0.12-alt1 p8:1524499233/ALT Linux p8) []
Remv grub2-pc (2.00-alt21 ) []
Remv grub2-common (2.00-alt21 ) []
Inst grub-common (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8) []
Inst grub-pc (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf grub-common (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf grub-pc (2.02-alt2.M80P.1 p8:1524499233/ALT Linux p8)
Conf alterator-grub (0.12-alt1 p8:1524499233/ALT Linux p8)

Оффлайн K0T

  • Давно тут
  • **
  • Сообщений: 215
  • Simply 7.0.5
    • Email
Re: Удаление пакетов grub-customizer...
« Ответ #2 : 24.04.2018 20:13:32 »
тема не новая, уже было После установки Simply8.2 Grub2 оказался в "локальных/устаревших" пакетах

и в багзилле висит https://bugzilla.altlinux.org/show_bug.cgi?id=34239 и https://bugzilla.altlinux.org/show_bug.cgi?id=34246

можно ничего не делать, и так работает
можно самому вручную
apt-get install grub-pc alterator-grubможно до р9 дождаться, может там исправят ...

Оффлайн San

  • Давно тут
  • **
  • Сообщений: 655
Re: Удаление пакетов grub-customizer...
« Ответ #3 : 25.04.2018 10:54:44 »
можно до р9 дождаться, может там исправят ...
Самое интересное, что я Р8 ждал так же... А косяков что то не убавилось...  (по сравнению с Р7 кажется даже прибавилось) Или ключевое слово здесь "Может"?
можно ничего не делать, и так работает
можно самому вручную
Скорее всего так и cделаю, но думаю по необходимости. А то при следующем обновлении оно опять его удалит как лишние пакеты...

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #4 : 25.04.2018 11:44:08 »
проблема с alterator-bootloader и grub исправлена. grub в p8 теперь заменяет grub2

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 578
Re: Удаление пакетов grub-customizer...
« Ответ #5 : 25.04.2018 13:19:10 »
Ну если это исправлено...
# apt-get update
Получено: 1 http://ftp.altlinux.org p8/branch/i586 release [880B]
Получено: 2 http://ftp.altlinux.org p8/branch/noarch release [673B]
Получено 1553B за 0s (12,2kB/s).
Найдено http://ftp.altlinux.org p8/branch/i586/classic pkglist
Найдено http://ftp.altlinux.org p8/branch/i586/classic release
Найдено http://ftp.altlinux.org p8/branch/noarch/classic pkglist
Найдено http://ftp.altlinux.org p8/branch/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
# apt-get dist-upgrade -s
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-grub alterator-l10n altlinux-mime-defaults libsystemd libudev1 pciids smplayer systemd-utils udev udev-hwdb udev-rule-generator-net
  udev-rules usbids
Следующие пакеты будут ЗАМЕНЕНЫ:
  grub2-common (by grub-common)  grub2-pc (by grub-pc)  libsystemd-shared (by systemd-utils)
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-pc udev-rule-generator
13 будет обновлено, 3 новых установлено, 3 пакетов будет заменено, 0 пакетов будет удалено и 0 не будет обновлено.
Inst alterator-l10n [2.9.38-alt1] (2.9.39-alt1 p8:1524576630/ALT Linux p8)
Inst alterator-grub [0.11-alt1] (0.12-alt1 p8:1524578708/ALT Linux p8) []
Inst grub-common (2.02-alt7.M80P.1 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] []
Inst grub-pc (2.02-alt7.M80P.1 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [grub-pc on grub2-pc] [grub2-pc ]
Inst udev-hwdb [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [grub-pc on grub2-pc] [udev on udev-hwdb] [grub2-pc udev ]
Inst systemd-utils [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [udev on udev-hwdb] [udev on systemd-utils] [grub2-pc udev ]
Inst udev-rule-generator-net [1:237-alt2.M80P.1] (2:1-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [udev on udev-hwdb] [udev on systemd-utils] [grub2-pc udev ]
Inst udev-rules [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [udev on udev-rules] [udev on udev-hwdb] [udev on systemd-utils] [grub2-pc udev ]
Inst udev [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst udev-rule-generator (2:1-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst altlinux-mime-defaults [0.43-alt0.M80P.1] (0.432-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst libsystemd [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst libudev1 [1:237-alt2.M80P.1] (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst pciids [20180401-alt1] (20180408-alt1 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst smplayer [17.11.2-alt0.M80P.8808] (18.3-alt0.M80P.8982 p8:1524578708/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Inst usbids [20180401-alt1] (20180415-alt1 p8:1524576630/ALT Linux p8) [grub-common on grub2-common] [grub2-pc on grub] [systemd-utils on libsystemd-shared] [grub-pc on grub2-pc] [grub2-pc ]
Conf alterator-l10n (2.9.39-alt1 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf grub-common broken
 Obsoletes:grub2-common
 [grub2-pc ]
Conf grub-pc broken
 Obsoletes:grub2-pc
 [grub2-pc ]
Conf alterator-grub (0.12-alt1 p8:1524578708/ALT Linux p8) [grub2-pc ]
Conf udev-hwdb (1:237-alt2.M80P.2 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf systemd-utils broken
 Obsoletes:libsystemd-shared
 [grub2-pc ]
Conf udev (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub2-pc ]
Conf udev-rule-generator (2:1-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf udev-rules (1:237-alt2.M80P.2 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf udev-rule-generator-net (2:1-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf altlinux-mime-defaults (0.432-alt0.M80P.1 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf libsystemd (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub2-pc ]
Conf libudev1 (1:237-alt2.M80P.2 p8:1524578708/ALT Linux p8) [grub2-pc ]
Conf pciids (20180408-alt1 p8:1524576630/ALT Linux p8) [grub2-pc ]
Conf smplayer (18.3-alt0.M80P.8982 p8:1524578708/ALT Linux p8) [grub2-pc ]
Conf usbids (20180415-alt1 p8:1524576630/ALT Linux p8) [grub2-pc ]
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Conf Broken grub-common
E: Conf Broken grub-pc
E: Conf Broken systemd-utils

Было плохо, стало ещё хуже.
« Последнее редактирование: 25.04.2018 13:23:24 от Speccyfighter »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 578
Re: Удаление пакетов grub-customizer...
« Ответ #6 : 25.04.2018 13:35:58 »
# apt-get dist-upgrade -s
...
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Conf Broken grub-common
E: Conf Broken grub-pc
E: Conf Broken systemd-utils

Мейнтейнеры, вы хоть проверяете за собой то что вы делаете? Или так, на чистой теории?

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #7 : 25.04.2018 20:15:57 »


Было плохо, стало ещё хуже.

Чем здесь хуже ?

Пакет grub заменяет пакет grub2. Всё правильно.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #8 : 25.04.2018 20:18:05 »


Мейнтейнеры, вы хоть проверяете за собой то что вы делаете? Или так, на чистой теории?
Все изменения проверяются на стандартных конфигурациях дистрибутивов Server, Workstation и Workstation K.

То, что у вас вылезло - это ваши попытки сохранить grub2. Не надо сохранять этот пакет - его уже давно нет в репозитории. Дистрибутивы линейки 8.2 перешли на grub-2.02 вместо grub2-2.0

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #9 : 25.04.2018 20:19:48 »
Просто сделайте dist-upgrade без -s. Симуляция не удаляет пакеты, поэтому у вас такая история с выводом.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #10 : 25.04.2018 20:31:17 »
Вот пример с рабочей машинки, только что обновил (я про dist-upgrade -s vs dist-upgrade):

Вот dist-upgrade -s, пишет такую же ошибку как у вас.

# apt-get dist-upgrade -s
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  agetty alterator-grub alterator-l10n bash-completion bash-completion-systemd chrony curl fdisk getopt hwclock libaudit1 libblkid libcurl libfdisk libmount
  libnspr libnss libnss-myhostname libnss-mymachines libpasswdqc libsmartcols libsystemd libudev1 libuuid losetup lsblk mount pam0_passwdqc pam_systemd
  passwdqc-control passwdqc-utils pciids schedutils setarch sfdisk strace systemd systemd-analyze systemd-services systemd-sysvinit systemd-utils udev
  udev-hwdb udev-rule-generator-net udev-rules util-linux util-linux-control zabbix-agent zabbix-common
Следующие пакеты будут ЗАМЕНЕНЫ:
  bash-completion-journalctl (by bash-completion-systemd)  grub2-common (by grub-common)  grub2-efi (by grub-efi)  grub2-pc (by grub-pc)  journalctl (by
  systemd-utils)  libsystemd-shared (by systemd-utils)
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-efi grub-pc libpcre2 udev-rule-generator
49 будет обновлено, 5 новых установлено, 6 пакетов будет заменено, 0 пакетов будет удалено и 0 не будет обновлено.
Inst bash-completion [1:1.99-alt6] (1:1.99-alt7 p8:1524576630/ALT Linux p8)
...
...
...
E: Fatal, conflicts violated systemd-services
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Fatal, conflicts violated grub2-pc
E: Conf Broken bash-completion-systemd
E: Conf Broken systemd-utils
E: Conf Broken grub-common
E: Conf Broken grub-pc
E: Conf Broken grub-efi

Ну а вот dist-upgrade, всё закончилось успешно, машина перезагружена и работает (это продакшн).

# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  agetty alterator-grub alterator-l10n bash-completion bash-completion-systemd chrony curl fdisk getopt hwclock libaudit1 libblkid libcurl libfdisk libmount
  libnspr libnss libnss-myhostname libnss-mymachines libpasswdqc libsmartcols libsystemd libudev1 libuuid losetup lsblk mount pam0_passwdqc pam_systemd
  passwdqc-control passwdqc-utils pciids schedutils setarch sfdisk strace systemd systemd-analyze systemd-services systemd-sysvinit systemd-utils udev
  udev-hwdb udev-rule-generator-net udev-rules util-linux util-linux-control zabbix-agent zabbix-common
Следующие пакеты будут ЗАМЕНЕНЫ:
  bash-completion-journalctl (by bash-completion-systemd)  grub2-common (by grub-common)  grub2-efi (by grub-efi)  grub2-pc (by grub-pc)  journalctl (by
  systemd-utils)  libsystemd-shared (by systemd-utils)
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-efi grub-pc libpcre2 udev-rule-generator
49 будет обновлено, 5 новых установлено, 6 пакетов будет заменено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 19,8MB архивов.
После распаковки потребуется дополнительно 20,0MB дискового пространства.
Продолжить? [Y/n]
Получено: 1 http://ftp.altlinux.org p8/branch/noarch/classic bash-completion 1:1.99-alt7 [142kB]
....
...
Получено 19,8MB за 2s (8479kB/s). 
Совершаем изменения...
Preparing...                                       ################################################################################################### [100%]
 1: libsmartcols                                   ################################################################################################### [  1%]
 2: libaudit1                                      ################################################################################################### [  3%]
 3: udev-rules                                     ################################################################################################### [  5%]
 4: libcurl                                        ################################################################################################### [  7%]
...
...
...
23: util-linux                                     ################################################################################################### [ 42%]
24: grub-common                                    ################################################################################################### [ 44%]
25: grub-pc                                        ################################################################################################### [ 46%]
Updating grub on /dev/vda
Выполняется установка для платформы i386-pc.
Установка завершена. Ошибок нет.
26: grub-efi                                       ################################################################################################### [ 48%]
modprobe: ERROR: could not insert 'efivars': No such device
Not booted in EFI mode, unable to update EFI GRUB
27: udev-hwdb                                      ################################################################################################### [ 50%]
28: libpcre2                                       ################################################################################################### [ 51%]
29: systemd-utils                                  ################################################################################################### [ 53%]
30: systemd-services                               ################################################################################################### [ 55%]
31: systemd                                        warning: /etc/systemd/journald.conf created as /etc/systemd/journald.conf.rpmnew
################################################################################################### [ 57%]
...
...
...
53: chrony                                         warning: /etc/chrony.conf created as /etc/chrony.conf.rpmnew
################################################################################################### [ 98%]
54: zabbix-agent                                   warning: /etc/zabbix/zabbix_agentd.conf created as /etc/zabbix/zabbix_agentd.conf.rpmnew            (  2%)
################################################################################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Генерируется файл настройки grub …
Найден образ linux: /boot/vmlinuz-std-def
skipping symlink: /boot/vmlinuz-std-def
Найден образ linux: /boot/vmlinuz
Найден образ initrd: /boot/initrd.img
Найден образ linux: /boot/vmlinuz-4.9.89-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.9.89-std-def-alt0.M80P.1.img
Found memtest image: /boot/memtest-5.01.bin
завершено
Couldn't write '-1' to 'kernel/perf_event_max_sample_rate': Invalid argument
Завершено

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 578
Re: Удаление пакетов grub-customizer...
« Ответ #11 : 26.04.2018 16:02:53 »
Просто сделайте dist-upgrade без -s. Симуляция не удаляет пакеты, поэтому у вас такая история с выводом.

Да, смотрел взрыв симулятора. Симулятор не будет конфигурировать файлы другого пакета. А grub-* это не grub2-*, это совсем другой пакет.

Оффлайн San

  • Давно тут
  • **
  • Сообщений: 655
Re: Удаление пакетов grub-customizer...
« Ответ #12 : 28.04.2018 22:14:34 »
А вот что у меня получилось при обновлении, благо опять виртуальная машина. Нажал кнопку вернуть снимок и все. А как быть на "Рабочей" не Виртуальной станции?
всё закончилось успешно, машина перезагружена и работает
А у меня не успешно! У меня закончилось вот ЭТИМ! (картинка) Что можно сделать?

Одинаково: - Хоть из под Синаптика, Хоть из под Консоли
$ su -
Password:
# apt-get update     
Получено: 1 http://ftp.altlinux.org p8/branch/x86_64 release [880B]
Получено: 2 http://ftp.altlinux.org p8/branch/x86_64-i586 release [537B]
Получено: 3 http://ftp.altlinux.org p8/branch/noarch release [673B]
Получено 2090B за 0s (12,2kB/s).
Получено: 1 http://ftp.altlinux.org p8/branch/x86_64/classic pkglist [20,1MB]
Получено: 2 http://ftp.altlinux.org p8/branch/x86_64/classic release [135B]                                                                                                                                                     
Получено: 3 http://ftp.altlinux.org p8/branch/x86_64-i586/classic pkglist [15,1MB]                                                                                                                                             
Получено: 4 http://ftp.altlinux.org p8/branch/x86_64-i586/classic release [140B]                                                                                                                                               
Получено: 5 http://ftp.altlinux.org p8/branch/noarch/classic pkglist [4955kB]                                                                                                                                                   
Получено: 6 http://ftp.altlinux.org p8/branch/noarch/classic release [135B]                                                                                                                                                     
Получено 40,2MB за 21s (1837kB/s).                                                                                                                                                                                             
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-grub alterator-l10n altlinux-mime-defaults i586-libgpg-error.32bit indilib indilib-common java-1.8.0-openjdk java-1.8.0-openjdk-headless kde5-connect kde5-connect-common kde5-kio-gdrive kde5-kstars kde5-skanlite
  krb5-ticket-watcher libgpg-error libindi libkdeconnectcore1 libkdeconnectinterfaces1 libkdeconnectpluginkcm1 pinentry-common pinentry-qt5 usbids
Следующие пакеты будут ЗАМЕНЕНЫ:
  alterator-browser-qt4 (by alterator-browser-qt5)  grub2-common (by grub-common)  grub2-efi (by grub-efi)  grub2-pc (by grub-pc)
Следующие НОВЫЕ пакеты будут установлены:
  alterator-browser-qt5 grub-common grub-efi grub-pc libqt5-datavisualization qt5-datavis3d-common
22 будет обновлено, 6 новых установлено, 4 пакетов будет заменено, 0 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 80,1MB архивов.
После распаковки потребуется дополнительно 22,5MB дискового пространства.
Продолжить? [Y/n] Y
Получено: 1 http://ftp.altlinux.org p8/branch/noarch/classic alterator-l10n 2.9.39-alt1 [389kB]
Получено: 2 http://ftp.altlinux.org p8/branch/x86_64/classic alterator-grub 0.12-alt1 [16,4kB]
Получено: 3 http://ftp.altlinux.org p8/branch/x86_64/classic grub-common 2.02-alt7.M80P.1 [1714kB]
Получено: 4 http://ftp.altlinux.org p8/branch/x86_64/classic grub-pc 2.02-alt7.M80P.1 [2766kB]
Получено: 5 http://ftp.altlinux.org p8/branch/x86_64/classic grub-efi 2.02-alt7.M80P.1 [3696kB]
Получено: 6 http://ftp.altlinux.org p8/branch/noarch/classic altlinux-mime-defaults 0.432-alt0.M80P.1 [22,5kB]
Получено: 7 http://ftp.altlinux.org p8/branch/x86_64-i586/classic i586-libgpg-error.32bit 1.29-alt1.M80P.1 [60,5kB]
Получено: 8 http://ftp.altlinux.org p8/branch/x86_64/classic libgpg-error 1.29-alt1.M80P.1 [189kB]
Получено: 9 http://ftp.altlinux.org p8/branch/x86_64/classic indilib 1.6.2-alt1.M80P.1 [926kB]
Получено: 10 http://ftp.altlinux.org p8/branch/x86_64/classic libindi 1.6.2-alt1.M80P.1 [340kB]                                                                                                                                 
Получено: 11 http://ftp.altlinux.org p8/branch/noarch/classic indilib-common 1.6.2-alt1.M80P.1 [15,7kB]                                                                                                                         
Получено: 12 http://ftp.altlinux.org p8/branch/x86_64/classic java-1.8.0-openjdk 0:1.8.0.144-alt1_1.b01jpp8.M80P.2 [179kB]                                                                                                       
Получено: 13 http://ftp.altlinux.org p8/branch/x86_64/classic java-1.8.0-openjdk-headless 0:1.8.0.144-alt1_1.b01jpp8.M80P.2 [28,8MB]                                                                                             
Получено: 14 http://ftp.altlinux.org p8/branch/x86_64/classic kde5-connect 1.3.0-alt1.M80P.1 [345kB]                                                                                                                             
Получено: 15 http://ftp.altlinux.org p8/branch/x86_64/classic libkdeconnectinterfaces1 1.3.0-alt1.M80P.1 [51,6kB]                                                                                                               
Получено: 16 http://ftp.altlinux.org p8/branch/x86_64/classic libkdeconnectpluginkcm1 1.3.0-alt1.M80P.1 [7002B]                                                                                                                 
Получено: 17 http://ftp.altlinux.org p8/branch/x86_64/classic libkdeconnectcore1 1.3.0-alt1.M80P.1 [106kB]                                                                                                                       
Получено: 18 http://ftp.altlinux.org p8/branch/noarch/classic kde5-connect-common 1.3.0-alt1.M80P.1 [129kB]                                                                                                                     
Получено: 19 http://ftp.altlinux.org p8/branch/x86_64/classic kde5-kio-gdrive 1.2.2-alt1.M80P.1 [82,8kB]                                                                                                                       
Получено: 20 http://ftp.altlinux.org p8/branch/x86_64/classic qt5-datavis3d-common 5.9.4-alt1.M80P.1 [1625B]                                                                                                                   
Получено: 21 http://ftp.altlinux.org p8/branch/x86_64/classic libqt5-datavisualization 5.9.4-alt1.M80P.1 [459kB]                                                                                                               
Получено: 22 http://ftp.altlinux.org p8/branch/x86_64/classic kde5-kstars 1:2.9.4-alt2.M80P.1 [36,8MB]                                                                                                                         
Получено: 23 http://ftp.altlinux.org p8/branch/x86_64/classic kde5-skanlite 2.1.0-alt1.M80P.1 [2267kB]                                                                                                                         
Получено: 24 http://ftp.altlinux.org p8/branch/x86_64/classic krb5-ticket-watcher 1.0.3-alt12.M80P.1 [105kB]                                                                                                                   
Получено: 25 http://ftp.altlinux.org p8/branch/x86_64/classic pinentry-qt5 1.1.0-alt1.M80P.1 [49,2kB]                                                                                                                           
Получено: 26 http://ftp.altlinux.org p8/branch/x86_64/classic pinentry-common 1.1.0-alt1.M80P.1 [61,0kB]                                                                                                                       
Получено: 27 http://ftp.altlinux.org p8/branch/noarch/classic usbids 20180415-alt1 [178kB]                                                                                                                                     
Получено: 28 http://ftp.altlinux.org p8/branch/x86_64/classic alterator-browser-qt5 3.0.2-alt2.M80P.1 [241kB]                                                                                                                   
Получено 80,1MB за 43s (1821kB/s).                                                                                                                                                                                             
Совершаем изменения...
Preparing...                                                                                                          ################################################################################################### [100%]
 1: grub-common                                                                                                       ################################################################################################### [  3%]
 2: kde5-connect-common                                                                                               ################################################################################################### [  7%]
 3: libgpg-error                                                                                                      ################################################################################################### [ 10%]
 4: pinentry-common                                                                                                   ################################################################################################### [ 14%]
 5: libkdeconnectinterfaces1                                                                                          ################################################################################################### [ 17%]
 6: libkdeconnectcore1                                                                                                ################################################################################################### [ 21%]
 7: libkdeconnectpluginkcm1                                                                                           ################################################################################################### [ 25%]
 8: grub-pc                                                                                                           ################################################################################################### [ 28%]
Updating grub on /dev/disk/by-id/ata-VBOX_HARDDISK_VB36797d6d-c5aa8bd2
Выполняется установка для платформы i386-pc.
/usr/sbin/grub-install: ошибка: не удалось найти привод GRUB для /dev/disk/by-id/ata-VBOX_HARDDISK_VB36797d6d-c5aa8bd2. Проверьте device.map.
** WARNING: grub-autoupdate failed, NEXT BOOT WILL LIKELY FAIL NOW
** WARNING: please run it by hand, record the output offline,
** WARNING: make sure you have bootable rescue CD/flash media handy
** WARNING: and try `grub-install /dev/sdX' manually
 9: grub-efi                                                                                                          ################################################################################################### [ 32%]
modprobe: ERROR: could not insert 'efivars': No such device
Not booted in EFI mode, unable to update EFI GRUB
10: libqt5-datavisualization                                                                                          ################################################################################################### [ 35%]
11: java-1.8.0-openjdk-headless                                                                                       ################################################################################################### [ 39%]
12: indilib-common                                                                                                    ################################################################################################### [ 42%]
13: libindi                                                                                                           ################################################################################################### [ 46%]
14: indilib                                                                                                           ################################################################################################### [ 50%]
15: alterator-l10n                                                                                                    ################################################################################################### [ 53%]
16: alterator-grub                                                                                                    ################################################################################################### [ 57%]
17: altlinux-mime-defaults                                                                                            ################################################################################################### [ 60%]
18: i586-libgpg-error                                                                                                 ################################################################################################### [ 64%]
19: java-1.8.0-openjdk                                                                                                ################################################################################################### [ 67%]
20: kde5-connect                                                                                                      ################################################################################################### [ 71%]
21: kde5-kio-gdrive                                                                                                   ################################################################################################### [ 75%]
22: kde5-kstars                                                                                                       ################################################################################################### [ 78%]
23: kde5-skanlite                                                                                                     ################################################################################################### [ 82%]
24: krb5-ticket-watcher                                                                                               ################################################################################################### [ 85%]
25: pinentry-qt5                                                                                                      ################################################################################################### [ 89%]
26: usbids                                                                                                            ################################################################################################### [ 92%]
27: alterator-browser-qt5                                                                                             ################################################################################################### [ 96%]
Running /usr/lib/rpm/posttrans-filetriggers
Генерируется файл настройки grub …
Найдена тема: /boot/grub/themes/branding-xalt-kworkstation/theme.txt
Found background image: grub.jpg
Найден образ linux: /boot/vmlinuz-std-def
skipping symlink: /boot/vmlinuz-std-def
Найден образ linux: /boot/vmlinuz
Найден образ initrd: /boot/initrd.img
Найден образ linux: /boot/vmlinuz-4.9.93-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.9.93-std-def-alt0.M80P.1.img
Найден образ linux: /boot/vmlinuz-4.9.92-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.9.92-std-def-alt0.M80P.1.img
Найден образ linux: /boot/vmlinuz-4.9.86-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.9.86-std-def-alt0.M80P.1.img
Найден образ linux: /boot/vmlinuz-4.9.53-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.9.53-std-def-alt0.M80P.1.img
Найден образ linux: /boot/vmlinuz-4.4.34-std-def-alt0.M80P.1
Найден образ initrd: /boot/initrd-4.4.34-std-def-alt0.M80P.1.img
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found memtest image: /boot/memtest-5.01.bin
завершено
Завершено.
# reboot

Проскакивают мысли вообще от обновлений отказаться, страшно уже становится! Не знаешь, запустится у тебя машина после очередного обновления или нет? Не хорошо это как то? По Маздайному... Ну некогда мне про каждый пакет читать и разбираться.
« Последнее редактирование: 28.04.2018 22:20:02 от San »

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Re: Удаление пакетов grub-customizer...
« Ответ #13 : 29.04.2018 08:20:04 »
А какой дистрибутив был установлен изначально ?

У вас grub выдал сообщение об ошибке в процессе установки, что говорит grub-autoupdate после завершения обновления ?

Оффлайн Grommit

  • Давно тут
  • **
  • Сообщений: 82
Re: Удаление пакетов grub-customizer...
« Ответ #14 : 29.04.2018 16:55:13 »
А вот что у меня получилось при обновлении
У меня так же, но не на виртуалке... Нужно было срочно сделать работу, а вместо этого пришлось восстанавливать grub через rescue. Разбираться в причинах времени не было совсем, но между булок подгорало долго...