Автор Тема: Установка "Рабочая станция" на DEPO Neos DF226 в режиме EFI  (Прочитано 35489 раз)

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Всем здравствуйте!
Имеется комп DEPO Neos DF226 с материнкой DEPO и с Дэпошным биусом, пытаюсь поставить ОС "Рабочая станция" в EFI но нечего не выходит. Т.е. ставлю загрузчик в раздел EFI перезагружаю и .. нечего BIOS тупо не видит загрузчик. Безопасную загрузку во время установки выключал, регестировал .efi файлы из раздела EFI в биосе нечего не помогает. Подскажите как быть.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Какая версия рабочей станции устанавливается ?

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Альт Рабочая станция 8.2.

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Следствия найдены:
1. в разделе EFI отсутствует папка BOOT зато есть папка altlinux в которой лежит grubx64.efi и другие .efi файлы
2. в папке altlinux отсутствует bootx64.efi

Решение:
подключить раздел EFI и переименовать папку altlinux в BOOT.
скопировать с образа файл (x):\EFI\BOOT\bootx64.efi в раздел EFI в папку BOOT.

если кто знает причину почему такое происходит(неправильное название папки, не полное создание файлов загрузки) буду рад объяснению.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
Как образ на flash записывали?

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
с помощью Win32DiskImager-0.9.5-binary

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 760
Всем здравствуйте!
Имеется комп DEPO Neos DF226 с материнкой DEPO и с Дэпошным биусом, пытаюсь поставить ОС "Рабочая станция" в EFI но нечего не выходит. Т.е. ставлю загрузчик в раздел EFI перезагружаю и .. нечего BIOS тупо не видит загрузчик. Безопасную загрузку во время установки выключал, регестировал .efi файлы из раздела EFI в биосе нечего не помогает. Подскажите как быть.
Прикрепите фотку экрана когда только загружается установщик - там больше картинок или текст?

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Всем здравствуйте!
Имеется комп DEPO Neos DF226 с материнкой DEPO и с Дэпошным биусом, пытаюсь поставить ОС "Рабочая станция" в EFI но нечего не выходит. Т.е. ставлю загрузчик в раздел EFI перезагружаю и .. нечего BIOS тупо не видит загрузчик. Безопасную загрузку во время установки выключал, регестировал .efi файлы из раздела EFI в биосе нечего не помогает. Подскажите как быть.
Прикрепите фотку экрана когда только загружается установщик - там больше картинок или текст?
запуск установки происходит в режиме UEFI однозначно. да с картинками. в BIOS отключен CSM так что запуск в режиме Legacy не возможен.
« Последнее редактирование: 29.10.2018 12:51:03 от nilford »

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
с помощью Win32DiskImager-0.9.5-binary

Странный у вас образ. У нас нет в образе папки EFI/altlinux/ Есть EFI/BOOT/

md5sum с образа скажите

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
Правильно, в образе нет. я про это и не говорил что это в образе. Эта папка появляется в разделе EFI жесткого диска, после установки загрузчика.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 760
У вас точно разметка gpt и первый раздел в fat32? Возможно что надо удалить все разделы, таблицу разделов и создать заново.

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
точно, sda1 fat32 далее идет раздел в 8МБ с пометкой GRUB и вроде как без файловой системы(черным отображает). после того как я переименовал папку в BOOT и скопировал туда bootx64.efi загрузка пошла.
« Последнее редактирование: 29.10.2018 17:32:16 от nilford »

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 760
точно, sda1 fat32 далее идет раздел в 8МБ с пометкой GRUB и вроде как без файловой системы(черным отображает). после того как я переименовал папку в BOOT и скопировал туда bootx64.efi загрузка пошла.
это что-то странное и раздел grub нужен был при разметке mbr.

Оффлайн Rider

  • /usr/sbin/control
  • *******
  • Сообщений: 1 136
точно, sda1 fat32 далее идет раздел в 8МБ с пометкой GRUB и вроде как без файловой системы(черным отображает). после того как я переименовал папку в BOOT и скопировал туда bootx64.efi загрузка пошла.

Переименовывать ничего не нужно.
Что говорит команда efibootmgr -v ?

Оффлайн nilford

  • Завсегдатай
  • *
  • Сообщений: 13
    • Email
точно, sda1 fat32 далее идет раздел в 8МБ с пометкой GRUB и вроде как без файловой системы(черным отображает). после того как я переименовал папку в BOOT и скопировал туда bootx64.efi загрузка пошла.

Переименовывать ничего не нужно.
Что говорит команда efibootmgr -v ?
однако, без переименования не работает. я сначала попробовал скопировать bootx64 перезагрузил не пашет, потом переименовал в boot и все заработало. по поводу команды напишу завтра.