Автор Тема: google-drive-ocamlfuse не хочет авторизовываться  (Прочитано 8292 раз)

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Здравствуйте. Проблема в том, что при запуске команды
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$ google-drive-ocamlfuse ~/google-drive/

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:153:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:154:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:578:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:579:28: The style property GtkWidget:interior-focus is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:580:28: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:581:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1333:25: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1334:25: The style property GtkRange:stepper-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1335:34: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1336:28: The style property GtkRange:stepper-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1337:34: The style property GtkRange:trough-under-steppers is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: not a number

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: Expected a string.

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: not a number

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: Expected a string.

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: not a number

(chromium:2770): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: Expected a string.

(chromium:2770): Gtk-WARNING **: Theme parsing error: applications.css:21:0: Expected a valid selector

браузер открывается, но дальше действий нет.
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$ cat /etc/os-release
NAME="ALT Workstation"
VERSION="8.2 (december)"
ID=altlinux
VERSION_ID=8.2
PRETTY_NAME="ALT Workstation 8.2 (december)"
ANSI_COLOR="1;33"
CPE_NAME="cpe:/o:alt:workstation:8.2"
HOME_URL="http://basealt.ru"
BUG_REPORT_URL="https://bugs.altlinux.org/"
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$ uname -a
Linux comp-a6-3400m-apu-3a3fbe.localdomain 4.9.71-std-def-alt0.M80P.1 #1 SMP Thu Dec 21 01:27:05 UTC 2017 x86_64 GNU/Linux
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$
пакет был установлен из репов альта

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 581
    • Домашняя страница
    • Email
Наверняка, Google изменил API.
Андрей Черепанов (cas@)

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Наверняка, Google изменил API.
Может версию пакета в репах обновить.

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 703
  • Кто ищет, тот найдёт.
Может версию пакета в репах обновить.
Цитировать
Описание:

google-drive-ocamlfuse is a FUSE-based file system backed by Google Drive,
written in OCaml. It lets you mount your Google Drive on Linux.

On the first time, just run google-drive-ocamlfuse, which will open a
browser for authentication. If that process succeeds, it will print
"Access token retrieved correctly.". Now run google-drive-ocamlfuse
with an empty directory supplied, which is the mount point for your Google
Drive.
You can optionally unmount with fusermount -u mount-point.
А вы первый раз запускали команду без параметров ?

Оффлайн Spanish ArCher

  • Давно тут
  • **
  • Сообщений: 1 199
Вау! Работает!
Только нужно себя в группу fuse включить.
Если я попался вам навстречу, Значит вам со мной не по пути.
(С) Воскресение

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 703
  • Кто ищет, тот найдёт.
Только нужно себя в группу fuse включить.
Штатная настройка систем Альт, когда добавление в группу надо делать руками.

Ну а про необходимость в обязательном порядке читать документацию я уже не говорю. Это само собой разумеется.

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Только нужно себя в группу fuse включить.
Штатная настройка систем Альт, когда добавление в группу надо делать руками.

Ну а про необходимость в обязательном порядке читать документацию я уже не говорю. Это само собой разумеется.
1)Только где эта документация?
2) делал по инструкции из интернета.

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Вау! Работает!
Только нужно себя в группу fuse включить.
Команда в студию?

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 703
  • Кто ищет, тот найдёт.
1)Только где эта документация?
В вашем случае вам крупно повезло: инструкция по использованию указана прямо в описании пакета https://forum.altlinux.org/index.php?topic=42233.msg334900#msg334900, которое можно посмотреть в том же Synaptic'e, а, если пакет установлен, то можно посмотреть от пользователя и через терминал rpm -qi название_пакета
2) делал по инструкции из интернета.
Не все инструкции одинаково работают при разных обстоятельствах и, что важно, работают не в каждом дистрибутиве линукса.
Команда в студию?
Не ленимся пользоваться поиском по форуму https://www.google.com/search?q=%D0%B4%D0%BE%D0%B1%D0%B0%D0%B2%D0%B8%D1%82%D1%8C+%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D1%82%D0%B5%D0%BB%D1%8F+%D0%B2+%D0%B3%D1%80%D1%83%D0%BF%D0%BF%D1%83+site:https://forum.altlinux.org/
И по первой ссылке из найденного сразу же находим тему с примерами команд: https://forum.altlinux.org/index.php?topic=8587.0 и конкретное сообщение https://forum.altlinux.org/index.php?topic=8587.msg115932#msg115932

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Вау! Работает!
Только нужно себя в группу fuse включить.
включил, но вот загвоздка, токен не получается, так как на chromium страница не открывается. 
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$ google-drive-ocamlfuse ~/google-drive/

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:153:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:154:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:578:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:579:28: The style property GtkWidget:interior-focus is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:580:28: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:581:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1333:25: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1334:25: The style property GtkRange:stepper-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1335:34: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1336:28: The style property GtkRange:stepper-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1337:34: The style property GtkRange:trough-under-steppers is deprecated and shouldn't be used anymore. It will be removed in a future version

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: not a number

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: Expected a string.

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: not a number

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1977:11: Expected a string.

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: not a number

(chromium:1425): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2527:11: Expected a string.

(chromium:1425): Gtk-WARNING **: Theme parsing error: applications.css:21:0: Expected a valid selector
[1425:1425:0205/124613.728279:ERROR:background_mode_manager_aura.cc(13)] Not implemented reached in virtual void BackgroundModeManager::EnableLaunchOnStartup(bool)
libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/r600_drv_video.so
libva info: Found init function __vaDriverInit_0_40
libva info: va_openDriver() returns 0
[8:72:0205/124621.352297:ERROR:adm_helpers.cc(62)] Failed to query stereo recording.
[11:109:0205/124624.470506:ERROR:adm_helpers.cc(62)] Failed to query stereo recording.
[1425:1425:0205/124931.111914:ERROR:CONSOLE(0)] "Uncaught (in promise) #<Event>", source: https://www.yandex.ru/chrome/newtab (0)
[1425:1425:0205/124931.112007:ERROR:CONSOLE(0)] "Uncaught (in promise) #<Event>", source: https://www.yandex.ru/chrome/newtab (0)
[1425:1425:0205/124931.112042:ERROR:CONSOLE(0)] "Uncaught (in promise) #<Event>", source: https://www.yandex.ru/chrome/newtab (0)
Cannot get token. Quitting.
[blacksaber@comp-a6-3400m-apu-3a3fbe ~]$

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 581
    • Домашняя страница
    • Email
Смотрите вывод groupsПосле внесения в группу требуется перезапуск сеанса.
Андрей Черепанов (cas@)

Оффлайн BlackSaber

  • ALTLinux usверь
  • Давно тут
  • **
  • Сообщений: 53
  • ALTLinux user
Смотрите вывод groupsПосле внесения в группу требуется перезапуск сеанса.
я вообще ноут перезагрузил. но результат тот же

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 703
  • Кто ищет, тот найдёт.
включил, но вот загвоздка, токен не получается, так как на chromium страница не открывается. 
Описание:

google-drive-ocamlfuse is a FUSE-based file system backed by Google Drive,
written in OCaml. It lets you mount your Google Drive on Linux.

On the first time, just run google-drive-ocamlfuse, which will open a
browser for authentication. If that process succeeds, it will print
"Access token retrieved correctly."
Вы точно читали описание ?
Первый раз надо запустить команду без параметров и получить токен (будет выдано сообщение "Access token retrieved correctly."). Если токен получен на предыдущем шаге, то запускать команду с пустой точкой монтирования. А вы что хотите от команды, которая должна выполняться только после получения токена.