Автор Тема: Palemoon Браузер - тестирование сборки.  (Прочитано 35358 раз)

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 8 703
  • Кто ищет, тот найдёт.
Пробовал собрать вчера для p8 - если собирать с gcc5, то облом, а указанный gcc7 в бранче отсутствует. Зависимости в спеке пришлось править, чтобы хотя бы сборку запустить: дубликатов хватает, а некоторых пакетов из сборочных зависимостей просто нет в p8. Так что сборка для p8 не совсем тривиальная задача.

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
а некоторых пакетов из сборочных зависимостей просто нет в p8
Где-то на форуме видел что р8 больше поддерживаться не будет.  :-(

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 758
некоторых пакетов из сборочных зависимостей просто нет в p8.
а firefox то тогда как в p8 собирают?

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
Вот
Developer_Guide:Build_Instructions/Pale_Moon/Linux_Tycho
Цитировать
GCC - Minimum version required is unknown. Versions 5.2.x is recommended, 6.x is still experimental and is known to produce unstable builds (segfaults in mozjs.so).
Это рекомендации к старой сборке, а 28.8.0 вышел 10 декабря минимальные требования другие.
http://www.palemoon.org/releasenotes.shtml

firefox с длительной поддержкой можно собирать с библиотеками более низких версий. У palemoon если делать культурно то взять архивную версию которая бы подходила р8 ну или пользоваться готовым бинарным пакетом.
В p8 есть старый palemoon прекрасно работающий.

Кстати :
Цитировать
Supported processors
The Pale Moon browser is specifically optimized for relatively-recent processors and uses instructions exclusively available in more modern (or rather: not museum-grade) processors. This means it will not run on PCs that are particularly old by today's standards, and is likely to display errors or refuse to start on systems with unsupported or poorly supported CPUs. Even if you meet the minimum CPU requirements for the browser, you should not expect wonders from your hardware if it is dated. Modern web browsers are very much alike full-fledged 3D games in the resources and processing power/graphics power they require.
Requirements for the regular Pale Moon browser are, in short: a CPU with SSE2 support. This support has been present in all mainstream CPUs since the Intel Pentium 4, and the AMD Athlon64 processors. All muti-core processors on the market should support this instruction set.
То есть хоть он и легенький, но все же создан для более менее современных машин.
« Последнее редактирование: 10.01.2020 22:19:42 от Koi »

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
Вышел новый релиз 28.8.1
Изменения:
Release notes
Требования

Фиксы сборки.
- new version
- Fixed:
+ fix error gtk
- Added:
+ pepperflash

В клубных репах.

Оффлайн Biker

  • в Linux начинающий "чайник"
  • Давно тут
  • **
  • Сообщений: 242
Спасибо за установщик, правда уже v28.14.2 (2020-10-02)
А после установки надо перезагружаться, чтобы новая программа появилась в меню?

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
Спасибо за установщик, правда уже v28.14.2 (2020-10-02)
А после установки надо перезагружаться, чтобы новая программа появилась в меню?
Обычно обновление меню динамическое.

Да, новую сборку надо сделать, кроме того поправить значки в контекстном меню, но на данный момент я нахожусь за городом в распоряжении 2-а довольно старых ноутбука, пока нет возможности собрать новую версию.

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
Обновил Palemoon в клубных репах.
Теперь из исходников его больше не собираю так как очень долго компилится у меня терпелка лопается если что-то компилится больше 40 минут.

Изменения в новой версии:
  • Пакет адаптирован под alt.
  • Удалены все поисковые плагины кроме утки и добавлены нормальные ну то есть гуг, яндекс, поиск по ресурсам alt, так же сделал плагины для vk и ok и т.д.
  • Оптимизирована плавная прокрутка так как на очень длинных сайтах она тормозила, но полностью от тормозов избавиться не удалось.
  • По умолчанию установлен русский язык, тема оформления PM Opera, словари и легкая перенастройка интерфейса без излишеств чтоб не перегружать.
  • Добавлен агент firefox потому что на собственный разные сервисы бывает ругаются.
  • Добавлена функция основанная на таблице стилей авто-скрытие панели меню.
  • Добавлен блок рекламы и флэш так же таблицами стилей, сразу говорю что это не панацея и убирает не все если сравнивать с расширениями, но зато почти не есть память и ресурсы процессора.
  • Различные мелкие базовые настройки, особо настраивать там нечего разработчик и так все вырубил. 
  • Сам пакет теперь селится так же как хром и мокрый софт в opt.
  • Если Вам не нравится работа блокировки рекламы или скрытие панели отключить можно в файле ~/.moonchild productions/pale moon/что-то_там.default/chrome/userChrome.css я там все подписал, что не надо просто закомментируйте.   
Ну и.. приятного просмотра.
« Последнее редактирование: 13.06.2021 12:59:12 от Koi »

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 889
  • валар дохаэрис
    • Канал на youtube
В клубных репах обновилась версия palemoon. :-)