Автор Тема: Помогите настроить сканеры Canon LiDE 400 и Xerox WC 3335  (Прочитано 9803 раз)

Оффлайн ShVlad

  • Завсегдатай
  • *
  • Сообщений: 5
ALT LINUX 8.0
xsane не видит

[root@a151f1 ~]# lsusb | grep '04a9'
Bus 001 Device 008: ID 04a9:1912 Canon, Inc.
[root@a151f1 ~]# getfacl /dev/bus/usb/001/008
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/008
# owner: root
# group: lp
user::rw-
group::rw-
other::r--
================================

root@a151f1 ~]# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".

found USB scanner (vendor=0x0924 [Xerox], product=0x42e2 [WorkCentre 3335]) at libusb:001:004
found USB scanner (vendor=0x04a9 [Canon], product=0x1912 [LiDE 400]) at libusb:001:008
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
================================================


[root@a151f1 ~]# scanimage -L
MIB search path: /usr/share/snmp/mibs:/usr/share/mibs/net-snmp:/usr/share/mibs/iana:/usr/share/mibs/ietf:/usr/share/mibs/tubs:/usr/share/mibs/cisco:/usr/share/pibs/ietf:/usr/share/pibs/tubs:
Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
Cannot find module (DISMAN-SCHEDULE-MIB): At line 0 in (none)
Cannot find module (EtherLike-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-TYPES): At line 0 in (none)
Cannot find module (IPV6-ICMP-MIB): At line 0 in (none)
Cannot find module (IPV6-MIB): At line 0 in (none)
Cannot find module (IPV6-TCP-MIB): At line 0 in (none)
Cannot find module (IPV6-UDP-MIB): At line 0 in (none)
Cannot find module (UCD-IPFWACC-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (TUNNEL-MIB): At line 0 in (none)
Cannot find module (IPV6-FLOW-LABEL-MIB): At line 0 in (none)
Cannot find module (UCD-DISKIO-MIB): At line 0 in (none)
Cannot find module (LM-SENSORS-MIB): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-VACM-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (IP-FORWARD-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
Cannot find module (NET-SNMP-PASS-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-EXTEND-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

В Linux'е полный ноль...
« Последнее редактирование: 11.05.2020 10:55:05 от ShVlad »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 874
ALT LINUX 8.0
xsane не видит

В Linux'е полный ноль...

Принципиальной разницы между виндоус и линукс нет. Для работы сканера в операционной системе нужен ... . Нужен что?

сканеры Canon LiDE 400 и Xerox WC 3335

Чтобы найти это "что", достаточно понимать общий принцип работы устройства в операционной системе и воспользоваться браузером и поиском в поисковике google:
На сайте производителя Cannon для этой модели, лежат deb и rpm пакеты под две архитектуры и исходники.
На сайте производителя Xerox для этой модели, лежат deb и rpm пакеты под две архитектуры.

Оффлайн ShVlad

  • Завсегдатай
  • *
  • Сообщений: 5
Цитировать
Чтобы найти это "что", достаточно понимать общий принцип работы устройства в операционной системе и воспользоваться браузером и поиском в поисковике google:
На сайте производителя Cannon для этой модели, лежат deb и rpm пакеты под две архитектуры и исходники.
На сайте производителя Xerox для этой модели, лежат deb и rpm пакеты под две архитектуры.

Все манипуляции выше производил после установки соответствующих пакетов. Еле-еле после танцев с бубнов встал принтер от WC 3335. А сканеры ....
 
« Последнее редактирование: 12.05.2020 08:19:39 от Skull »

Оффлайн ShVlad

  • Завсегдатай
  • *
  • Сообщений: 5
Вот что выдал Canon:
Reading Package Lists...
Building Dependency Tree...
Selecting scangearmp2 for '/home/user/scangearmp2-3.70-1-rpm/packages/scangearmp2-3.70-1.x86_64.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following packages have unmet dependencies:
  scangearmp2: Depends: rpmlib(FileDigests) (<= 4.6.0-1) but it is not installable
E: Broken packages

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 874
epm install --repack /home/user/scangearmp2-3.70-1-rpm/packages/scangearmp2-3.70-1.{i386,x86_64}.rpm

Он может установиться
# rpm -q scangearmp2
scangearmp2-3.70-alt1.repacked.with.epm.2

но что это за библиотеки, не знаю
lib.req: WARNING: /usr/local/bin/scangearmp2: library libcncpmslld2.so not found
lib.req: WARNING: /usr/local/bin/scangearmp2: library libcncpnet20.so not found
lib.req: WARNING: /usr/local/bin/scangearmp2: library libcncpnet30.so not found
lib.req: WARNING: /usr/local/bin/scangearmp2: library libcncpnet2.so not found
(выплюнет на репаке)

Для Cannon есть исходник, но нужен желающий его собрать.
rpm-пакеты собирались в федора.

Оффлайн ShVlad

  • Завсегдатай
  • *
  • Сообщений: 5
Все проделал. События все аналогичные. Устройтв не обнаружено (xsane)

Оффлайн ShVlad

  • Завсегдатай
  • *
  • Сообщений: 5
Неужели ничего нельзя сделать?

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 874
Пишут что lide 400 поддерживается:
http://www.sane-project.org/lists/sane-mfgs-cvs.html

В p8 видел lide 300, но не увидел lide 400.

В p9:
$ rpm -qpvl sane-1.0.28-alt3.x86_64.rpm | grep sane-backends.html
-rw-r--r--    1 root    root                   630232 ноя 18 15:07 /usr/share/doc/sane-backends/sane-backends.html
$ sed -n '4451,4454p; 5042,5048p' ./sane-backends.txt
  Backend: pixma (0.23.0)

   Manual page: sane-pixma

   |              |----------------------------+-------------------+---------------+----------+---------------------------------------------------|
   |              |     CanoScan LiDE 300      |        USB        | 0x04a9/0x1913 | Complete | Support up to 4800DPI (Note: does not have less   |
   |              |                            |                   |               |          | than 300DPI support)                              |
   |              |----------------------------+-------------------+---------------+----------+---------------------------------------------------|
   |              |     CanoScan LiDE 400      |        USB        | 0x04a9/0x1912 | Complete | Support up to 4800DPI (Note: does not have less   |
   |              |                            |                   |               |          | than 300DPI support)                              |
   +----------------------------------------------------------------------------------------------------------------------------------------------+

Сконввертировано со страницы на sane-project.org:
$ sed -n '852,857p; 1068,1071p' ./SANE-Supported-Devices.txt
  Manufacturer: Canon

   Link(s): http://www.canon.com/

   +----------------------------------------------------------------------------------------------------------------------------------------------+
   |        Model        |  Interface   |    USB id     |   Status    |              Comment               |     Backend      |      Manpage      |
   |---------------------+--------------+---------------+-------------+------------------------------------+------------------+-------------------|
   |  CanoScan LiDE 400  |     USB      | 0x04a9/0x1912 |  Complete   | All resolutions supported (up to   |      pixma       |    sane-pixma     |
   |                     |              |               |             | 4800DPI)                           |     (0.27.7)     |                   |
   |---------------------+--------------+---------------+-------------+------------------------------------+------------------+-------------------|

Оффлайн it3kor

  • Завсегдатай
  • *
  • Сообщений: 6
Привет всем.
В общем проблема такая: моноблок asus с alt linux spt 7 + Canon lide 400.
scan-find-scaner -q корректно все находит.
Но scanimage -L видит вэбкамеру от моноблока. Соответственно, ничего не работает... xsane запускается и думает что сканер это вэбкамера.
Нужна помощь сообщества специалистов. Давайте попробуем победить бяку?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 581
    • Домашняя страница
    • Email
Скачайте драйвера с сайта Canon (если есть), обратитесь в техподдержку Canon.
Андрей Черепанов (cas@)

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 6 994
    • Email
Сноси Винду, переходи на Линукс ! :)

Оффлайн it3kor

  • Завсегдатай
  • *
  • Сообщений: 6

Оффлайн it3kor

  • Завсегдатай
  • *
  • Сообщений: 6
Скачайте драйвера с сайта Canon (если есть), обратитесь в техподдержку Canon.

Драйвера скачал - не ставятся... пишет нужен glib - мол установите. А я его ставлю пишет он последней версии....

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 581
    • Домашняя страница
    • Email
Смотрите внимательнее. И техподдержка Canon ждёт обращений.
Андрей Черепанов (cas@)

Оффлайн Vyacheslav

  • Завсегдатай
  • *
  • Сообщений: 6
    • Email
Еле-еле после танцев с бубнов встал принтер от WC 3335
Здравствуйте, поделитесь как смогли установить 3335? Я смог только через дравйвер 7335.