Автор Тема: Нет дисков после установки Альт  (Прочитано 3025 раз)

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 617
Re: Нет дисков после установки Альт
« Ответ #15 : 07.05.2021 08:55:07 »
Я знаю, что виндовый загрузчик MBR затирается и вместо него прописывается grub, с которого загружается либо винда либо линь. Но хотел этого избежать. дело в том, что были случаи,
когда делая именно так я терял ВСЁ, если что-то случалось с линуксом, а они на одном диске и через один загрузчик... Неприятно было.
Ну не надо преувеличивать. "Потерять ВСЁ" - это когда весь диск затирается (dd if=/dev/zero of=/dev/sda). А когда затирается или неверно прописывается только MBR, то практически всё нормально восстанавливается при помощи того же testdisk.
Теперь: переустановил, загрузчику указал ставиться на виндовский диск. Он отказывается, пишет про какую-то "ошибку и невозможность загрузчика на этом диске."
Если хотите, чтобы была двойная загрузка (Windows и Linux), сначала определите, в каком режиме у Вас загружается Windows - Legacy (MBR) или UEFI. И в этом же режиме надо загружать инсталлятор с флэшки, чтобы Linux поставил загрузчик соответствующим образом.
Кстати, эта тема на форуме обсуждалась уже не один раз с подробным расписыванием, что как почему и какие грабли могут встретиться.

ЗЫ. После экспериментов на виртуалках Вы сразу же выбрали нетривиальный вариант установки на реальное железо, который на виртуалке не проверяли, и сразу же прошлись по известным граблям. При этом про подробности, например про тип загрузки, приходится всем только догадываться.
« Последнее редактирование: 07.05.2021 08:59:34 от Александр Ерещенко »

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 797
Re: Нет дисков после установки Альт
« Ответ #16 : 07.05.2021 09:05:17 »
Если хотите, чтобы была двойная загрузка (Windows и Linux), сначала определите, в каком режиме у Вас загружается Windows - Legacy (MBR) или UEFI. И в этом же режиме надо загружать инсталлятор с флэшки, чтобы Linux поставил загрузчик соответствующим образом.
Кстати, эта тема на форуме обсуждалась уже не один раз с подробным расписыванием, что как почему и какие грабли могут встретиться.
Это не на форуме, а в инсталляторе большими буквами должно быть написано.

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 617
Re: Нет дисков после установки Альт
« Ответ #17 : 07.05.2021 09:24:57 »
И как вы собирались через биос загружаться с ssd, если он его не видит
Я собирался, когда ещё не знал, что биос его не видит. Да и когда увидел, что его нет в списке... как то подумал, может оттого, что он не подготовлен, не размечен, наконец...
Если в биос выставлен режим только UEFI, то в вариантах загрузки (Boot Menu) покажутся только те устройства, где есть EFI-раздел
Если включена поддержка Legacy (MBR), то покажутся все устройства вне зависимости, что содержится на них (и размеченные и неразмеченные)
Опять же, в биос обычно есть такая вещь, как список "порядок жестких дисков", и в загрузочном меню может показываться только первое устройство из этого списка. Все эти особенности на усмотрение производителя биос.

А до этого были? Нет в виде смонтированных дисков (D: E: F: и т.п.) или как устройств в диспетчере дисков ?
Флэшка была, естественно, ведь я её готовил для установки с неё.
SSD был и в "Диспетчере устройств" и в "Управление компьютером"-"Управление дисками".

А сегодня появился там же, но как пустой.
Но, самое странное, что и флэшка стала неразмеченной, 80Мб раздел UEFI, остальное- пустота. Мистика какая-то.
Никакой мистики.
После заливки образа iso на флэшку винда именно так и будет видеть её - efi-раздел загрузчика для варианта загрузки в UEFI и неразмеченный участок, в котором на самом деле записано содержимое iso-образа (файловая система iso9660, и под линукс её вполне можно смонтировать).
А тот исправный "неизвестный" для винды раздел - это судя по всему корневой раздел установленной Вами системы линукс в формате ext4.
А виндовс, увы, видит только "свои" файловые системы. Видимо, в MS считают, что ни к чему их пользователям (да и админам) знать "лишнее".

ЗЫ. Странно, что Вы 15 лет пробуя в виртуалках линукс, так и не узнали всего, что я выше понаписал ... :(((

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 617
Re: Нет дисков после установки Альт
« Ответ #18 : 07.05.2021 09:31:40 »
Если хотите, чтобы была двойная загрузка (Windows и Linux), сначала определите, в каком режиме у Вас загружается Windows - Legacy (MBR) или UEFI. И в этом же режиме надо загружать инсталлятор с флэшки, чтобы Linux поставил загрузчик соответствующим образом.
Кстати, эта тема на форуме обсуждалась уже не один раз с подробным расписыванием, что как почему и какие грабли могут встретиться.
Это не на форуме, а в инсталляторе большими буквами должно быть написано.
По-умолчанию предполагается, что система на компьютере одна. Вариант, когда на компьютере несколько систем - это именно нетривиальный.
Вот у MS в этом плане политика вообще простая при установке - если ранее была система не от MS, то её как будто и не было.
А насчет UEFI/MBR - это вообще отдельный разговор.
« Последнее редактирование: 07.05.2021 09:33:49 от Александр Ерещенко »

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 617
Re: Нет дисков после установки Альт
« Ответ #19 : 07.05.2021 10:06:16 »
И отвлечённо о наболевшем.
Как я понимаю Андрея (Skull). Он, видно, что уже устал от одного и того же.
Часто новички, задающие вопросы на форуме, не утруждают себя для начала ознакомиться с базовыми знаниями в том вопросе, где у них возникла проблема. Иначе возможно и вопроса бы и не было.
И когда Андрей коротко отсылает к документации (он, как понял, заходит на форум с телефона, и "простыни" особо не попишешь), то в ответ начинают обижаться.

К тому же, в вопросах часто проблему описывают крайне поверхностно, почему-то подразумевая, что у остальных всё всегда так же, как и у спрашивающего. И приходится догадываться, что же там на самом деле происходит, и долго вытаскивать весьма важные подробности, от которых правильный ответ на заданный вопрос зависит с точностью "до наоборот".
Чтобы правильно ответить на вопрос, проблему надо воспроизвести. А так, как обычно любят описывать проблему, то действительно у остальных при таким образом описанных условиях "всё работает".

Поэтому, уважаемый Yojik, не надо обижаться. Вопросы тоже надо учиться задавать. В процессе правильно формулирования вопроса часто  можно уже и найти ответ.

Оффлайн andrew_b

  • Давно тут
  • **
  • Сообщений: 476
Re: Нет дисков после установки Альт
« Ответ #20 : 07.05.2021 10:54:48 »
Как я понимаю Андрея (Skull). Он, видно, что уже устал от одного и того же.
Часто новички, задающие вопросы на форуме, не утруждают себя для начала ознакомиться с базовыми знаниями в том вопросе, где у них возникла проблема. Иначе возможно и вопроса бы и не было.
И когда Андрей коротко отсылает к документации (он, как понял, заходит на форум с телефона, и "простыни" особо не попишешь), то в ответ начинают обижаться.
Тут был Drool, который ушёл с форума именно по этой причине (и не он, по-моему, один). Вы его, наверное, уже не застали. (Ох ты, уже больше 10 лет прошло.) Да, годы идут, а пользователи не меняются.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 5 797
Re: Нет дисков после установки Альт
« Ответ #21 : 07.05.2021 11:54:37 »
Если в биос выставлен режим только UEFI, то в вариантах загрузки (Boot Menu) покажутся только те устройства, где есть EFI-раздел
на некоторых материнках может показать и возможность загрузиться в UEFI или legacy режиме, причем второе бывает и по умолчанию выбрано (особенно когда грузишься по F10/F12 - boot select...)

Оффлайн rabochyITs

  • Давно тут
  • **
  • Сообщений: 764
  • Евгений
Re: Нет дисков после установки Альт
« Ответ #22 : 07.05.2021 13:01:09 »
на некоторых материнках
Верное дополнение, я такие "сделанные для людей" тоже видел, но вот есть такие, которые Legasy режим либо прячут хитро, либо лочат, либо еще как, в стиле MS меню-кнопка пуск ), пытаются спрятать.  В моем примере, я только в efi мог загрузиться.

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 1 065
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Нет дисков после установки Альт
« Ответ #23 : 07.05.2021 16:50:55 »
В моем примере, я только в efi мог загрузиться.
С какой материнкой?

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 1 065
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Нет дисков после установки Альт
« Ответ #24 : 07.05.2021 16:53:45 »
Хотя всё это напоминает балаган.
Как по мне, балаган - это когда несколько систем ставятся на один жёсткий диск, а когда на разные - вполне приемлимо.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 682
Re: Нет дисков после установки Альт
« Ответ #25 : 07.05.2021 17:04:08 »
И как вы собирались через биос загружаться с ssd, если он его не видит
Я собирался, когда ещё не знал, что биос его не видит. Да и когда увидел, что его нет в списке... как то подумал, может оттого, что он не подготовлен, не размечен, наконец...
Если в биос выставлен режим только UEFI, то в вариантах загрузки (Boot Menu) покажутся только те устройства, где есть EFI-раздел
Если включена поддержка Legacy (MBR), то покажутся все устройства вне зависимости, что содержится на них (и размеченные и неразмеченные)
Опять же, в биос обычно есть такая вещь, как список "порядок жестких дисков", и в загрузочном меню может показываться только первое устройство из этого списка. Все эти особенности на усмотрение производителя биос.

Наверное стоит развернуть.
Для Yojik:

Есть ли подводные камни, в самой лучшей в мире технологии, такой как UEFI BIOS?
Есть и большие, как же без них:
А вот теперь фото!

Эта кнопка Novo особенно нужна по причине того запа*ла, которое может устроить UEFI вместе с Windows. Но при OS Optimized Default [Disabled], если загрузка более чем желаельна и приоритетна через Legacy, эта кнопка не обязательна. Но в ряде ситуаций, лишней она никогда не будет.

Подводный камень тут вот в чём:
...
Lenovo G50-80:
$ cat /run/media/user/ALT\ p9\ xfce-sysv_x86_64/.disk/info
ALT p9 xfce-sysv/x86_64 build 2020-09-12
...
# parted -l | grep '^Диск\|^Таб\|^Номер\|^ 1' | head -n 4
Диск /dev/sda: 500GB
Таблица разделов: gpt
Номер  Начало  Конец  Размер  Файловая система  Имя                           Флаги
 1     1049kB  274MB  273MB   fat32             EFI system partition          загрузочный, esp
# dd if=/dev/sda of=mbr-sda.bin bs=512 count=1
# hexdump -C -s 446 ./mbr-sda.bin
000001be  00 00 02 00 ee ff ff ff  01 00 00 00 2f 60 38 3a  |............/`8:|
000001ce  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001fe  55 aa                                             |U.|
00000200


InsideH20 Setup Utility

Security
Secure Boot [Disabled]

Boot
Boot Mode [Legacy Support]
Boot Priority [Legacy First]

Exit
OS Optimized Defaults [Disabled]

Comment for OS Optimized Defaults
[Disabled]
When load default values, will load
legacy support mode default values.


...

При таблице gpt и загрузке одной из операционных систем через UEFI, например в UEFI BIOS Lenovo G50, если линукс грузится через Protective MBR, всё будет идти хорошо до тех пор, пока хотя бы один раз не загрузится W10. После этого, несмотря на Boot Priority [Legacy First] в UEFI BIOS Lenovo G50, грузится будет только она, игнорируя Boot Priority [Legacy First] в BIOS.
Чтобы умолчанием, всегда и без исключений грузился загрузчик линукс из MBR, расположенного на винчестере с GPT, в UEFI BIOS Lenovo G50, в секции Exit, существует опция OS Optimized Defaults, по-умолчанию установленная в Enabled, отдавая приоритет UEFI загрузке. Установка этой опции в Disabled, заставляет UEFI BIOS Lenovo G50, по-умолчанию, всегда и без исключений использовать загрузчик MBR, если существует.
 
Если загрузка линукс идёт через MBR на GPT, желательно (но не обязательно), создавать раздел BIOS Boot Partition размером в мегабайт не содержащий файловую. Для встраивания загрузчика grub второй стадии. Если этого раздела нет, то переустановка grub в MBR на винчестер с GPT, возможна будет только через опцию force:
Приёмы профессиональной работы в shell: Установка GRUB2 в MBR


В таблице разделов GPT, LBA 0, отдан под первый сектор MBR (Protective MBR):
# hexdump -s 446 ./mbr-sda.bin
00001be 0000 0002 ffee ffff 0001 0000 602f 3a38
00001ce 0000 0000 0000 0000 0000 0000 0000 0000
*
00001fe aa55                                   
0000200

размером в 512 байт (счёт адресов с нуля):
# ./base.sh 0x00001ff
hex=1FF    dec=511    oct=777    bin=111111111

и таблица разделов в MBR начинается с адреса 01be по смещению в 446 байт.

Сам EFI раздел
# fdisk -l /dev/sda | grep -i 'Тип\|Устр\|sda1 \|sda2 \|sda8 \|sda9 \|sda10 '
Тип метки диска: gpt
Устр-во       начало     Конец   Секторы Размер Тип
/dev/sda1       2048    534527    532480   260M EFI
/dev/sda2     534528    567295     32768    16M Зарезервированный раздел Microsoft
/dev/sda8  315979776 463421951 147442176  70,3G Microsoft basic data
/dev/sda9  463781888 819761151 355979264 169,8G Microsoft basic data
/dev/sda10 860719104 882443519  21724416  10,4G Microsoft basic data
# parted -l | head -n 19 | grep 'Таблица\|Флаги$\|^ 1\|^ 2\|^ 8\|^ 9\|^10'
Таблица разделов: gpt
Номер  Начало  Конец  Размер  Файловая система  Имя                           Флаги
 1     1049kB  274MB  273MB   fat32             EFI system partition          загрузочный, esp
 2     274MB   290MB  16,8MB                    Microsoft reserved partition  msftres
 8     162GB   237GB  75,5GB  ext4                                            legacy_boot, msftdata
 9     237GB   420GB  182GB   ext4                                            msftdata
10     441GB   452GB  11,1GB  linux-swap(v1)                                  msftdata

начинается со второго мегабайта от начала жёсткого диска
# echo '2048*512' | bc -l
1048576
# echo '1048576/1024^2' | bc -l
1.00000000000000000000

Со второго сектора в 512 байт, начинается LBA 1, первые восемь байт которого, отданы под сигнатуру:
# hexdump -s 512 -C ./mbr-sda-1MiB.bin | head -n 1
00000200  45 46 49 20 50 41 52 54  00 00 01 00 5c 00 00 00  |EFI PART....\...|


Что это всё даёт?
Это даёт, при наличии Lecacy/CSM в UEFI BIOS, полностью развязать по загрузке две операционные системы находящихся на одном винчестере. Одна из которых будет грузиться через UEFI, другая через MBR (Protective MBR).
При загрузке линукс через Protective MBR, единственная проблема возникнет на os-prober. Бестолковый os-prober не понимает, что например W10 грузящуюся через UEFI, в Legacy mode невозможно загрузить даже теоретически. И всегда будет прописывать её опцией загрузки в grub.
В этом смысле намного более лучшим был GRUB 1.99:
Если раздел с boot не был смонтирован, то os-prober не видел эту операционную систему и не прописывал её опцией загрузчика. Т.о., это было чуть сложнее для пользователя, но давало гибкую возможность прописывать опциями только то, что необходимо.
Но прошло время, grub улучшили, и он потерял эту функциональность.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 682
Re: Нет дисков после установки Альт
« Ответ #26 : 07.05.2021 17:25:31 »
Но, самое странное, что и флэшка стала неразмеченной, 80Мб раздел UEFI, остальное- пустота. Мистика какая-то.

В W10? :-)
А вы на структуру разделов альтового образа ещё посмотрите.
EFI раздел (sdc2) находится внутри первого раздела (sdc1), чего в классической разбивке на разделы, не может быть даже теоретически:
# fdisk -l /dev/sdc | tail -n 3
Устр-во    Загрузочный начало   Конец Секторы Размер Идентификатор Тип
/dev/sdc1  *               64 1886207 1886144   921M             0 Пустой
/dev/sdc2                 948   14963   14016   6,9M            ef EFI (FAT-12/16/32)
# parted -l | tail -n 5

Номер  Начало  Конец   Размер  Тип      Файловая система  Флаги
 2     485kB   7662kB  7176kB  primary                    esp



Первый раздел расположен с 64-го по 1886207-й сектор. А EFI с 948-го по 14963-й сектор. Т.е. внутри первого раздела с типом Пустой.

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 1 065
  • Дмитрий/Dmitry/德米特里/दिमित्री
Re: Нет дисков после установки Альт
« Ответ #27 : 07.05.2021 17:42:08 »
Ну его, короче, этот W10 ;-D ;-D ;-D

Оффлайн Yojik

  • Завсегдатай
  • *
  • Сообщений: 12
Re: Нет дисков после установки Альт
« Ответ #28 : 07.05.2021 18:47:53 »
Если хотите, чтобы была двойная загрузка (Windows и Linux), сначала определите, в каком режиме у Вас загружается Windows - Legacy (MBR) или UEFI. И в этом же режиме надо загружать инсталлятор с флэшки, чтобы Linux поставил загрузчик соответствующим образом.
Кстати, эта тема на форуме обсуждалась уже не один раз с подробным расписыванием, что как почему и какие грабли могут встретиться.

ЗЫ. После экспериментов на виртуалках Вы сразу же выбрали нетривиальный вариант установки на реальное железо, который на виртуалке не проверяли, и сразу же прошлись по известным граблям. При этом про подробности, например про тип загрузки, приходится всем только догадываться.
Извиняюсь. Да, и там и там через UEFI.

Оффлайн Yojik

  • Завсегдатай
  • *
  • Сообщений: 12
Re: Нет дисков после установки Альт
« Ответ #29 : 07.05.2021 18:54:18 »
Странно, что Вы 15 лет пробуя в виртуалках линукс, так и не узнали всего, что я выше понаписал ... :(((
Мне это тоже печально сознавать, но, такова уж была моя задача - выбирать и знакомиться с незнакомыми зверями. Не до тонкостей в таких вот областях.
Я в них, мягко говоря не спец совсем. Помню только в Мандриве монтировал диски в Терминале и дрова на видеокарту. Всё пальчиками. Не понравилось.
Теперь то другое дело, но и тут вот споткнулся об ровное место из-за своей некомпетентности. Извините, не до сих пор не вдавался в глубину вопроса.
Ну а теперь вот придётся.