Автор Тема: Проблемы с i586-glibc-core и 32битными проложениями  (Прочитано 3262 раз)

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Alt linux 9 Starterkits

Мне понадобилось установить wine64, и для его установки пришлось утановить определённые версии некоторых зависимостей, вроде даже xorg-server обновить
В итоге перелапатив куча пакетов он всё же установился, но перестали устанавливаться 32 битные пакеты

Пример с установкой стим:
# apt-get install steam
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-steam.32bit для 'steam'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  i586-steam.32bit: Требует: i586-glibc-pthread (>= 2.15)
                    Требует: i586-glibc-nss (>= 2.15)
                    Требует: i586-libdbusmenu-gtk2
                    Требует: i586-libGL
                    Требует: i586-libnss
E: Извините, `битые' пакеты
# apt-get install i586-glibc-pthread
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-glibc-pthread.32bit для 'i586-glibc-pthread'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  i586-glibc-pthread.32bit: Требует: glibc-pthread (= 6:2.23-alt3.M80P.2)
                            Требует: i586-glibc-core (= 6:2.23-alt3.M80P.2)
                            Требует: libgcc_s.so.1
E: Извините, `битые' пакеты
23:28:07 [root@main]:~
# apt-get install i586-glibc-core
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-glibc-core.32bit для 'i586-glibc-core'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  i586-glibc-core.32bit: Требует: glibc-core (= 6:2.23-alt3.M80P.2)
E: Извините, `битые' пакеты

В итоге всё сводиться к glibc-core версии 6:2.23-alt3.M80P.2, но при попытке поставить его система пытаеться удалить абсолютно все пакеты

Пытался сделать так:
apt-repo rm all
apt-repo add p8
apt-get update
apt-get dist-upgrade
Результатов не дало


Как можно решить проблему данную?

Оффлайн Александр Ерещенко

  • Давно тут
  • **
  • Сообщений: 580
Пытался сделать так:
apt-repo rm all
apt-repo add p8
apt-get update
apt-get dist-upgrade
Результатов не дало

А почему p8 ? У Вас же p9 (Alt linux 9 Starterkits)
Кажется, Вы понамешали сразу две платформы, отсюда и весь этот бардак с зависимостями.
Что показывает apt-repo ?

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Я начал чудить с зависимостями уже после того, как перестали работать приложения, да и пакеты не трогал толком, так что врятли они выноваты тут, все беды начались, из-за зависимостей к wine64
А вот что в примере указал p8 - не знаю

Сейчас apt-repo выглядит так:
# apt-repo list
rpm [p9] http://ftp.altlinux.org/pub/distributions/ALTLinux p9/branch/x86_64 classic
rpm [p9] http://ftp.altlinux.org/pub/distributions/ALTLinux p9/branch/x86_64-i586 classic
rpm [p9] http://ftp.altlinux.org/pub/distributions/ALTLinux p9/branch/noarch classic

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 564
Пытался сделать так:
apt-repo rm all
apt-repo add p8
apt-get update
apt-get dist-upgrade

Вот тут, вы уже сделали так, - система на p9 нацелена на p8 с обновлённой базой, в то врема как i586-glibc-pthread, в p9, уже в версии 2.27-alt13, а apt-get install у вас не может его найти:
Alt linux 9 Starterkits

Мне понадобилось установить wine64,
...
# apt-get install steam
...
Следующие пакеты имеют неудовлетворенные зависимости:
  i586-steam.32bit: Требует: i586-glibc-pthread (>= 2.15)
                    Требует: i586-glibc-nss (>= 2.15)
                    Требует: i586-libdbusmenu-gtk2
                    Требует: i586-libGL
                    Требует: i586-libnss
E: Извините, `битые' пакеты
...
...


Как можно решить проблему данную?

Не тащить в систему на p9 rpm, где зависимости жёсткие, пакеты из репозитория версией ниже, чем на котором собрана система.

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 564
Чистая alt-p9-xfce-sysv-20210605-x86_64:
[root@localhost ~]# apt-get update && apt-get install steam wine-full -s
Получено: 1 http://mirror.yandex.ru p9/branch/x86_64 release [1954B]
Получено: 2 http://mirror.yandex.ru p9/branch/x86_64-i586 release [1175B]
Получено: 3 http://mirror.yandex.ru p9/branch/noarch release [1545B]
Получено 4674B за 1s (3244B/s).
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64/classic release
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/x86_64-i586/classic release
Найдено http://mirror.yandex.ru p9/branch/noarch/classic pkglist
Найдено http://mirror.yandex.ru p9/branch/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано i586-steam.32bit для 'steam'
Следующие дополнительные пакеты будут установлены:
  cabextract i586-bzlib.32bit i586-fontconfig.32bit i586-glib2.32bit i586-glibc-core.32bit i586-glibc-nss.32bit
  i586-glibc-pthread.32bit i586-libEGL-mesa.32bit i586-libEGL.32bit i586-libGL.32bit i586-libGLX-mesa.32bit i586-libGLX.32bit
  i586-libX11.32bit i586-libXau.32bit i586-libXcomposite.32bit i586-libXcursor.32bit i586-libXdamage.32bit i586-libXdmcp.32bit
  i586-libXext.32bit i586-libXfixes.32bit i586-libXft.32bit i586-libXi.32bit i586-libXinerama.32bit i586-libXrandr.32bit
  i586-libXrender.32bit i586-libXxf86vm.32bit i586-libatk.32bit i586-libavahi.32bit i586-libblkid.32bit i586-libcairo.32bit
  i586-libcups.32bit i586-libdatrie.32bit i586-libdbus.32bit i586-libdbusmenu-gtk2.32bit i586-libdbusmenu.32bit i586-libdrm.32bit
  i586-libelf.32bit i586-libexpat.32bit i586-libffi6.32bit i586-libfreetype.32bit i586-libfribidi.32bit i586-libgbm.32bit
  i586-libgcc1.32bit i586-libgcrypt20.32bit i586-libgdk-pixbuf.32bit i586-libgio.32bit i586-libglvnd.32bit i586-libgmp10.32bit
  i586-libgnutls30.32bit i586-libgpg-error.32bit i586-libgraphite2.32bit i586-libgtk+2.32bit i586-libharfbuzz.32bit
  i586-libhogweed4.32bit i586-libidn2.32bit i586-libjasper.32bit i586-libjbig.32bit i586-libjpeg.32bit i586-liblz4.32bit
  i586-liblzma.32bit i586-libmount.32bit i586-libnettle6.32bit i586-libnsl1.32bit i586-libnspr.32bit i586-libnss.32bit
  i586-libp11-kit.32bit i586-libpango.32bit i586-libpciaccess.32bit i586-libpcre3.32bit i586-libpixman.32bit i586-libpng16.32bit
  i586-libselinux.32bit i586-libsqlite3.32bit i586-libsystemd.32bit i586-libtasn1.32bit i586-libthai.32bit i586-libtiff5.32bit
  i586-libunistring2.32bit i586-libuuid.32bit i586-libwayland-client.32bit i586-libwayland-server.32bit i586-libwebp7.32bit
  i586-libxcb.32bit i586-libxshmfence.32bit i586-libzstd.32bit i586-steam.32bit i586-zlib.32bit libSDL2 libdbusmenu libdbusmenu-gtk2
  libfaudio0 libnsl1 libopenal1 libspirv-tools0 libtxc_dxtn libvkd3d1 libwine libwine-gl wine wine-gecko wine-mono wine-programs
  winetricks
Следующие НОВЫЕ пакеты будут установлены:
  cabextract i586-bzlib.32bit i586-fontconfig.32bit i586-glib2.32bit i586-glibc-core.32bit i586-glibc-nss.32bit
  i586-glibc-pthread.32bit i586-libEGL-mesa.32bit i586-libEGL.32bit i586-libGL.32bit i586-libGLX-mesa.32bit i586-libGLX.32bit
  i586-libX11.32bit i586-libXau.32bit i586-libXcomposite.32bit i586-libXcursor.32bit i586-libXdamage.32bit i586-libXdmcp.32bit
  i586-libXext.32bit i586-libXfixes.32bit i586-libXft.32bit i586-libXi.32bit i586-libXinerama.32bit i586-libXrandr.32bit
  i586-libXrender.32bit i586-libXxf86vm.32bit i586-libatk.32bit i586-libavahi.32bit i586-libblkid.32bit i586-libcairo.32bit
  i586-libcups.32bit i586-libdatrie.32bit i586-libdbus.32bit i586-libdbusmenu-gtk2.32bit i586-libdbusmenu.32bit i586-libdrm.32bit
  i586-libelf.32bit i586-libexpat.32bit i586-libffi6.32bit i586-libfreetype.32bit i586-libfribidi.32bit i586-libgbm.32bit
  i586-libgcc1.32bit i586-libgcrypt20.32bit i586-libgdk-pixbuf.32bit i586-libgio.32bit i586-libglvnd.32bit i586-libgmp10.32bit
  i586-libgnutls30.32bit i586-libgpg-error.32bit i586-libgraphite2.32bit i586-libgtk+2.32bit i586-libharfbuzz.32bit
  i586-libhogweed4.32bit i586-libidn2.32bit i586-libjasper.32bit i586-libjbig.32bit i586-libjpeg.32bit i586-liblz4.32bit
  i586-liblzma.32bit i586-libmount.32bit i586-libnettle6.32bit i586-libnsl1.32bit i586-libnspr.32bit i586-libnss.32bit
  i586-libp11-kit.32bit i586-libpango.32bit i586-libpciaccess.32bit i586-libpcre3.32bit i586-libpixman.32bit i586-libpng16.32bit
  i586-libselinux.32bit i586-libsqlite3.32bit i586-libsystemd.32bit i586-libtasn1.32bit i586-libthai.32bit i586-libtiff5.32bit
  i586-libunistring2.32bit i586-libuuid.32bit i586-libwayland-client.32bit i586-libwayland-server.32bit i586-libwebp7.32bit
  i586-libxcb.32bit i586-libxshmfence.32bit i586-libzstd.32bit i586-steam.32bit i586-zlib.32bit libSDL2 libdbusmenu libdbusmenu-gtk2
  libfaudio0 libnsl1 libopenal1 libspirv-tools0 libtxc_dxtn libvkd3d1 libwine libwine-gl wine wine-full wine-gecko wine-mono
  wine-programs winetricks
0 будет обновлено, 104 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Inst cabextract (1.7-alt1@1534340181 p9:1622821529/ALT Linux p9)
Inst i586-glibc-core.32bit (6:2.27-alt13:p9+261868.100.3.1@1606153817 p9:1622821693/ALT Linux p9)
Inst i586-bzlib.32bit (1:1.0.8-alt1:p9+261810.100.1.1@1605720034 p9:1622821693/ALT Linux p9)
Inst i586-libexpat.32bit (2.2.10-alt1:p9+261554.100.1.1@1605181844 p9:1622821693/ALT Linux p9)
Inst i586-libgcc1.32bit (8.4.1-alt0.p9.1:p9+247559.100.2.1@1585935537 p9:1622821693/ALT Linux p9)
Inst i586-libffi6.32bit (1:3.2.1-alt3:p9+251949.100.1.1@1590158797 p9:1622821693/ALT Linux p9)
Inst i586-libpcre3.32bit (8.44-alt1:p9+249555.100.1.1@1586529400 p9:1622821693/ALT Linux p9)
Inst i586-glibc-pthread.32bit (6:2.27-alt13:p9+261868.100.3.1@1606153849 p9:1622821693/ALT Linux p9)
Inst i586-glib2.32bit (2.60.7-alt1:p9+237353.100.2.2@1568396547 p9:1622821693/ALT Linux p9)
Inst i586-libgraphite2.32bit (1.3.13-alt2:sisyphus+226799.100.1.1@1554648552 p9:1622821693/ALT Linux p9)
Inst i586-libharfbuzz.32bit (2.6.2-alt1:p9+238790.200.1.1@1570623864 p9:1622821693/ALT Linux p9) []
Inst i586-zlib.32bit (1.2.11-alt1:sisyphus+221902.6000.4.1@1550629707 p9:1622821693/ALT Linux p9) []
Inst i586-libpng16.32bit (1.6.36-alt1:sisyphus+219478.100.1.1@1547633779 p9:1622821693/ALT Linux p9) []
Inst i586-libfreetype.32bit (2.10.1-alt1.1.p9.1:p9+260179.200.3.1@1603971642 p9:1622821693/ALT Linux p9)
Inst i586-libuuid.32bit (2.33.2-alt2:p9+254003.100.1.1@1593706650 p9:1622821693/ALT Linux p9)
Inst i586-fontconfig.32bit (2.13.1-alt1:p9+247340.200.3.1@1583425312 p9:1622821693/ALT Linux p9)
Inst i586-glibc-nss.32bit (6:2.27-alt13:p9+261868.100.3.1@1606153847 p9:1622821693/ALT Linux p9)
Inst i586-libpciaccess.32bit (1:0.14-alt1@1528980173 p9:1622821693/ALT Linux p9)
Inst i586-libdrm.32bit (1:2.4.105-alt2:p9+271012.100.1.1@1621246364 p9:1622821693/ALT Linux p9)
Inst i586-libwayland-client.32bit (1.18.0-alt1:p9+260591.100.12.1@1606235415 p9:1622821693/ALT Linux p9)
Inst i586-libwayland-server.32bit (1.18.0-alt1:p9+260591.100.12.1@1606235425 p9:1622821693/ALT Linux p9)
Inst i586-libXau.32bit (1.0.9-alt1:sisyphus+223149.200.2.1@1551291810 p9:1622821693/ALT Linux p9)
Inst i586-libXdmcp.32bit (1.1.3-alt1:sisyphus+225206.600.1.2@1552983997 p9:1622821693/ALT Linux p9)
Inst i586-libxcb.32bit (1.13.1-alt1:sisyphus+226527.100.2.2@1554594544 p9:1622821693/ALT Linux p9)
Inst i586-libX11.32bit (3:1.7.1-alt1:p9+272150.200.1.1@1621947815 p9:1622821693/ALT Linux p9)
Inst i586-libXext.32bit (1.3.4-alt1:sisyphus+225206.700.1.2@1552984001 p9:1622821693/ALT Linux p9)
Inst i586-libXfixes.32bit (5.0.3-alt1:sisyphus+226736.100.2.2@1554615256 p9:1622821693/ALT Linux p9)
Inst i586-libXxf86vm.32bit (1.1.4-alt2@1527672374 p9:1622821693/ALT Linux p9)
Inst i586-libselinux.32bit (1:3.1-alt1:p9+257413.200.9.1@1610359528 p9:1622821693/ALT Linux p9)
Inst i586-libxshmfence.32bit (1.3-alt1:sisyphus+223149.1000.2.1@1551291837 p9:1622821693/ALT Linux p9)
Inst i586-libGLX-mesa.32bit (4:21.0.3-alt1:p9+271012.200.3.1@1621246359 p9:1622821693/ALT Linux p9)
Inst i586-libgbm.32bit (4:21.0.3-alt1:p9+271012.200.3.1@1621246368 p9:1622821693/ALT Linux p9)
Inst i586-libEGL-mesa.32bit (4:21.0.3-alt1:p9+271012.200.3.1@1621246355 p9:1622821693/ALT Linux p9)
Inst i586-libglvnd.32bit (7:1.3.2-alt0.p9:p9+265957.240.8.1@1617622799 p9:1622821693/ALT Linux p9)
Inst i586-libEGL.32bit (7:1.3.2-alt0.p9:p9+265957.240.8.1@1617622765 p9:1622821693/ALT Linux p9)
Inst i586-libGLX.32bit (7:1.3.2-alt0.p9:p9+265957.240.8.1@1617622779 p9:1622821693/ALT Linux p9)
Inst i586-libGL.32bit (7:1.3.2-alt0.p9:p9+265957.240.8.1@1617622771 p9:1622821693/ALT Linux p9)
Inst i586-libXcomposite.32bit (0.4.5-alt1:sisyphus+225206.300.1.2@1552983983 p9:1622821693/ALT Linux p9)
Inst i586-libXrender.32bit (0.9.10-alt1:p9+261891.200.2.1@1606149362 p9:1622821693/ALT Linux p9)
Inst i586-libXcursor.32bit (1.2.0-alt1:sisyphus+225206.400.1.2@1552983988 p9:1622821693/ALT Linux p9)
Inst i586-libXdamage.32bit (1.1.5-alt1:sisyphus+225206.500.1.2@1552983992 p9:1622821693/ALT Linux p9)
Inst i586-libXft.32bit (2.3.3-alt1:sisyphus+225206.1000.3.2@1552989125 p9:1622821693/ALT Linux p9)
Inst i586-libXi.32bit (1.7.9-alt2:sisyphus+226377.100.1.2@1554261099 p9:1622821693/ALT Linux p9)
Inst i586-libXinerama.32bit (1.1.4-alt1:sisyphus+223149.300.2.1@1551291815 p9:1622821693/ALT Linux p9)
Inst i586-libXrandr.32bit (1.5.2-alt1:sisyphus+225206.1300.1.2@1552984015 p9:1622821693/ALT Linux p9)
Inst i586-libatk.32bit (2.32.0-alt1:sisyphus+225059.600.3.2@1552928739 p9:1622821693/ALT Linux p9)
Inst i586-libgpg-error.32bit (1.36-alt1:p9+261942.140.4.1@1606238832 p9:1622821693/ALT Linux p9)
Inst i586-libgcrypt20.32bit (1.8.5-alt3:p9+261942.200.4.1@1606238830 p9:1622821693/ALT Linux p9)
Inst i586-liblz4.32bit (1:1.9.2-alt1:p9+238696.500.1.1@1570238331 p9:1622821693/ALT Linux p9)
Inst i586-liblzma.32bit (5.2.5-alt1:p9+268339.40.3.1@1617267644 p9:1622821693/ALT Linux p9)
Inst i586-libzstd.32bit (1.4.3-alt1:p9+238696.400.1.1@1570238348 p9:1622821693/ALT Linux p9)
Inst i586-libsystemd.32bit (1:246.13-alt1:p9+265718.640.15.1@1618507504 p9:1622821693/ALT Linux p9)
Inst i586-libdbus.32bit (1.12.16-alt2:p9+240607.100.1.1@1573555076 p9:1622821693/ALT Linux p9)
Inst i586-libavahi.32bit (0.8-alt2:p9+270905.100.1.1@1619640444 p9:1622821693/ALT Linux p9)
Inst i586-libblkid.32bit (2.33.2-alt2:p9+254003.100.1.1@1593706627 p9:1622821693/ALT Linux p9)
Inst i586-libpixman.32bit (3:0.38.4-alt1:sisyphus+228006.100.1.1@1556037454 p9:1622821693/ALT Linux p9)
Inst i586-libcairo.32bit (1:1.16.0-alt1:sisyphus+226534.100.2.3@1554516315 p9:1622821693/ALT Linux p9)
Inst i586-libgmp10.32bit (6.1.2-alt3:sisyphus+229304.40.2.1@1557771843 p9:1622821693/ALT Linux p9)
Inst i586-libnettle6.32bit (3.4.1-alt1:sisyphus+226533.100.2.1@1554513459 p9:1622821693/ALT Linux p9)
Inst i586-libhogweed4.32bit (3.4.1-alt1:sisyphus+226533.100.2.1@1554513453 p9:1622821693/ALT Linux p9)
Inst i586-libunistring2.32bit (0.9.10-alt1:sisyphus+221902.4100.4.1@1550629700 p9:1622821693/ALT Linux p9)
Inst i586-libidn2.32bit (2.2.0-alt1:p9+229971.100.2.1@1558696662 p9:1622821693/ALT Linux p9)
Inst i586-libp11-kit.32bit (0.23.15-alt2:p9+254920.2400.19.1@1601677892 p9:1622821693/ALT Linux p9)
Inst i586-libtasn1.32bit (4.14-alt1:p9+235792.100.2.1@1565426141 p9:1622821693/ALT Linux p9)
Inst i586-libgnutls30.32bit (3.6.15-alt2:p9+268190.200.4.1@1616604870 p9:1622821693/ALT Linux p9)
Inst i586-libcups.32bit (2.3.3-alt2.op2:p9+267729.100.2.1@1616002298 p9:1622821693/ALT Linux p9)
Inst i586-libdatrie.32bit (0.2.9-alt1_6@1511686870 p9:1622821693/ALT Linux p9)
Inst libdbusmenu (16.04.0-alt1@1458417811 p9:1622821529/ALT Linux p9)
Inst libdbusmenu-gtk2 (16.04.0-alt1@1458417811 p9:1622821529/ALT Linux p9)
Inst i586-libelf.32bit (0.183-alt1:p9+266215.200.3.1@1614871630 p9:1622821693/ALT Linux p9)
Inst i586-libmount.32bit (2.33.2-alt2:p9+254003.100.1.1@1593706639 p9:1622821693/ALT Linux p9)
Inst i586-libgio.32bit (2.60.7-alt1:p9+237353.100.2.2@1568396631 p9:1622821693/ALT Linux p9)
Inst i586-libdbusmenu.32bit (16.04.0-alt1@1458418668 p9:1622821693/ALT Linux p9)
Inst i586-libjpeg.32bit (2:2.0.2-alt1:sisyphus+226996.100.1.1@1554908165 p9:1622821693/ALT Linux p9)
Inst i586-libjasper.32bit (2.0.22-alt1:p9+259398.100.5.1@1602881100 p9:1622821693/ALT Linux p9)
Inst i586-libjbig.32bit (2.1-alt1@1401381172 p9:1622821693/ALT Linux p9)
Inst i586-libwebp7.32bit (1.0.3-alt1:p9+234901.200.1.1@1563568121 p9:1622821693/ALT Linux p9)
Inst i586-libtiff5.32bit (4.0.10.0.57.f9fc01c3-alt1:sisyphus+226958.100.1.1@1554851347 p9:1622821693/ALT Linux p9)
Inst i586-libgdk-pixbuf.32bit (2.38.2-alt1:p9+237353.1000.2.2@1568396625 p9:1622821693/ALT Linux p9)
Inst i586-libfribidi.32bit (1.0.7-alt1:p9+238309.200.1.1@1569936548 p9:1622821693/ALT Linux p9)
Inst i586-libthai.32bit (0.1.28-alt1_1:sisyphus+226107.100.1.1@1554131653 p9:1622821693/ALT Linux p9)
Inst i586-libpango.32bit (1.44.6-alt1:p9+237353.700.2.2@1568396672 p9:1622821693/ALT Linux p9)
Inst i586-libgtk+2.32bit (2.24.32-alt3:sisyphus+227306.100.1.3@1555647521 p9:1622821693/ALT Linux p9)
Inst i586-libdbusmenu-gtk2.32bit (16.04.0-alt1@1458418672 p9:1622821693/ALT Linux p9)
Inst libnsl1 (6:2.27-alt13:p9+261868.100.3.1@1606152844 p9:1622821529/ALT Linux p9)
Inst i586-libnsl1.32bit (6:2.27-alt13:p9+261868.100.3.1@1606153853 p9:1622821693/ALT Linux p9)
Inst i586-libnspr.32bit (1:4.28-alt1:p9+254920.20.18.1@1601677880 p9:1622821693/ALT Linux p9)
Inst i586-libsqlite3.32bit (3.33.0-alt1:p9+258834.40.2.1@1601365863 p9:1622821693/ALT Linux p9)
Inst i586-libnss.32bit (3.56.0-alt1:p9+254920.30.20.1@1601677886 p9:1622821693/ALT Linux p9)
Inst i586-steam.32bit (1.0.0.70-alt1:p9+269315.100.1.1@1617991451 p9:1622821693/ALT Linux p9)
Inst libSDL2 (2.0.14-alt4:p9+268544.100.3.1@1617635717 p9:1622821529/ALT Linux p9)
Inst libfaudio0 (19.09-alt0.1.g65b787f:p9+240174.200.7.1@1576690734 p9:1622821529/ALT Linux p9)
Inst libopenal1 (1.19.1-alt1:sisyphus+222956.100.1.1@1551298513 p9:1622821529/ALT Linux p9)
Inst libspirv-tools0 (2020.3-alt1:p9+255691.200.3.2@1596819326 p9:1622821529/ALT Linux p9)
Inst libtxc_dxtn (1:1.0.1-alt1@1374475772 p9:1622821529/ALT Linux p9)
Inst libvkd3d1 (1.2-alt1:p9+259141.40.10.1@1602761771 p9:1622821529/ALT Linux p9)
Inst libwine (1:5.20.0.1-alt1:p9+260418.100.3.1@1604335199 p9:1622821529/ALT Linux p9)
Inst libwine-gl (1:5.20.0.1-alt1:p9+260418.100.3.1@1604335199 p9:1622821529/ALT Linux p9)
Inst wine-gecko (2.47.1-alt1:p9+244888.200.3.2@1580837300 p9:1622818633/ALT Linux p9)
Inst wine (1:5.20.0.1-alt1:p9+260418.100.3.1@1604335199 p9:1622821529/ALT Linux p9)
Inst wine-mono (5.1.1-alt1:p9+259141.230.10.1@1602762710 p9:1622818633/ALT Linux p9)
Inst winetricks (20210206-alt1:p9+267276.100.2.1@1614961458 p9:1622818633/ALT Linux p9)
Inst wine-programs (1:5.20.0.1-alt1:p9+260418.100.3.1@1604335199 p9:1622821529/ALT Linux p9)
Inst wine-full (1:5.20.0.1-alt1:p9+260418.100.3.1@1604335199 p9:1622821529/ALT Linux p9)
Conf cabextract (1.7-alt1@1534340181 p9:1622821529/ALT Linux p9)
...
[root@localhost ~]#

Все строки ^Conf вырезаны по причине:
Следующие ошибки возникли при попытке отправки сообщения:
Сообщение превышает максимально допустимую длину (21500 знаков).


Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 564
При этом локальную базу с интексами, нужно обновлять дважды в сутки.
До 15:45, на сервере была старая база.
После 15:45, на сервере появились и новые/обновлённые пакеты и новая база, а локальная база с индексами, без 'apt-get update' остаётся старой и без 'apt-get update', 'apt-get install' не сможет найти какие-то пакеты:
(сброс страницы из elinks как Файл=>Save formatted document)
$ sed "" p9-branch-x86_64-base.txt
                                      Index of /pub/distributions/ALTLinux/p9/branch/x86_64/base/

   ---------------------------------------------------------------------------------------------------------------------------------

 ../
 contents_index                                     04-Jun-2021 15:48           148669116
 pkglist.checkinstall.xz                            04-Jun-2021 15:45                7288
 pkglist.classic.xz                                 04-Jun-2021 15:45            19472412
 pkglist.debuginfo.xz                               04-Jun-2021 15:45             3398720
 pkglist.gostcrypto.xz                              04-Jun-2021 15:45               11888
 release                                            04-Jun-2021 15:45                1954
 release.checkinstall                               04-Jun-2021 15:45                 140
 release.classic                                    04-Jun-2021 15:45                 135
 release.debuginfo                                  04-Jun-2021 15:45                 137
 release.gostcrypto                                 04-Jun-2021 15:45                 138
 srclist.classic.xz                                 04-Jun-2021 15:45             1821752

   ---------------------------------------------------------------------------------------------------------------------------------

References

   Visible links
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/contents_index
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/pkglist.checkinstall.xz
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/pkglist.classic.xz
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/pkglist.debuginfo.xz
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/pkglist.gostcrypto.xz
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/release
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/release.checkinstall
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/release.classic
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/release.debuginfo
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/release.gostcrypto
   . http://ftp.altlinux.org/pub/distributions/ALTLinux/p9/branch/x86_64/base/srclist.classic.xz

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Не тащить в систему на p9 rpm, где зависимости жёсткие, пакеты из репозитория версией ниже, чем на котором собрана система.
Скорее всего это связано с тем, что я сидел на ветви http://mirror.yandex.ru p9/branch/, а потом перешёл на p9 из-за не достатка некоторых пакетов
Я попытался установить версии пакетов из alt-p9-xfce-sysv-20210605-x86_64, которую Вы указали, но всё же требуеться glibc-core=6:2.27-alt13:p9+261868.100.3.1

Зависящие пакеты:
# apt-cache rdepends glibc-core
glibc-core
Reverse Depends:
  glibc-pthread
  glibc-pthread
  libcrypt
  libstdc++6
  i586-glibc-core.32bit
  glibc-i18ndata
  glibc-i18ndata
  blocks
  appliance-base-glibc
  nvidia_glx_common
  libcrypt
  libnsl1
  libnsl1
  glibc-pthread
  glibc-pthread
  libstdc++6
  alterator-update-kernel

# rpm -qv glibc-pthread
glibc-pthread-2.32-alt2.x86_64

# rpm -qv glibc-pthread
glibc-pthread-2.32-alt2.x86_64

# rpm -qv libcrypt
libcrypt-4.4.17-alt1.x86_64

# rpm -qv libstdc++6
libstdc++6-10.2.1-alt3.x86_64

# rpm -qv i586-glibc-core.32bit
пакет i586-glibc-core.32bit не установлен

# rpm -qv glibc-i18ndata
пакет glibc-i18ndata не установлен

# rpm -qv blocks
пакет blocks не установлен

# rpm -qv appliance-base-glibc
пакет appliance-base-glibc не установлен

# rpm -qv nvidia_glx_common
пакет nvidia_glx_common не установлен

# rpm -qv libcrypt
libcrypt-4.4.17-alt1.x86_64

# rpm -qv libnsl1
пакет libnsl1 не установлен

# rpm -qv glibc-pthread
glibc-pthread-2.32-alt2.x86_64

# rpm -qv libstdc++6
libstdc++6-10.2.1-alt3.x86_64

# rpm -qv alterator-update-kernel
пакет alterator-update-kernel не установлен

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
При этом локальную базу с интексами, нужно обновлять дважды в сутки.
Понял, не знал, спасибо

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 564
steam, это виртуальный пакет
# apt-cache show steam
Виртуальный пакет steam предоставляется следующими пакетами:
  i586-steam.32bit 1.0.0.70-alt1:p9+269315.100.1.1@1617991451
You should explicitly select one to show.
E: Package steam is a virtual package with multiple providers.
# aptitude search ~nsteam | grep -v python
v   i586-steam                      -                                           
p   i586-steam.32bit                - Launcher for the Steam software distributi
v   steam                           -                                           

который в свою очередь подтянет зависимости
# apt-cache depends i586-steam.32bit
i586-steam.32bit-1.0.0.70-alt1:p9+269315.100.1.1@1617991451
  Требует: bash >= 4.4
  Требует: curl
  Требует: <i586-glibc-pthread>
    i586-glibc-pthread.32bit-6:2.27-alt13:p9+261868.100.3.1@1606153849
  Требует: <i586-glibc-nss>
    i586-glibc-nss.32bit-6:2.27-alt13:p9+261868.100.3.1@1606153847
  Требует: <i586-libdbusmenu-gtk2>
    i586-libdbusmenu-gtk2.32bit-16.04.0-alt1@1458418672
  Требует: <i586-libGL>
    i586-libGL.32bit-7:1.3.2-alt0.p9:p9+265957.240.8.1@1617622771
  Требует: <i586-libnsl1>
    i586-libnsl1.32bit-6:2.27-alt13:p9+261868.100.3.1@1606153853
  Требует: <i586-libnss>
    i586-libnss.32bit-3.56.0-alt1:p9+254920.30.20.1@1601677886
  Требует: xz
  Требует: </lib/udev/rules.d>
    udev-rules-1:246.13-alt1:p9+265718.640.15.1@1618506267
  Требует: </usr/bin/env>
    coreutils-8.31.0.3.6bd78-alt2:p9+233308.100.1.1@1561631908
  Требует: coreutils
  Требует: <i586-libgio>
    i586-libgio.32bit-2.60.7-alt1:p9+237353.100.2.2@1568396631
  Требует: python3
  Требует: tar
  Требует: xterm
  Требует: zenity

А те в свою очередь подтянут свои отсутствующие в системе зависимости.
Которых в чистой свежей beta alt-p9-xfce-sysv-20210605-x86_64 не просто много, а дофига, - 104 пакета :-)
(количество пакетов которые будут установлены с сервера; -s это --simulate, - имитация установки пакетов, при установке пакетов steam и 64 бит wine-full)
# apt-get update &&  apt-get install steam wine-full -s | grep ^Inst | wc -l
104
« Последнее редактирование: 07.06.2021 15:30:23 от Speccyfighter »

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Проще систему переустановить)
Но только проги качать долго придёться некоторые

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 564
Я попытался установить версии пакетов из alt-p9-xfce-sysv-20210605-x86_64, которую Вы указали, но всё же требуеться glibc-core=6:2.27-alt13:p9+261868.100.3.1

В свежей beta xfce-sysv от 20210605, эти пакеты уже в образе:
# rpm -q glibc-pthread glibc-core
glibc-pthread-2.27-alt13.x86_64
glibc-core-2.27-alt13.x86_64

Но в системе более ранней установки, можно обновить все установленные в системе пакеты до свежих, с которой обновятся и glibc-pthread glibc-core до свежих, если они требуют обновления:
# apt-get update && apt-get dist-upgrade

А потом тащить steam и wine.

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Те. всё же лучше переусановить ОС?

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 403
  • Sunny 273 RUS crew
Те. всё же лучше переусановить ОС?
Обновление до текущего состояния p9 не работает что ли?

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Обновление до текущего состояния p9 не работает что ли?
Так она уже на p9, или что вы подрузомеваете ввиду? Я мог не понять
На бету обновиться каким-либо оброзом?

Пакеты уже поломались, не знаю, поможет ли это.
Я сомневаюсь, но попробовать можно

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 403
  • Sunny 273 RUS crew
Обновление до текущего состояния p9 не работает что ли?
Так она уже на p9, или что вы подрузомеваете ввиду? Я мог не понять
На бету обновиться каким-либо оброзом?

Пакеты уже поломались, не знаю, поможет ли это.
Я сомневаюсь, но попробовать можно
Ничего не поломалось, если не лазили мимо rpm. wine 64 разрядный так же снести.