Автор Тема: Проблемы с i586-glibc-core и 32битными проложениями  (Прочитано 3261 раз)

Оффлайн gosts 87

  • Давно тут
  • **
  • Сообщений: 1 106
  • Дмитрий/Dmitry/德米特里/दिमित्री
Самое главное - не смешивать репозитории из разных платформ и пакеты из них. Именно это у Вас и получилось.

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Ничего не поломалось, если не лазили мимо rpm. wine 64 разрядный так же снести.
Wine64 я давно снёс, но при установке его зависимостей проблема, при эксплуатации, и обнаружилась

Оффлайн Koi

  • Мастер
  • ***
  • Сообщений: 1 943
  • валар дохаэрис
    • Канал на youtube
Мне понадобилось установить wine64
apt-get install steam
Поставьте playonlinux это решит многие проблемы, про обновление базы перед установками уже говорили.
Проще систему переустановить)
Но только проги качать долго придёться некоторые
Можно воспользоваться программой kernel manager, из нее можно почистить базу, удалить неиспользуемые библиотеки, обновить дистрибутив, переключить репозитории( не рекомендуется скакать туда-сюда ) и т.д.


Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 877
Ничего не поломалось, если не лазили мимо rpm. wine 64 разрядный так же снести.
Wine64 я давно снёс, но при установке его зависимостей проблема, при эксплуатации, и обнаружилась

Нет проблем :-)
В чистую alt-p9-xfce-sysv-20210605-x86_64, пакет wine-full захочет притащить новые пакеты:
# apt-get install wine-full
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  cabextract libSDL2 libfaudio0 libopenal1 libspirv-tools0 libtxc_dxtn libvkd3d1 libwine libwine-gl wine wine-gecko wine-mono
  wine-programs winetricks
Следующие НОВЫЕ пакеты будут установлены:
  cabextract libSDL2 libfaudio0 libopenal1 libspirv-tools0 libtxc_dxtn libvkd3d1 libwine libwine-gl wine wine-full wine-gecko
  wine-mono wine-programs winetricks
0 будет обновлено, 15 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 164MB архивов.
После распаковки потребуется дополнительно 700MB дискового пространства.
Продолжить? [Y/n] n
Прервано.

Проверьте командой, что из них установлено в системе:
# rpm -q cabextract libSDL2 libfaudio0 libopenal1 libspirv-tools0 libtxc_dxtn \
libvkd3d1 libwine libwine-gl wine wine-full wine-gecko

которая в чистой  alt-p9-xfce-sysv-20210605-x86_64 отработает как:
# rpm -q cabextract libSDL2 libfaudio0 libopenal1 libspirv-tools0 libtxc_dxtn \
> libvkd3d1 libwine libwine-gl wine wine-full wine-gecko
пакет cabextract не установлен
пакет libSDL2 не установлен
пакет libfaudio0 не установлен
пакет libopenal1 не установлен
пакет libspirv-tools0 не установлен
пакет libtxc_dxtn не установлен
пакет libvkd3d1 не установлен
пакет libwine не установлен
пакет libwine-gl не установлен
пакет wine не установлен
пакет wine-full не установлен
пакет wine-gecko не установлен

Если что-то установлено, - удалите.
Будьте осторожны с удалением не-*wine* пакетов:
Какой-то из пакетов может быть востребован установленным в системе пакетом. Тогда такой пакет удалять нельзя.

Чтобы проверить, можно ли удалять из системы пакет, на этот случай существует скрипт wpr:
Приёмы профессиональной работы в shell
Скрипт wpr - какие установленные пакеты требуют указанный пакет

https://forum.altlinux.org/index.php?topic=32361.msg346031#msg346031

Этот самописный скрипт создавался во времена создания и отладки стартеркита xfce-sysv. С учётом, что существуют цепочечные зависимости. Вы можете копировать этот скрипт и распространять.
Но я до сих пор не знаю, под какой лицензией ему лучше идти. Логика подсказывает что это GPLv2+. Но учитывая что экосистема в разных линукс разная, вероятно несколько лучшей была бы public domain.

В последнюю версию скрипта добавлена блокировка запуска с предупреждением, если пользователь не root.
В сообщение справочника добавлены и перечислены зависимости, которые требуются скрипту wpr.

Для указанного скрипту параметром имени установленного пакета, скрипт ищет установленные в системе пакеты, которым требуется указанный параметром пакет.
Если имя пакета указанного параметром, указано неверно, скрипт выдаст ошибку:
E: Невозможно найти пакет <имя_указанного_пакета>

Вы можете положить этот скрипт например в /usr/local/sbin. Но этот путь в переменной PATH root-а должен быть указан.
Или положить его в домашний каталог root. В этом случае нежелательно держать его исполняемым. Но запускать его придётся через sh командой:
# sh ./wpr.sh <имя_установленного_пакета>

После завершения работы команды, выполнение которой, в зависимости от указанного пакета может потребоваться некоторое время, будут выведены имена установленных пакетов, которым требуется указанный параметром пакет.

Используя выводы wpr, можно аккуратно вычистить систему не повредив её.

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Можно воспользоваться программой kernel manager, из нее можно почистить базу, удалить неиспользуемые библиотеки, обновить дистрибутив, переключить репозитории( не рекомендуется скакать туда-сюда ) и т.д.
Спасибо, попробую (надеюсь не сломаю опять)

Оффлайн lev145

  • Завсегдатай
  • *
  • Сообщений: 16
Чтобы проверить, можно ли удалять из системы пакет, на этот случай существует скрипт wpr:
Приёмы профессиональной работы в shell
Скрипт wpr - какие установленные пакеты требуют указанный пакет
https://forum.altlinux.org/index.php?topic=32361.msg346031#msg346031
Поставил, штучка отличная, сначало не понял как она работает, но потом быстро разобрался, она может помочь, спасибо, что порекомендовали