Автор Тема: установка альт сервера 9.1 с LVM  (Прочитано 396 раз)

Оффлайн ios

  • Начинающий
  • *
  • Сообщений: 4
Народ!!! что делаю не так? Хочу запустить альт сервер с LVM.

Скачал дистрибутив альт сервера X86-64 (ALT-SERVER-9.1-X86_64.ISO)
Развернул виртуальную машинку (VMware) с одним HDD. 
запускаю образ.
1. дохожу до этапа 4/12:Подготовка диска. Выбираю профиль "Вручную"
2. на диске sda создаю 2 мелких раздела: /boot/efi и swap
3. оставшееся место хочу использовать в LVM. Но тут и начинаются фокусы установщика.
если оставить оставшиеся место как <unused2>  то выбрав LVM, установщик  ничего не предлагает (не видит подходящего пространства)
пробую в <unused2> sda создать раздел для LVM.
Установщик предлагает следующие типы нового раздела: efi, basic data, bios boot, powerpc prep, linux file system. Пробовал все, ни один не подхватывается LVM-ом.
Видел на ютюбе пример установки Альтворкстаэйшн с LVM. там создавался раздел типа "Linux LVM" ... в моем  случае этого нет....


4. убираю все из sda.
5. выбираю LVM, создаю группу томов, в созданной группе создаю тома для   /boot/efi , swap и /  (по аналогии со стандартной установкой)  .
Начинается установка и затыкается на этапе 7/12:установка загрузчика (?????). Установщик запрашивает на какое устройство ставить загрузчик.
Предлагаемые варианты: "раздел линукс...", "жесткий диск sda", "не устанавливать"
любой вариант закачивается ошибкой...

6. пробовал вариант аналогично п.5 но вместо тома для раздела /boot оставил свободное место. результат аналогичный.

7. Единственный рабочий вариант у меня получился когда я добавил виртуалке 2-й HDD. Дальше использовал sda чисто под boot и swap. А sdb целиком вошел в LVM на котором был раздел "рут"
но по моему это не множко "колхозно" :)

... или я что-то не так делаю ... или установщик не умеет работать с  LVM .... подскажите!!!!



Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 494
    • Домашняя страница
    • Email
Re: установка альт сервера 9.1 с LVM
« Ответ #1 : 07.06.2021 14:27:46 »
Народ!!! что делаю не так? Хочу запустить альт сервер с LVM.

Скачал дистрибутив альт сервера X86-64 (ALT-SERVER-9.1-X86_64.ISO)
Развернул виртуальную машинку (VMware) с одним HDD. 
запускаю образ.
1. дохожу до этапа 4/12:Подготовка диска. Выбираю профиль "Вручную"
2. на диске sda создаю 2 мелких раздела: /boot/efi и swap
3. оставшееся место хочу использовать в LVM. Но тут и начинаются фокусы установщика.
если оставить оставшиеся место как <unused2>  то выбрав LVM, установщик  ничего не предлагает (не видит подходящего пространства)
пробую в <unused2> sda создать раздел для LVM.
Установщик предлагает следующие типы нового раздела: efi, basic data, bios boot, powerpc prep, linux file system. Пробовал все, ни один не подхватывается LVM-ом.
Видел на ютюбе пример установки Альтворкстаэйшн с LVM. там создавался раздел типа "Linux LVM" ... в моем  случае этого нет....


4. убираю все из sda.
5. выбираю LVM, создаю группу томов, в созданной группе создаю тома для   /boot/efi , swap и /  (по аналогии со стандартной установкой)  .
Начинается установка и затыкается на этапе 7/12:установка загрузчика (?????). Установщик запрашивает на какое устройство ставить загрузчик.
Предлагаемые варианты: "раздел линукс...", "жесткий диск sda", "не устанавливать"
любой вариант закачивается ошибкой...

6. пробовал вариант аналогично п.5 но вместо тома для раздела /boot оставил свободное место. результат аналогичный.

7. Единственный рабочий вариант у меня получился когда я добавил виртуалке 2-й HDD. Дальше использовал sda чисто под boot и swap. А sdb целиком вошел в LVM на котором был раздел "рут"
но по моему это не множко "колхозно" :)

... или я что-то не так делаю ... или установщик не умеет работать с  LVM .... подскажите!!!!



https://docs.altlinux.org/ru-RU/alt-server/9.1/html-single/alt-server/index.html#idm140616476463632
Андрей Черепанов (cas@)

Оффлайн ios

  • Начинающий
  • *
  • Сообщений: 4
Re: установка альт сервера 9.1 с LVM
« Ответ #2 : 07.06.2021 14:58:38 »
Спасибо.
https://docs.altlinux.org/ru-RU/alt-server/9.1/html-single/alt-server/index.html#idm140616476463632
С документацией ознакомился.  Даже в разделе "12.4.2. Создание LVM-томов" дан пример настройки LVM на железку  из 2-х дисков. Из которых только 1 выбирают под LVM.
В конце раздела написано: "После создания группы томов LVM её можно использовать как обычный жёсткий диск, то есть внутри группы томов можно создавать тома (аналог раздела на физическом жёстком диске) и файловые системы внутри томов."
И тут возникает проблема с загрузочным разделом.... которая никак не отражена в документации :(
Как  установить альтсервер  с LVM, стандартным дистрибутивом и на однодисковую машину?

P.S. Может надо каким-то определенным образом конфигурировать диск в виртуалке?


« Последнее редактирование: 07.06.2021 15:13:10 от ios »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 18 494
    • Домашняя страница
    • Email
Re: установка альт сервера 9.1 с LVM
« Ответ #3 : 07.06.2021 20:03:33 »
Я лично не вижу смысла в LVM, но в Google наверняка найдётся более подробная инструкция для LVM.
Андрей Черепанов (cas@)

Оффлайн ios

  • Начинающий
  • *
  • Сообщений: 4
Re: установка альт сервера 9.1 с LVM
« Ответ #4 : 08.06.2021 16:48:07 »
Я лично не вижу смысла в LVM, но в Google наверняка найдётся более подробная инструкция для LVM.
очень ценный совет :)  !!!!!

разобрался я с данной проблемой, нашел очень интересную фичу у этого дистрибутива
В настройка гостевой ОС VMWare есть опция ... boot firmware и 2 значения: BIOS и EFI
В зависимости от этого параметра дистрибутив "альт сервера 9.1" в отношении начальной настройки  LVM ведет себя по разному (за другие версии альтов не скажу):
Что бросилось сразу в глаза - отличались первые загрузочные меню дистрибутива. я даже подумал что случайно подцепил другой дистриб :)

Если кому интересно, алгоритм настройки LVM следующий: (гостева ос настроена на boot bios) 
.... после выбора часового пояса
- ручная настройка дисков
- с диска все удалить
- создать на диске раздел типа "Linux LVM"  обязательно !!!!! оставив свободными кусок диска (я оставил 100Мб) иначе будут проблемы с boot разделом
- в LVM создать группу томов
- в группе нарезал рутовый и сваповый разделы . остальные по желанию
- дальше стандартная установка....         

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 431
  • Sunny 273 RUS crew
Re: установка альт сервера 9.1 с LVM
« Ответ #5 : 08.06.2021 17:11:23 »
И тут возникает проблема с загрузочным разделом.... которая никак не отражена в документации :(
А это разве не очевидно? Кто-то должен загрузить ядро и, обычно, initrd с этого раздела, а дальше простой вопрос: этот кто-то знает про LVM? Если этот "кто-то" Grub, может быть уже и знает. Но ещё и сам Grub кто-то должен загрузить.

Оффлайн ios

  • Начинающий
  • *
  • Сообщений: 4
Re: установка альт сервера 9.1 с LVM
« Ответ #6 : 09.06.2021 07:25:01 »
А это разве не очевидно? Кто-то должен загрузить ядро и, обычно, initrd с этого раздела, а дальше простой вопрос: этот кто-то знает про LVM? Если этот "кто-то" Grub, может быть уже и знает. Но ещё и сам Grub кто-то должен загрузить.

Уровень квалификации у всех разный :) ... и официальная документация (цитату из которой я приводил) должна была бы восполнить недостающий уровень знаний. С одной стороны очевидно что гдето должен быть загрузчик, а с другой - в доке пишут: "пользуйтесь как обычным диском"  :-o когнитивный диссонанс какойто  :)

P.S. Для меня так и осталось загадкой почему в варианте загрузки ОС методом boot efi - дистриб не позволяет создавать разделы типа "linux LVM"  :-(