Автор Тема: О продолжительности сопровождения платформы  (Прочитано 1290 раз)

Оффлайн Geidrow

  • Начинающий
  • *
  • Сообщений: 4
Приветствую всех подписчиков форума.
 Будьте добры, подскажите, пожалуйста, по вопросам использования Альт 10.

 Назрела необходимость обновления прикладного ПО и ОС, рассматриваю для этого Альт Рабочая станция 10.0. Не все свойства дистрибутива можно понять при ознакомлении с ним в виртуальной машине да и на реальном железе за краткий промежуток времени, поэтому пишу здесь.

 Значительное влияние на удобство в эксплуатации ОС для меня как пользователя оказывает срок доступности новых версий прикладного ПО и обновлений безопасности. Срок поддержки 10-ой платфомы заявлен до 24 года, но также на сайте упомянуты и бэкпорты. Каков же подход и выделяемые ресурсы к наполнению основных репозиториев и бэкпортов: все версии прикладного ПО поддерживаются актуальными в течение срока поддержки соответствующей платформы или только часть (например, наиболее востребованные)? В частности инструментарий snap и flatpack? Последний вопрос связан с тем, что ПО, собранное более новой версией инструментария flatpack, не работает в системе с более ранней версией flatpack.

 Настоящая преамбула имеет целью прояснение предпосылок к задаваемым вопросам и уточнения контекста вопросов. Позвольте же сами вопросы сформулировать отдельно в более лаконичной форме.

1. Адрес репозитория бэкпортов для P10
2.1. Срок сопровождения репозитория бэкпортов для прикладного ПО
2.2. То же для обновлений безопасности
2.3. То же для обновлений ядра, в том числе preemt версии
2.4. То же для обновлений инструментария snap и flatpack.

 Спасибо
 Примечание. Читатель может поинтересоваться причинами проглядывающего из этой заметки стремления использовать уже установленный дистрибутив как можно дольше. Причин несколько. Новая платформа поставляется обычно с актуальной версией КДЕ, а последний или связанные с  ним сторонние дополнения могут нести в себе "сюрпризы" как, например, урезание настроек 5 версии по сравнению с 4 или прекращение поддержки Oxygen-transparent. Да и в системные компоненты вносятся требующие к себе внимания изменения: то переход в спящий режим не работает "из коробки", то новое ядро не модифицируется патчами от Колина, и приходится подбирать подходящую комбинацию. В общем, стремимся к снижению временн'ых эксплуатационных затрат :).
« Последнее редактирование: 06.07.2022 17:55:10 от Geidrow »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 475
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
1. Никаких бекпортов  давно нет, есть один репозиторий p10.
2. Срок поддержки p10 указан на wiki
3. Поддержка конкретного пакета в репозитории, не связанная с безопасностью, зависит от желания мантейнера данного пакета обновлять пакеты в репозитории.
Некоторые пакеты и сейчас обновляются в p9 и p8, хотя срок поддержки их давно прошёл, а некоторые не обновляются и в p10, так как у них нет проблем с безопасностью, а мантейнера пакета вполне устраивает текущая версия (например, он сам работает только на Сизифе).
« Последнее редактирование: 01.07.2022 12:42:00 от ruslandh »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 475
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
В случае необходимости обновления пакета, надо писать в багзилу (для физических лиц)  , или в техподдержку (для юридических лиц)

Конкретику можно уточнить, написав письмо на sales@basealt.ru

А тут форум пользователей
« Последнее редактирование: 01.07.2022 12:45:25 от ruslandh »

Оффлайн Geidrow

  • Начинающий
  • *
  • Сообщений: 4
ruslandh, спасибо за ответ.
" тут форум пользователей"
Я тоже пользователь :)
"Некоторые пакеты и сейчас обновляются в p9 и p8"
Об этих нюансах (взгляд изнутри, так сказать) и стараюсь узнать подробнее. Какие из популярных поддерживаются, какие нет?

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 475
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Есть такая рассылка от робота сборки, можно посмотреть его архивы.
https://lists.altlinux.org/mailman/listinfo/sisyphus-cybertalk

Например, сегодня в p9  (https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2022-July/117546.html)  обновился один пакет:

Цитировать
myconnector - MyConnector - remote desktop client
* Fri May 20 2022 Evgeniy Korneechev <ekorneechev на altlinux> 2.3-alt1
- Added global settings and a global list of connections
- Added stealth mode
- [CLI] Added editing of the configuration file
- Fixed bash-completion
- Fixed connect when there is a password save, but saving is disabled
- Added autofilling in lists of servers and groups
- Updated documentation and manual pages
* Wed Mar 16 2022 Evgeniy Korneechev <ekorneechev на altlinux> 2.2.1-alt1

А в p10 (https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2022-July/117545.html) пришло два новых пакета и обновилось 45 пакетов


Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 475
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Последнее обновление p8 было 30 июня (https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2022-June/117536.html), обновилось 15 пакетов - ядро un-def

Оффлайн Geidrow

  • Начинающий
  • *
  • Сообщений: 4
Спасибо. Это полезный  в том числе и для пользователей ОС ресурс.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 389
    • Домашняя страница
    • Email
Приветствую всех форумчан.
 Будьте добры, подскажите, пожалуйста, по вопросам использования Альт 10.

 Назрела необходимость обновления прикладного ПО и ОС, рассматриваю для этого Альт Рабочая станция 10.0. Не все свойства дистрибутива можно понять при ознакомлении с ним в виртуальной машине да и на реальном железе за краткий промежуток времени, поэтому пишу здесь.

 Значительное влияние на удобство в эксплуатации ОС для меня как пользователя оказывает срок доступности новых версий прикладного ПО и обновлений безопасности. Срок поддержки 10-ой платфомы заявлен до 24 года, но также на сайте упомянуты и бэкпорты. Каков же подход и выделяемые ресурсы к наполнению основных репозиториев и бэкпортов: все версии прикладного ПО поддерживаются актуальными в течение срока поддержки соответствующей платформы или только часть (например, наиболее востребованные)? В частности инструментарий snap и flatpack? Последний вопрос связан с тем, что ПО, собранное более новой версией инструментария flatpack, не работает в системе с более ранней версией flatpack.

 Настоящая преамбула имеет целью прояснение предпосылок к задаваемым вопросам и уточнения контекста вопросов. Позвольте же сами вопросы сформулировать отдельно в более лаконичной форме.

1. Адрес репозитория бэкпортов для P10
2.1. Срок сопровождения репозитория бэкпортов для прикладного ПО
2.2. То же для обновлений безопасности
2.3. То же для обновлений ядра, в том числе preemt версии
2.4. То же для обновлений инструментария snap и flatpack.

 Спасибо
 Примечание. Читатель может поинтересоваться причинами проглядывающего из этой заметки стремления использовать уже установленный дистрибутив как можно дольше. Причин несколько. Новая платформа поставляется обычно с актуальной версией КДЕ, а последний или связанные с  ним сторонние дополнения могут нести в себе "сюрпризы" как, например, урезание настроек 5 версии по сравнению с 4 или прекращение поддержки Oxygen-transparent. Да и в системные компоненты вносятся требующие к себе внимания изменения: то переход в спящий режим не работает "из коробки", то новое ядро не модифицируется патчами от Колина, и приходится подбирать подходящую комбинацию. В общем, стремимся к снижению временн'ых эксплуатационных затрат :).
Вам Альт не нужен, используйте Arch Linux.
Андрей Черепанов (cas@)

Оффлайн Geidrow

  • Начинающий
  • *
  • Сообщений: 4
Цитировать
Вам Альт не нужен, используйте Arch Linux.
Возможно, Арч и подходит.  Инструментарий flatpak, appimage, snapd позволяет выборочно (на случай регрессивных изменений) поддерживать актуальные версии прикладного ПО. В то время как обновление всей системы ставит во взаимозависимость версии компонентов и может возникнуть ситуация, когда обновление одних компонентов нежелательно, а других необходимо, но раздельно так сделать не предусмотрено самой системой построения дистрибутива. И в этой ситуации подход "роллинг" может быть очень неудобен. А обновления безопасности не предполагают мажорных обновлений зависимых компонентов.
Ознакомление с версиями пакетов на pkgs.org показало, что даже P9 поддерживается в актуальном состоянии дольше, чем  бэкпорты одного дистрибутива (здесь речь о его старой версии - может, в новой иначе). Поэтому продолжаю знакомиться с Альт.

Оффлайн WinLin2

  • Начинающий
  • *
  • Сообщений: 4
Вам Альт не нужен, используйте Arch Linux.
Золотые слова, если бы не импортозамещение.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 389
    • Домашняя страница
    • Email
Вам Альт не нужен, используйте Arch Linux.
Золотые слова, если бы не импортозамещение.
Тогда поумерьте свои амбиции, Вам работать или тешить новыми версиями свою гордыню?
Андрей Черепанов (cas@)

Оффлайн N0rbert

  • Давно тут
  • **
  • Сообщений: 105
flatpack

Обновления самого пакета Flatpak см. на его странице в Сизифе - https://packages.altlinux.org/en/sisyphus/srpms/flatpak/ . Тоже самое со Snap - https://packages.altlinux.org/en/sisyphus/srpms/snapd/ .
Сравнение версий можете выполнить с помощью Repology - https://repology.org/project/flatpak/versions, https://repology.org/project/snapd/versions .

поддерживать актуальные версии прикладного ПО
Какая-то размытая формулировка. Какого именно ПО? Чего не хватает в RPM-варианте?

По моим недавним оценкам в репозитории p10 насчитывается ~17875 уникальных пакетов, при этом Synaptic на установленной системе сообщает о доступных ~45915 пакетах.
Добавление репозиториев Autoimports увеличивает количество доступных для установки через Synaptic пакетов до 89125 пакетов, т.е. дают прибавку в ~71250 пакетов относительно официальных репозиториев.

Поэтому для себя я пока такой вывод сделал - ALT Linux сам по себе лучший среди российских дистрибутивов по сообществу, инфраструктуре и размеру репозитория. А если что-то кого-то не устраивает, то санкционных рисков от использования Debian нет, см. справку от Астры (сама астра 2.12 orel убога из-за использования урезанной пакетной базы Debian 9, снятого с поддержки в июне 2022 года; а свободной загрузки 1.7 на Debian 10 нет). Если вам нужны лицензии ФСТЭК и т.п., то Альт 8 СПТ предположительно окажется лучше Астры.
« Последнее редактирование: 08.10.2022 10:19:24 от N0rbert »

Оффлайн Виктор Дуб

  • Давно тут
  • **
  • Сообщений: 184
Добавление репозиториев Autoimports увеличивает количество доступных для установки через Synaptic пакетов до 89125 пакетов
А где посмотреть состав этого репа? Я подключил себе, но что-то свежестью не веет :)

Оффлайн N0rbert

  • Давно тут
  • **
  • Сообщений: 105
А где посмотреть состав этого репа?

В Synaptic перейдите на вкладку Origin (Происхождение) далее в списке слева выберите строку mirror.yandex.ru/autoimports (или аналогичную строку с ftp.altlinux.ru). Баг-запрос веб-версии создан под номером 43312.
« Последнее редактирование: 08.10.2022 22:58:24 от N0rbert »

Оффлайн Виктор Дуб

  • Давно тут
  • **
  • Сообщений: 184
Ещё требуется в параметрах включить.
После чего пустое поле в этой позиции вижу. (у меня гном отсюда https://forum.altlinux.org/index.php?topic=46758.msg374552#msg374552)
« Последнее редактирование: 09.10.2022 01:21:20 от Виктор Дуб »