Автор Тема: Битый пакет (решено)  (Прочитано 5574 раз)

Оффлайн sasa

  • Завсегдатай
  • *
  • Сообщений: 1 152
Битый пакет (решено)
« : 03.06.2012 05:35:03 »
[root@linux Загрузки]# apt-get install vlc
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  vlc: Требует: vlc-plugin-ffmpeg (= 2.0.1-alt1.M60P.1)
E: Извините, `битые' пакеты
[root@linux Загрузки]#
Пробовал на двух зеркалах (официальном и яндексе)
« Последнее редактирование: 03.06.2012 08:27:30 от sasa »
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн sasa

  • Завсегдатай
  • *
  • Сообщений: 1 152
Re: Битый пакет
« Ответ #1 : 03.06.2012 07:46:20 »
Также не могу установить офис:
[root@linux ~]# apt-get install libreoffice
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libreoffice: Требует: gst-ffmpeg
E: Извините, `битые' пакеты
[root@linux ~]#
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн Vovka-Korovka

  • alt linux team
  • ***
  • Сообщений: 1 186
  • True Metal Cow
    • Email
Re: Битый пакет
« Ответ #2 : 03.06.2012 08:04:58 »
Вы попробуйте сделать apt-get install для требуемых пакетов gst-ffmpeg или vlc-plugin-ffmpeg. Если и на них будет ругань, то попробуйте установить неустанавливаемые зависимости gst-ffmpeg или vlc-plugin-ffmpeg. Так в конце концов вы доберетесь до пакета, который вам мешает.

Оффлайн Vovka-Korovka

  • alt linux team
  • ***
  • Сообщений: 1 186
  • True Metal Cow
    • Email
Re: Битый пакет
« Ответ #3 : 03.06.2012 08:08:57 »
Тут в соседней теме говорят, что мешает libavcodec52. Сделайте

sudo apt-get install libavcodec53

Оффлайн sasa

  • Завсегдатай
  • *
  • Сообщений: 1 152
Re: Битый пакет
« Ответ #4 : 03.06.2012 08:21:41 »
Спасибо за совет! :)
[root@linux ~]# apt-get install libavcodec53
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  libavcodec53: Требует: libx264.so.120 (>= set:miZK03vzZfPv9xWp7oVDO2Sg6ZgNPGZtI0eDJ9G0)
E: Извините, `битые' пакеты
[root@linux ~]#
В общем, установил libx264.so.120, оно  предложило что-то удалить, что-то установить и все стало нормально :)
[root@linux ~]# apt-get install libx264.so.120
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libx264 для 'libx264.so.120'
Следующие дополнительные пакеты будут установлены:
  audacious-plugins gst-plugins-ugly libavcodec53 libavformat53 libgegl
  libx264
Следующие пакеты будут ОБНОВЛЕНЫ:
  audacious-plugins gst-plugins-ugly libgegl libx264
Следующие пакеты будут УДАЛЕНЫ:
  libavcodec52 libavformat52
Следующие НОВЫЕ пакеты будут установлены:
  libavcodec53 libavformat53
4 будет обновлено, 2 новых установлено, 2 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 5800kB архивов.
После распаковки потребуется дополнительно 2815kB дискового пространства.
Продолжить? [Y/n] y       
Получено: 1 ftp://mirror.yandex.ru i586/classic gst-plugins-ugly 0.10.18-alt0.M60P.2 [262kB]
Получено: 2 ftp://mirror.yandex.ru i586/classic libgegl 0.2.0-alt0.M60P.1 [372kB]
Получено: 3 ftp://mirror.yandex.ru i586/classic audacious-plugins 2.5.0-alt1.M60P.1 [1577kB]
Получено: 4 ftp://mirror.yandex.ru i586/classic libx264 120-alt0.0.M60P.1 [371kB]
Получено: 5 ftp://mirror.yandex.ru i586/classic libavcodec53 1:0.8.1-alt0.M60P.1 [2749kB]
Получено: 6 ftp://mirror.yandex.ru i586/classic libavformat53 1:0.8.1-alt0.M60P.1 [469kB]
Получено 5800kB за 12s (470kB/s).                                             
Совершаем изменения...
Preparing...                 ########################################### [100%]
1: libx264                   ########################################### [ 16%]
2: libavcodec53              ########################################### [ 33%]
3: libavformat53             ########################################### [ 50%]
4: gst-plugins-ugly          ########################################### [ 66%]
5: libgegl                   ########################################### [ 83%]
6: audacious-plugins         ########################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Завершено.
« Последнее редактирование: 03.06.2012 08:26:43 от sasa »
Компьютер - это лопата, к нему мозги нужны (с)

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 961
    • Домашняя страница
    • Email
Re: Битый пакет
« Ответ #5 : 03.06.2012 20:40:12 »
Такие ситуации обычно решаются через apt-get dist-upgrade
Андрей Черепанов (cas@)

Оффлайн Vovka-Korovka

  • alt linux team
  • ***
  • Сообщений: 1 186
  • True Metal Cow
    • Email
Re: Битый пакет
« Ответ #6 : 03.06.2012 20:45:10 »
Такие ситуации обычно решаются через apt-get dist-upgrade

Не всегда. С libavcodec у меня на сизифе не прокатывало. Просто при dist-upgrade часть пакетов попадали в секцию "Будут сохранены".