Автор Тема: установка принтера Canon WF-2860  (Прочитано 411 раз)

Оффлайн am56

  • Начинающий
  • *
  • Сообщений: 3
Добрый день,
не удалось установить принтер Epson WF-2860

Пытался установить драйвер
udo rpm -ivh --force --nodeps /home/am/tmp/epson-printer-utility-1.1.1-1lsb3.2.x86_64.rpm

получил такой ответ
ln: не удалось создать символьную ссылку '/usr/bin/epson-printer-utility': Файл существует
Install Message > Start /usr/lib/epson-backend/setup to change setup.
Running /usr/lib/rpm/posttrans-filetriggers
nice: «/usr/lib/epson-backend/ecbd»: Нет такого файла или каталога
предупреждение: невозможно получить блокировку разделяемый на /var/lib/rpm/Packages

не удалось создать символьную ссылку - наверно потому что запускал эту команду несколько раз

Можете подсказать решение?

Оффлайн am56

  • Начинающий
  • *
  • Сообщений: 3
Re: установка принтера Canon WF-2860
« Ответ #1 : 28.03.2022 18:08:05 »
речь об установке принтера в Simple Linux 9.1

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 115
Re: установка принтера Canon WF-2860
« Ответ #2 : 28.03.2022 22:20:02 »
eepm install --repack epson-printer-utility-1.1.1-1lsb3.2.x86_64.rpm

Оффлайн am56

  • Начинающий
  • *
  • Сообщений: 3
Re: установка принтера Canon WF-2860
« Ответ #3 : 31.03.2022 18:23:12 »
Добрый день, yaleks,

установил Simple Linux 10.0
запустил команду eepm install --repack epson-inkjet-printer-escpr2-1.1.48-1lsb3.2.x86_64.rpm
в ответ попросил установить пакет lsb
установил командой apt-get install lsb
опять запустил команду: в ответ попросил установить пакет alien
попробовал установить пакет командой apt-get install alien
отвечает: Невозможно найти пакет alien

Можете помочь?

Спасибо

 

Оффлайн Александр Ерещенко

  • Завсегдатай
  • *
  • Сообщений: 839
Re: установка принтера Canon WF-2860
« Ответ #4 : 31.03.2022 19:21:56 »
Добрый день, yaleks,

установил Simple Linux 10.0
запустил команду eepm install --repack epson-inkjet-printer-escpr2-1.1.48-1lsb3.2.x86_64.rpm
в ответ попросил установить пакет lsb
установил командой apt-get install lsb
опять запустил команду: в ответ попросил установить пакет alien
попробовал установить пакет командой apt-get install alien
отвечает: Невозможно найти пакет alien

Можете помочь?

Спасибо
Пакетная база перед этим была обновлена?
apt-get update

eepm, насколько помню, сам должен был доустановить недостающие пакеты (при условии, что сведения о пакетах обновлены)
По хорошему можете сначала обновить систему до свежего состояния, а потом уже перепаковывать и устанавливать отдельный пакет.
eepm Upgrade
или классически
apt-get update && apt-get dist-upgrade

Оффлайн NickM

  • Завсегдатай
  • *
  • Сообщений: 577
    • Email
Re: установка принтера Canon WF-2860
« Ответ #5 : 31.03.2022 20:05:26 »
или классически
apt-get update && apt-get dist-upgrade
Специфически.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 169
    • Домашняя страница
    • Email
Re: установка принтера Canon WF-2860
« Ответ #6 : 01.04.2022 06:02:11 »
epson-inkjet-printer-escpr2 должен без переупаковки устанавливаться.
Андрей Черепанов (cas@)