Автор Тема: Использование звука (звуковое сопровождение как в windows) при входе/выходе  (Прочитано 6149 раз)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Здравствуйте! Интересует, есть ли возможность вставить звуковое сопровождение при входе в систему (у меня Simply Linux). Хочется поставить "Привет!" и "Пока!" женским голосом, как  в Windows при входе-выходе из/в ОС. Кто-нибудь знает, как это делается?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Здравствуйте! Интересует, есть ли возможность вставить звуковое сопровождение при входе в систему (у меня Simply Linux). Хочется поставить "Привет!" и "Пока!" женским голосом, как  в Windows при входе-выходе из/в ОС. Кто-нибудь знает, как это делается?
Найти или записать звуковые файлы и подставить их в уведомления.
Андрей Черепанов (cas@)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Как это точно сделать? Есть уже готовые звуковые файлы из ОС windows. Последовательно расскажите, что и как делать. Заранее благодарен. С уважением, Дмитрий.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Как это точно сделать? Есть уже готовые звуковые файлы из ОС windows. Последовательно расскажите, что и как делать. Заранее благодарен. С уважением, Дмитрий.
В центре настроек посмотрите. У меня сейчас под рукой XFCE нет, смогу посмотреть только в понедельник-вторник.
Андрей Черепанов (cas@)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Здравствуйте, Андрей! Искал там - не нашел. Жду от Вас сообщений. С уважением, Дмитрий.

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Здравствуйте, Андрей! Искал там - не нашел. Жду от Вас сообщений. С уважением, Дмитрий.
Прошу прощения. В центре настроек нет этого. На форуме XFCE (http://forum.xfce.org/viewtopic.php?id=3496) советуют создать для автозапуска вызова проигрывателя с файлом (Настройки → Диспетчер настроек → Сеансы и запуск → Автозапуск приложений):
Цитировать
Or you can add to autostarted apps something like:
play /home/dergutekoenig/.startsong.wav
С выходом ещё сложнее, так как потребует тонкой доводки скрипта запуска XFCE (/usr/bin/startxfce4).
Андрей Черепанов (cas@)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Мда... Вот с этого момента поподробнее. Также (я думаю это сделать отдельной темой, если ее не было) не подключается нормально Epson perfection 1670. Жду от Вас сообщений, предложений. С уважением, Дмитрий.
« Последнее редактирование: 25.06.2012 22:35:01 от daimon1004 »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Мда... Вот с этого момента поподробнее.
Добавьте команду воспроизведения в конец этого файла. Сразу скажу: я не пробовал, но теоретически должно работать. См. также http://forum.xfce.org/viewtopic.php?id=2731
Цитировать
Также (я думаю это сделать отдельной темой, если ее не было) не подключается нормально Epson perfection 1670. Жду от Вас сообщений, предложений. С уважением, Дмитрий.
Разделяйте вопросы по отдельным темам.
« Последнее редактирование: 26.06.2012 14:37:51 от Skull »
Андрей Черепанов (cas@)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Добавил в меню "Сеансы и запуск" в сеансы автозагрузки строку "Startup" со след. путем: /usr/share/sounds/startup3.wav. Перегрузил ПК - никакого результата. Прилагаю снимок экрана. Жду от вас сообщений, предложений. С уважением, Дмитрий.

Оффлайн sb

  • Модератор глобальный
  • *****
  • Сообщений: 9 001
Измените ваш путь на такую строку play /usr/share/sounds/startup3.wav, сохраните и проверьте.

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Сделал как сказали. Не идет. Может где то что то еще надо нажать?

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 962
    • Домашняя страница
    • Email
Сделал как сказали. Не идет. Может где то что то еще надо нажать?
Из терминала запускали? Работает?
Андрей Черепанов (cas@)

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Нет, не пашет. Пишет вот что: play: команда не найдена (см. снимок экрана).

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 10 259
$ rpm -qf /usr/bin/play
sox-base-14.3.2-alt0.M60P.1
sox-play-14.3.2-alt0.M60P.1

$ rpm -ql sox-base|grep bin
/usr/bin/play
/usr/bin/rec
/usr/bin/sox
/usr/bin/soxeffect
/usr/bin/soxi
/usr/bin/soxplay

$ rpm -ql sox-play|grep bin
/usr/bin/play
/usr/bin/rec
/usr/bin/soxplay

$ ls -l /usr/bin/play
lrwxrwxrwx 1 root root 3 Июн  5 18:53 /usr/bin/play -> sox

$ ls -l /usr/bin/sox
-rwxr-xr-x 1 root root 55252 Май 13 13:59 /usr/bin/sox
$ play /usr/share/sounds/startup3.wav

/usr/share/sounds/startup3.wav:

 File Size: 884k      Bit Rate: 1.41M
  Encoding: Signed PCM   
  Channels: 2 @ 16-bit   
Samplerate: 44100Hz     
Replaygain: off         
  Duration: 00:00:05.01 

In:100%  00:00:05.01 [00:00:00.00] Out:221k  [      |      ]        Clip:0   
Done.
« Последнее редактирование: 28.06.2012 03:20:19 от Speccyfighter »

Оффлайн daimon1004

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Повторил ваш подвиг - никакого результата. Смог сделать максимум чтобы через автозагрузку шел звук входа в систему, но ведь еще нужно настроить звук выхода из системы, да и аудиоплеер каждй раз задолбаешься закрывать (вставил строку в автозагруз audacious /usr/share/sounds/startup3.wav и заработало, но при этом окрывается сам плеер  audacious и его приходится закрывать вручную - крайне неудобно). А еще - не решен вопрос со звуковым сопровождением выхода...Ну и здесь со входом тоже надо что то делать. После установки в автозагруз вашего варианта записи (ком. строки play /usr/share/sounds/startup3.wav) он у меня перезагрузке или при входе с систему просто отключает звук совсем и все. Ничего более не происходит.  Жду от вас сообщений, предложений. С уважением, Дмитрий.