Автор Тема: Не ставится офис wps  (Прочитано 757 раз)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 353
Не ставится офис wps
« : 10.04.2024 17:52:10 »
https://wdl1.pcfg.cache.wpscdn.com/wpsdl/wpsoffice/download/linux/11719/wps-office-11.1.0.11719.XA-1.x86_64.rpm
В чём причина? Версия не та? Не поддерживается вообще?

Оффлайн tarasov-it1

  • Давно тут
  • **
  • Сообщений: 132
Re: Не ставится офис wps
« Ответ #1 : 11.04.2024 08:26:26 »
Чтобы определить причину, обычно нужно немного больше информации, чем "не ставится".
Пользуюсь именно этой версией, установленной через epm.

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 353
Re: Не ставится офис wps
« Ответ #2 : 11.04.2024 12:35:27 »
[a@lureenvoy ~]$ su -
Password:
[root@lureenvoy ~]# epm -i /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm
WARNING: %%% You are trying install package /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm from third-party software source. Use it at your own risk. %%%
WARNING: Scripts are DISABLED for package wps-office-11.1.0.11719.XA-1.x86_64.rpm from outside vendor '(none)'. Use --scripts if you need run scripts from such packages.
WARNING: There is repack rule for 'wps-office' package. It is better install this package via 'epm install --repack' or 'epm play'.
 # rpm -Uvh --noscripts /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm
Подготовка...                           ################################# [100%]
файл /etc/cron.d из устанавливаемого пакета wps-office-11.1.0.11719.XA-1.x86_64 конфликтует с файлом из пакета vixie-cron-4.1.20060426-alt10.3.x86_64
файл /etc/logrotate.d из устанавливаемого пакета wps-office-11.1.0.11719.XA-1.x86_64 конфликтует с файлом из пакета logrotate-3.20.1-alt2.x86_64

Workaround for install packages via apt with --noscripts (see https://bugzilla.altlinux.org/44670)
Firstly install package requrements …
 # epm req --short /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm
 # rpm -q --requires -p /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm
 # epm install --skip-installed libICE.so.6()(64bit) libSM.so.6()(64bit) libX11.so.6()(64bit) libXext.so.6()(64bit) libXrender.so.1()(64bit) libXss.so.1()(64bit) libc.so.6()(64bit) libcups.so.2()(64bit) libfontconfig.so.1()(64bit) libfreetype.so.6()(64bit) libgcc_s.so.1()(64bit) libgcc_s.so.1(GCC_3.0)(64bit) libglib-2.0.so.0()(64bit) libgobject-2.0.so.0()(64bit) libgthread-2.0.so.0()(64bit) libpthread.so.0()(64bit) libpulse-mainloop-glib.so.0()(64bit) librt.so.1()(64bit) libxcb.so.1()(64bit) libz.so.1()(64bit)
 # apt-get -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true install libICE.so.6()(64bit) libSM.so.6()(64bit) libX11.so.6()(64bit) libXext.so.6()(64bit) libXrender.so.1()(64bit) libXss.so.1()(64bit) libc.so.6()(64bit) libcups.so.2()(64bit) libfontconfig.so.1()(64bit) libfreetype.so.6()(64bit) libgcc_s.so.1()(64bit) libgcc_s.so.1(GCC_3.0)(64bit) libglib-2.0.so.0()(64bit) libgobject-2.0.so.0()(64bit) libgthread-2.0.so.0()(64bit) libpthread.so.0()(64bit) libpulse-mainloop-glib.so.0()(64bit) librt.so.1()(64bit) libxcb.so.1()(64bit) libz.so.1()(64bit)
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано libICE для 'libICE.so.6()(64bit)'
Последняя версия libICE уже установлена.
Выбрано libSM для 'libSM.so.6()(64bit)'
Последняя версия libSM уже установлена.
Выбрано libX11 для 'libX11.so.6()(64bit)'
Последняя версия libX11 уже установлена.
Выбрано libXext для 'libXext.so.6()(64bit)'
Последняя версия libXext уже установлена.
Выбрано libXrender для 'libXrender.so.1()(64bit)'
Последняя версия libXrender уже установлена.
Выбрано libXScrnSaver для 'libXss.so.1()(64bit)'
Последняя версия libXScrnSaver уже установлена.
Выбрано glibc-core для 'libc.so.6()(64bit)'
Последняя версия glibc-core уже установлена.
Выбрано libcups для 'libcups.so.2()(64bit)'
Последняя версия libcups уже установлена.
Выбрано libfontconfig1 для 'libfontconfig.so.1()(64bit)'
Последняя версия libfontconfig1 уже установлена.
Выбрано libfreetype для 'libfreetype.so.6()(64bit)'
Последняя версия libfreetype уже установлена.
Выбрано libgcc1 для 'libgcc_s.so.1()(64bit)'
Последняя версия libgcc1 уже установлена.
Выбрано libgcc1 для 'libgcc_s.so.1(GCC_3.0)(64bit)'
Последняя версия libgcc1 уже установлена.
Выбрано glib2 для 'libglib-2.0.so.0()(64bit)'
Последняя версия glib2 уже установлена.
Выбрано glib2 для 'libgobject-2.0.so.0()(64bit)'
Последняя версия glib2 уже установлена.
Выбрано glib2 для 'libgthread-2.0.so.0()(64bit)'
Последняя версия glib2 уже установлена.
Выбрано glibc-pthread для 'libpthread.so.0()(64bit)'
Последняя версия glibc-pthread уже установлена.
Выбрано libpulseaudio для 'libpulse-mainloop-glib.so.0()(64bit)'
Последняя версия libpulseaudio уже установлена.
Выбрано glibc-pthread для 'librt.so.1()(64bit)'
Последняя версия glibc-pthread уже установлена.
Выбрано libxcb для 'libxcb.so.1()(64bit)'
Последняя версия libxcb уже установлена.
Выбрано zlib для 'libz.so.1()(64bit)'
Последняя версия zlib уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 33 не будет обновлено.
 # rpm -Uvh --noscripts /home/a/Загрузки/wps-office-11.1.0.11719.XA-1.x86_64.rpm
Подготовка...                           ################################# [100%]
файл /etc/cron.d из устанавливаемого пакета wps-office-11.1.0.11719.XA-1.x86_64 конфликтует с файлом из пакета vixie-cron-4.1.20060426-alt10.3.x86_64
файл /etc/logrotate.d из устанавливаемого пакета wps-office-11.1.0.11719.XA-1.x86_64 конфликтует с файлом из пакета logrotate-3.20.1-alt2.x86_64

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 242
Re: Не ставится офис wps
« Ответ #3 : 11.04.2024 16:51:43 »
eepm install --repack wps-office-11.1.0.11719.XA-1.x86_64.rpmтоже не помогает?

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 353
Re: Не ставится офис wps
« Ответ #4 : 11.04.2024 17:50:27 »
Спасибо. Это помогло.