Автор Тема: Не получается установить PhpStorm-2023.3 Linux на Альтлинукс 10  (Прочитано 906 раз)

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Пытаюсь установить - ошибки.
Активатор:
[a@lureenvoy ~]$ su -
Password:
 epm -i /home/a/Загрузки/PhpStorm-2023.3.2_Lin/jetbra.tar.gz
WARNING: %%% You are trying install package /home/a/Загрузки/PhpStorm-2023.3.2_Lin/jetbra.tar.gz not from official ALTLinux/p10 repository. Use it at your own risk. %%%

Repacking /home/a/Загрузки/PhpStorm-2023.3.2_Lin/jetbra.tar.gz to local rpm format (inside /var/tmp/tmp.Z08UAoK6hH/jetbra.tar.gz.tmpdir) ...
 # /usr/bin/env bash /etc/eepm/pack.d/generic-tar.sh /var/tmp/tmp.Z08UAoK6hH/jetbra.tar.gz /var/tmp/tmp.Z08UAoK6hH/filefortarname 
FATAL: Can't get version from /var/tmp/tmp.Z08UAoK6hH/jetbra.tar.gz. We have almost no chance it will supported in alien.
ERROR:   (you can discuss the epm 3.57.6-alt1 problem in Telegram: https://t.me/useepm)
Сама программа: epm -i /home/a/Загрузки/PhpStorm-2023.3.2_Lin/PhpStorm-2023.3.2.tar.gz
WARNING: %%% You are trying install package /home/a/Загрузки/PhpStorm-2023.3.2_Lin/PhpStorm-2023.3.2.tar.gz not from official ALTLinux/p10 repository. Use it at your own risk. %%%

Repacking /home/a/Загрузки/PhpStorm-2023.3.2_Lin/PhpStorm-2023.3.2.tar.gz to local rpm format (inside /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir) ...
 # /usr/bin/env bash /etc/eepm/pack.d/generic-tar.sh /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz /var/tmp/tmp.Cdr69IpYg3/filefortarname 
 # erc type PhpStorm-2023.3.2.tar.gz
 # alien --generate --to-rpm ../PhpStorm-2023.3.2.tar.gz
 # /usr/bin/env bash /etc/eepm/repack.d/generic.sh /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2 /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2-2.spec PhpStorm /home/a/Загрузки/PhpStorm-2023.3.2_Lin/PhpStorm-2023.3.2.tar.gz
 # rpmbuild --buildroot /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2 --target x86_64 -bb /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2-2.spec
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/bin
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/lib
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/plugins
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/plugins/remote-dev-server
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/plugins/webp
предупреждение: Файл указан дважды: /PhpStorm-233.13135.108/plugins/webp/lib
find-provides: running scripts (alternatives,debuginfo,fpc,gir,lib,mono,pam,perl,pkgconfig,python,python3,shell,typelib)
find-requires: running scripts (cpp,debuginfo,files,fpc,gir-js,gir-python,gir,lib,mono,monolib,pam,perl,pkgconfig,pkgconfiglib,python,python3,rpmlib,shebang,shell,static,symlinks,systemd-services,typelib)
gir-js.req.files: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/plugins/javascript-impl/jsLanguageServicesImpl/js-lanuage-api.js:  empty (PASS)
lib.req.files: ELF executable /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/plugins/platform-ijent-impl/ijent-aarch64-unknown-linux-musl-release is not executable
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/java: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/javac: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/javadoc: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jcmd: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jdb: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jfr: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jhsdb: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jinfo: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jmap: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jps: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jrunscript: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jstack: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/jstat: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/keytool: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/rmiregistry: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/bin/serialver: overlinked libraries: /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libz.so.1
readelf: Warning: local symbol 1 found at index >= .dynsym's sh_info value of 1
readelf: Warning: local symbol 2 found at index >= .dynsym's sh_info value of 1
readelf: Warning: local symbol 3 found at index >= .dynsym's sh_info value of 1
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libattach.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libawt.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libawt_headless.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libawt_headless.so: overlinked libraries: /lib64/libm.so.6
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libawt_xawt.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libextnet.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libfontmanager.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libfontmanager.so: underlinked libraries: /lib64/libdl.so.2
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libinstrument.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libinstrument.so: overlinked libraries: /lib64/libdl.so.2 /lib64/libz.so.1
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjava.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjavajpeg.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjawt.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjawt.so: overlinked libraries: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libawt.so /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjava.so
readelf: Warning: local symbol 3 found at index >= .dynsym's sh_info value of 3
readelf: Warning: local symbol 4 found at index >= .dynsym's sh_info value of 3
readelf: Warning: local symbol 5 found at index >= .dynsym's sh_info value of 3
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjdwp.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjdwp.so: overlinked libraries: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjava.so
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjimage.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjimage.so: overlinked libraries: /lib64/libm.so.6
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libjsound.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjsound.so: overlinked libraries: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjava.so
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/liblcms.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libmanagement.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libmanagement_agent.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libmanagement_ext.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libmlib_image.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libmlib_image.so: overlinked libraries: /lib64/libdl.so.2 /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjava.so
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libnativewindow_awt.so: library libjawt.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libnativewindow_x11.so: underlinked libraries: /lib64/libdl.so.2
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libnet.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libprefs.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/librmi.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libsaproc.so: overlinked libraries: /lib64/libm.so.6
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libsctp.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libsctp.so: overlinked libraries: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libnio.so
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libsplashscreen.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libsplashscreen.so: overlinked libraries: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/libjava.so
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libverify.so: library libjvm.so not found
lib.req: WARNING: /PhpStorm-233.13135.108/jbr/lib/libzip.so: library libjvm.so not found
lib.req: WARNING: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/jbr/lib/server/libjvm.so: overlinked libraries: /lib64/librt.so.1
ldd: ERROR: /var/tmp/tmp.Cdr69IpYg3/PhpStorm-2023.3.2.tar.gz.tmpdir/PhpStorm-2023.3.2/PhpStorm-233.13135.108/lib/async-profiler/aarch64/libasyncProfiler.so: failed to find the program interpreter
find-requires: ERROR: /usr/lib/rpm/lib.req failed
ошибка: /bin/sh failed
ошибка: Failed to find Requires
    Файл указан дважды: /PhpStorm-233.13135.108
    Файл указан дважды: /PhpStorm-233.13135.108
    Файл указан дважды: /PhpStorm-233.13135.108
    Файл указан дважды: /PhpStorm-233.13135.108/bin
    Файл указан дважды: /PhpStorm-233.13135.108/lib
    Файл указан дважды: /PhpStorm-233.13135.108/plugins
    Файл указан дважды: /PhpStorm-233.13135.108/plugins/remote-dev-server
    Файл указан дважды: /PhpStorm-233.13135.108/plugins/webp
    Файл указан дважды: /PhpStorm-233.13135.108/plugins/webp/lib
    /bin/sh failed
    Failed to find Requires
ERROR:   (you can discuss the epm 3.57.6-alt1 problem in Telegram: https://t.me/useepm)

Оффлайн N0rbert

  • alt linux team
  • ***
  • Сообщений: 231
  • snk@
Про активатор не знаю, а сам PhpStorm нормально ставится в p10 через JetBrains Toolbox :

# epm play jetbrains-toolbox
$ jetbrains-toolbox

И остальные IDE от JetBrains также можно так поставить.
« Последнее редактирование: 09.01.2024 22:35:47 от N0rbert »

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
У меня он не ставится (пробовал и из-под пользователя, и из-под root): [a@lureenvoy ~]$ epm play jetbrains-toolbox
WARNING: APT database is 2 days old, please run 'epm update'!
 $ /usr/bin/env bash /etc/eepm/play.d/jetbrains-toolbox.sh --run
 $ epm --inscript tool json -b
 $ eget -O- https://data.services.jetbrains.com/products?code=TBA&release.type=eap%2Crc%2Crelease&fields=distributions%2Clink%2Cname%2Creleases
 $ json -b
 $ /usr/bin/wget -O- https://data.services.jetbrains.com/products?code=TBA&release.type=eap%2Crc%2Crelease&fields=distributions%2Clink%2Cname%2Creleases
--2024-01-10 02:39:37--  https://data.services.jetbrains.com/products?code=TBA&release.type=eap%2Crc%2Crelease&fields=distributions%2Clink%2Cname%2Creleases
Распознаётся data.services.jetbrains.com (data.services.jetbrains.com)… 52.211.46.177, 52.212.3.79, 2a05:d018:941:c02:db54:95f8:5688:d0a1, ...
Подключение к data.services.jetbrains.com (data.services.jetbrains.com)|52.211.46.177|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200
Длина: нет данных [application/json]
Сохранение в: «STDOUT»

-                       [   <=>              ] 165,95K   253KB/s    за 0,7s   

2024-01-10 02:39:40 (253 KB/s) - записан в stdout [169934]

 $ epm pack --install jetbrains-toolbox https://download.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz
 $ eget --latest https://download.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz
 $ /usr/bin/wget --content-disposition https://download.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz
--2024-01-10 02:39:40--  https://download.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz
Распознаётся download.jetbrains.com (download.jetbrains.com)… 108.138.51.96, 108.138.51.117, 108.138.51.25, ...
Подключение к download.jetbrains.com (download.jetbrains.com)|108.138.51.96|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 302 Moved Temporarily
Адрес: https://download-cdn.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz [переход]
--2024-01-10 02:39:41--  https://download-cdn.jetbrains.com/toolbox/jetbrains-toolbox-2.1.3.18901.tar.gz
Распознаётся download-cdn.jetbrains.com (download-cdn.jetbrains.com)… 108.138.51.120, 108.138.51.4, 108.138.51.3, ...
Подключение к download-cdn.jetbrains.com (download-cdn.jetbrains.com)|108.138.51.120|:443... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 OK
Длина: 73721189 (70M) [binary/octet-stream]
Сохранение в: «jetbrains-toolbox-2.1.3.18901.tar.gz»

jetbrains-toolbox-2 100%[===================>]  70,31M   898KB/s    за 94s     

2024-01-10 02:41:15 (767 KB/s) - «jetbrains-toolbox-2.1.3.18901.tar.gz» сохранён [73721189/73721189]

 $ /usr/bin/env bash /etc/eepm/pack.d/jetbrains-toolbox.sh /var/tmp/tmp.wlHqX9Eji2/jetbrains-toolbox-2.1.3.18901.tar.gz /var/tmp/tmp.2aVTg0WjBy/filefortarname 
 $ erc /var/tmp/tmp.wlHqX9Eji2/jetbrains-toolbox-2.1.3.18901.tar.gz
 $ 7z x -si -ttar
 $ 7z x -so /var/tmp/tmp.wlHqX9Eji2/jetbrains-toolbox-2.1.3.18901.tar.gz

7-Zip [64] 17.04 : Copyright (c) 1999-2021 Igor Pavlov : 2017-08-28
p7zip Version 17.04 (locale=ru_RU.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs AMD FX(tm)-4300 Quad-Core Processor             (600F20),ASM,AES-NI)


Extracting archive:
--
Path =
Type = tar
Code Page = UTF-8

Everything is Ok                                       

Folders: 1
Files: 1
Size:       73998312
Compressed: 6144
пакет /var/tmp/tmp.2aVTg0WjBy/jetbrains-toolbox-2.1.3.18901/jetbrains-toolbox-2.1.3.18901.AppImage не установлен

Repacking /var/tmp/tmp.2aVTg0WjBy/jetbrains-toolbox-2.1.3.18901/jetbrains-toolbox-2.1.3.18901.AppImage to local rpm format (inside /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir) ...
 $ /usr/bin/env bash /etc/eepm/pack.d/generic-appimage.sh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage /var/tmp/tmp.2X9BQuDJIg/filefortarname 
/usr/bin/AppImageLauncher: /usr/lib64/libcurl.so.4: no version information available (required by /usr/bin/../lib/x86_64-linux-gnu/appimagelauncher/libappimageupdate.so)
 $ erc pack jetbrains-toolbox-2.1.3.18901.tar squashfs-root
WARNING: Couldn't read jetbrains-toolbox-2.1.3.18901.tar, skipping mime checking
 $ 7z a jetbrains-toolbox-2.1.3.18901.tar squashfs-root

7-Zip [64] 17.04 : Copyright (c) 1999-2021 Igor Pavlov : 2017-08-28
p7zip Version 17.04 (locale=ru_RU.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs AMD FX(tm)-4300 Quad-Core Processor             (600F20),ASM,AES-NI)

Scanning the drive:
28 folders, 176 files, 110488764 bytes (106 MiB)

Creating archive: jetbrains-toolbox-2.1.3.18901.tar

Items to compress: 204

   
Files read from disk: 204
Archive size: 110636544 bytes (106 MiB)
Everything is Ok
 $ alien --generate --to-rpm ../jetbrains-toolbox-2.1.3.18901.tar
Warning: alien is not running as root!
Warning: Ownerships of files in the generated packages will probably be wrong.
 $ /usr/bin/env bash /etc/eepm/repack.d/generic.sh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901 /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901-2.spec jetbrains-toolbox /var/tmp/tmp.2aVTg0WjBy/jetbrains-toolbox-2.1.3.18901/jetbrains-toolbox-2.1.3.18901.AppImage
 $ /usr/bin/env bash /etc/eepm/repack.d/generic-appimage.sh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901 /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901-2.spec jetbrains-toolbox /var/tmp/tmp.2aVTg0WjBy/jetbrains-toolbox-2.1.3.18901/jetbrains-toolbox-2.1.3.18901.AppImage
 $ /usr/bin/env bash /etc/eepm/repack.d/jetbrains-toolbox.sh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901 /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901-2.spec jetbrains-toolbox /var/tmp/tmp.2aVTg0WjBy/jetbrains-toolbox-2.1.3.18901/jetbrains-toolbox-2.1.3.18901.AppImage
 $ rpmbuild --buildroot /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901 --target x86_64 -bb /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901.AppImage.tmpdir/jetbrains-toolbox-2.1.3.18901-2.spec
 $ epm install /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm
WARNING: %%% You are trying install package /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm repacked from third-party software source. Use it at your own risk. %%%
sudo: a password is required
Please enter sudo user password to use sudo in the current session.
 $ sudo rpm -Uvh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm
[sudo] password for a:
Sorry, user a is not allowed to execute '/bin/rpm -Uvh /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm' as root on lureenvoy.
[sudo] password for a:

 $ sudo apt-get -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true install /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm
[sudo] password for a:
Sorry, user a is not allowed to execute '/usr/bin/apt-get -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true install /var/tmp/tmp.2X9BQuDJIg/jetbrains-toolbox-2.1.3.18901-epm1.repacked.2.x86_64.rpm' as root on lureenvoy.
ERROR: There was some error during install the application.  (you can discuss the epm 3.57.6-alt1 problem in Telegram: https://t.me/useepm)

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
пробовал и из-под пользователя
Из под пользователя НЕ устанавливают даже скачанное локально! Из под пользователя можно только перепаковать!

Оффлайн gosts 87

  • Завсегдатай
  • *
  • Сообщений: 2 724
  • Дмитрий/Dmitry/德米特里/दिमित्री
А так, в логах указано, что не хватает кое-каких библиотек...

Оффлайн Vaasiliy

  • Странник
  • *
  • Сообщений: 5
я так понимаю, вопрос уже здесь решили?
« Последнее редактирование: 01.06.2024 18:51:06 от Vaasiliy »

Оффлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 337
Смотря какая версия. https://www.jetbrains.com/ru-ru/pycharm/download/?section=linux
Там 2 версии: платная Professional - у неё пока так и нет нескольких библиотек, и бесплатная Community Edition - там всё нормально ставится.
Я пока только начал изучать Python - мне и бесплатной достаточно, а кто например с графикой что-то пишет - в ней ни Flask, ни Django не поддерживается. Конечно, здесь бесплатная не вариант, а консоль самого Python очень неудобная.
На бесплатной версии тоже не всё хорошо (я проверил на другой версии Линукс - глюк есть, на виндовс-версии - нету). При нажатии на кнопку "Python Packages" - IDE падает.
« Последнее редактирование: 28.05.2024 20:04:32 от GrishaDm »