Автор Тема: Можно ли поставить anjuta в Альтлинукс 10?  (Прочитано 1135 раз)

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
У меня не получилось. Брал отсюда: https://gitlab.gnome.org/Archive/anjuta

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 976

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
Попробовал отсюда. но и тут не смог: [a@lureenvoy ~]$ su -
Password:
[root@lureenvoy ~]# epm -i /home/a/Загрузки/anjuta-3.8.2/*.rpm
 # rpm -Uvh --replacepkgs /home/a/Загрузки/anjuta-3.8.2/anjuta-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devel-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-glade-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-glade-debuginfo-3.8.2-alt2.x86_64.rpm
ошибка: Неудовлетворенные зависимости:
autogen >= 5.0 нужен для anjuta-3.8.2-alt2.x86_64
libgda4-sqlite нужен для anjuta-3.8.2-alt2.x86_64
libgda-4.0.so.4()(64bit) >= set:nh0Lg6lhpgyhBm2DtYXZzSYvbhaebuvdtZnpPRDXnvMA76cim9nnBk04lnt8JnQHrK5tXkbmOkV8ZGd1lR6xu2i3Z2T9A4F8GHM9 нужен для anjuta-3.8.2-alt2.x86_64
libgdl-3.so.5()(64bit) >= set:lgvikhKZlopH8EH5Q7JfqxRVA65bc5FglsRJmAUT0HCeVR8XVZv73uZiJdOXAI6f нужен для anjuta-3.8.2-alt2.x86_64
libvala-0.20.so.0()(64bit) >= set:piKZmDyy703TsJNXdv2GFwNQz91PQBZ5USK3RPgwJdZFiUaQH4ym0DPoK74RyHqCjPQYCcj8Km6P3f3rt4sszjiYWTFGkuZorJZ52YZzaskeXSEHYYtzkodSh3PVk4aLIuMMZaOC6UIz5EjV2mWqfC5kgp3Mh1nkGuJPCyOZmgUWnEAEPCQTglZ729eOxUSUGjhiBwzQJ25xZJxLMrHaAjMjTEBlUA9BbAt4tIDlM7Wqvf3U6ZF2OgzFU8Usfv2m2EeYB6zcbvC8TMiGJbm8xg0yJoFZzNG7VKxZ97jJPudiZD6Autd4QjjZmp5sVWnXskFuFBgBpoQ4PR5D7cxrcWsRApGiLLTHfJj0 нужен для anjuta-3.8.2-alt2.x86_64
libvte2_90.so.9()(64bit) >= set:lhbSgtTqVXUAiyZs4RqdsZsXvRCb6Cb нужен для anjuta-3.8.2-alt2.x86_64
python2.7(distutils) нужен для anjuta-3.8.2-alt2.x86_64
python2.7(pkg_resources) нужен для anjuta-3.8.2-alt2.x86_64
python2.7(rope) нужен для anjuta-3.8.2-alt2.x86_64
cvs нужен для anjuta-cvs-3.8.2-alt2.x86_64
/usr/lib/debug/lib64/ld-linux-x86-64.so.2.debug нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libc.so.6) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libcairo.so.2) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgcc_s.so.1) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgda-4.0.so.4) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgdk-3.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgdk_pixbuf-2.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgdl-3.so.5) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgio-2.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libglib-2.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgmodule-2.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgobject-2.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgtk-3.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libgtksourceview-3.0.so.1) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libpango-1.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libpangocairo-1.0.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libpthread.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libpython2.7.so.1.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libstdc++.so.6) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libutil.so.1) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libvala-0.20.so.0) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libvte2_90.so.9) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
debug64(libxml2.so.2) нужен для anjuta-debuginfo-3.8.2-alt2.x86_64
gir(GObject) = 2.0 нужен для anjuta-devel-3.8.2-alt2.x86_64
gir(Gtk) = 3.0 нужен для anjuta-devel-3.8.2-alt2.x86_64
libgdl3-devel нужен для anjuta-devel-3.8.2-alt2.x86_64
libgtk+3-devel нужен для anjuta-devel-3.8.2-alt2.x86_64
pkgconfig(gdl-3.0) нужен для anjuta-devel-3.8.2-alt2.x86_64
pkgconfig(gtk+-3.0) нужен для anjuta-devel-3.8.2-alt2.x86_64
libdevhelp-3.so.2()(64bit) >= set:kh74UyklfqjfNbWy5wTt3 нужен для anjuta-devhelp-3.8.2-alt2.x86_64
libwebkit2gtk-3.0.so.25()(64bit) >= set:pmCylzs7FYAxiCZm8epZAFvIq91 нужен для anjuta-devhelp-3.8.2-alt2.x86_64
debug64(libdevhelp-3.so.2) нужен для anjuta-devhelp-debuginfo-3.8.2-alt2.x86_64
debug64(libwebkit2gtk-3.0.so.25) нужен для anjuta-devhelp-debuginfo-3.8.2-alt2.x86_64
libgladeui-2.so.4()(64bit) >= set:nhutjZBsVyJt9J445z4TJ5WT9pGHiCLSYZLKlX7IrCS0zsGFu98Hm4JIaHhVdD2V9Zbre3DE2urTChfdNCLg7NRZ1ZCIKf4P5ht7ZECNHAYd8GvI8BF0k661y8WC5vpGclHFfHZuNJGEElZfxYs2bvE4eKJ9tz6 нужен для anjuta-glade-3.8.2-alt2.x86_64
debug64(libgladeui-2.so.4) нужен для anjuta-glade-debuginfo-3.8.2-alt2.x86_64

 # apt-get -o APT::Install::VirtualVersion=true -o APT::Install::Virtual=true install /home/a/Загрузки/anjuta-3.8.2/anjuta-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devel-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-debuginfo-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-glade-3.8.2-alt2.x86_64.rpm /home/a/Загрузки/anjuta-3.8.2/anjuta-glade-debuginfo-3.8.2-alt2.x86_64.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано anjuta для '/home/a/Загрузки/anjuta-3.8.2/anjuta-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-cvs для '/home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-cvs-debuginfo для '/home/a/Загрузки/anjuta-3.8.2/anjuta-cvs-debuginfo-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-debuginfo для '/home/a/Загрузки/anjuta-3.8.2/anjuta-debuginfo-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-devel для '/home/a/Загрузки/anjuta-3.8.2/anjuta-devel-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-devhelp для '/home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-devhelp-debuginfo для '/home/a/Загрузки/anjuta-3.8.2/anjuta-devhelp-debuginfo-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-glade для '/home/a/Загрузки/anjuta-3.8.2/anjuta-glade-3.8.2-alt2.x86_64.rpm'
Выбрано anjuta-glade-debuginfo для '/home/a/Загрузки/anjuta-3.8.2/anjuta-glade-debuginfo-3.8.2-alt2.x86_64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  anjuta: Depends: libgda4-sqlite но пакет не может быть установлен
          Depends: libgda-4.0.so.4()(64bit) (>= set:nh0Lg6lhpgyhBm2DtYXZzSYvbhaebuvdtZnpPRDXnvMA76cim9nnBk04lnt8JnQHrK5tXkbmOkV8ZGd1lR6xu2i3Z2T9A4F8GHM9) но пакет не может быть установлен
          Depends: libvala-0.20.so.0()(64bit) (>= set:piKZmDyy703TsJNXdv2GFwNQz91PQBZ5USK3RPgwJdZFiUaQH4ym0DPoK74RyHqCjPQYCcj8Km6P3f3rt4sszjiYWTFGkuZorJZ52YZzaskeXSEHYYtzkodSh3PVk4aLIuMMZaOC6UIz5EjV2mWqfC5kgp3Mh1nkGuJPCyOZmgUWnEAEPCQTglZ729eOxUSUGjhiBwzQJ25xZJxLMrHaAjMjTEBlUA9BbAt4tIDlM7Wqvf3U6ZF2OgzFU8Usfv2m2EeYB6zcbvC8TMiGJbm8xg0yJoFZzNG7VKxZ97jJPudiZD6Autd4QjjZmp5sVWnXskFuFBgBpoQ4PR5D7cxrcWsRApGiLLTHfJj0) но пакет не может быть установлен
          Depends: libvte2_90.so.9()(64bit) (>= set:lhbSgtTqVXUAiyZs4RqdsZsXvRCb6Cb) но пакет не может быть установлен
          Depends: python2.7(rope) но пакет не может быть установлен
  anjuta-debuginfo: Depends: /usr/lib/debug/lib64/ld-linux-x86-64.so.2.debug но пакет не может быть установлен
                    Depends: debug64(libc.so.6) но пакет не может быть установлен
                    Depends: debug64(libcairo.so.2) но пакет не может быть установлен
                    Depends: debug64(libgcc_s.so.1) но пакет не может быть установлен
                    Depends: debug64(libgda-4.0.so.4) но пакет не может быть установлен
                    Depends: debug64(libgdk-3.so.0) но пакет не может быть установлен
                    Depends: debug64(libgdk_pixbuf-2.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libgdl-3.so.5) но пакет не может быть установлен
                    Depends: debug64(libgio-2.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libglib-2.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libgmodule-2.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libgobject-2.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libgtk-3.so.0) но пакет не может быть установлен
                    Depends: debug64(libgtksourceview-3.0.so.1) но пакет не может быть установлен
                    Depends: debug64(libpango-1.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libpangocairo-1.0.so.0) но пакет не может быть установлен
                    Depends: debug64(libpthread.so.0) но пакет не может быть установлен
                    Depends: debug64(libpython2.7.so.1.0) но пакет не может быть установлен
                    Depends: debug64(libstdc++.so.6) но пакет не может быть установлен
                    Depends: debug64(libutil.so.1) но пакет не может быть установлен
                    Depends: debug64(libvala-0.20.so.0) но пакет не может быть установлен
                    Depends: debug64(libvte2_90.so.9) но пакет не может быть установлен
                    Depends: debug64(libxml2.so.2) но пакет не может быть установлен
  anjuta-devhelp: Depends: libdevhelp-3.so.2()(64bit) (>= set:kh74UyklfqjfNbWy5wTt3) но пакет не может быть установлен
                  Depends: libwebkit2gtk-3.0.so.25()(64bit) (>= set:pmCylzs7FYAxiCZm8epZAFvIq91) но пакет не может быть установлен
  anjuta-devhelp-debuginfo: Depends: debug64(libdevhelp-3.so.2) но пакет не может быть установлен
                            Depends: debug64(libwebkit2gtk-3.0.so.25) но пакет не может быть установлен
  anjuta-glade: Depends: libgladeui-2.so.4()(64bit) (>= set:nhutjZBsVyJt9J445z4TJ5WT9pGHiCLSYZLKlX7IrCS0zsGFu98Hm4JIaHhVdD2V9Zbre3DE2urTChfdNCLg7NRZ1ZCIKf4P5ht7ZECNHAYd8GvI8BF0k661y8WC5vpGclHFfHZuNJGEElZfxYs2bvE4eKJ9tz6) но пакет не может быть установлен
  anjuta-glade-debuginfo: Depends: debug64(libgladeui-2.so.4) но пакет не может быть установлен
E: Извините, `битые' пакеты

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 976
ну дак оно еще 2 пайтон хочет, все протухло...


пробуйте последние версии из https://pkgs.org/download/anjuta

может что и влетит из др. дистров - как минимум есть аж 5 попыток - мандрейк, суся, федора и красношапка, да еще и пс-лиукс :)))


а по нормальному пересобирать из исходников надо...
« Последнее редактирование: 12.04.2024 18:31:56 от YYY »

Оффлайн ProfessorNavigator

  • Давно тут
  • **
  • Сообщений: 240
а по нормальному пересобирать из исходников надо...
На сколько я понимаю - смысла особого нет. Оно заброшено. В Gnome теперь другая IDE. Если Gnome не принципиален, то надо уже смотреть, в зависимости от ЯП. Для C++ навскидку - Qt Creator, CodeBlocks, Eclipse CDT, NetBeans. Для других - не знаю, не писал под них.

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
Gnome Builder я тоже установить не смог. Там только через flatpak. А там ошибки идут.

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 976
а по нормальному пересобирать из исходников надо...
На сколько я понимаю - смысла особого нет. Оно заброшено.

может быть это надо just for lulz

вообще лучшая IDE на GTK это Geany!

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
Попробовал Codeblocks 20.03  а там пакеты deb. Естественно, ничего не ставится.

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 976
Попробовал Codeblocks 20.03  а там пакеты deb. Естественно, ничего не ставится.

он же есть в репе

https://packages.altlinux.org/en/search/?branch=p10&q=Codeblocks


Оффлайн ProfessorNavigator

  • Давно тут
  • **
  • Сообщений: 240
вообще лучшая IDE на GTK это Geany!
Пробовал - да, в принципе нормально. Единственно - с настройкой повозиться надо. Лично я предпочитаю Eclipse. Конечно, грузит процессор и память, но зато неплохая проверка синтаксиса "на лету", подсветка синтаксиса тоже достаточно удобная, плюс автоформатирование кода неплохо работает. А также есть забавная штука - автоматическое подключение заголовочных файлов. Иногда подглючивает или пихает лишнее, но в целом - сильно упрощает жизнь. CodeBlocks тоже неплох. Единственно, когда я последний раз его смотрел, плагин автоформатирования не совсем корректно работал. Можно было вручную подключить сторонний "форматер", но тогда им пользоваться уже не очень удобно. Ну и интерфейс работы с GDB и Valgrind мне тоже не очень нравится. Хотя в целом CodeBlocks меня выручал, когда нужно было под aarch64 код отлаживать.   

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
https://packages.altlinux.org/en/search/?branch=p10&q=Codeblocks
У меня не устанавливаются пакеты codeblocks-contrib-debuginfo-20.03-alt7.x86_64.rpm и codeblocks-debuginfo-20.03-alt7.x86_64.rpm
Получено: 1 http://altlinuxclub.ru x86_64 release [1733B]

Получено: 2 http://ftp.altlinux.org p10/branch/x86_64 release [4223B]

Получено: 3 http://ftp.altlinux.org p10/branch/x86_64-i586 release [1665B]

Получено: 4 http://ftp.altlinux.org p10/branch/noarch release [2844B]

Получено 10,5kB за 0s (11,6kB/s).

Найдено http://altlinuxclub.ru x86_64/hasher pkglist

Найдено http://ftp.altlinux.org p10/branch/x86_64/classic pkglist

Найдено http://altlinuxclub.ru x86_64/hasher release

Найдено http://ftp.altlinux.org p10/branch/x86_64/classic release

Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic pkglist

Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic release

Найдено http://ftp.altlinux.org p10/branch/noarch/classic pkglist

Найдено http://ftp.altlinux.org p10/branch/noarch/classic release

Чтение списков пакетов...

Построение дерева зависимостей...

Reading Package Lists...
Building Dependency Tree...
Selecting codeblocks-contrib-debuginfo for '/run/media/a/Новый том/codeblocks-contrib-debuginfo-20.03-alt7.x86_64.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following packages have unmet dependencies:
  codeblocks-contrib-debuginfo: Depends: debug64(libbz2.so.1) but it is not installable
                                Depends: debug64(libfontconfig.so.1) but it is not installable
                                Depends: debug64(libgamin-1.so.0) but it is not installable
                                Depends: debug64(libhunspell.so.2) but it is not installable
                                Depends: debug64(libwx_gtk3u_richtext-3.1.so.5) but it is not installable
                                Depends: debug64(libz.so.1) but it is not installable
                                Depends: codeblocks-debuginfo (= 20.03-alt7:p10+290312.100.1.1) but it is not installable
E: Broken packages
Получено: 1 http://ftp.altlinux.org p10/branch/x86_64 release [4223B]

Получено: 2 http://altlinuxclub.ru x86_64 release [1733B]

Получено: 3 http://ftp.altlinux.org p10/branch/x86_64-i586 release [1665B]

Получено: 4 http://ftp.altlinux.org p10/branch/noarch release [2844B]

Получено 10,5kB за 0s (12,5kB/s).

Найдено http://ftp.altlinux.org p10/branch/x86_64/classic pkglist

Найдено http://altlinuxclub.ru x86_64/hasher pkglist

Найдено http://ftp.altlinux.org p10/branch/x86_64/classic release

Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic pkglist

Найдено http://ftp.altlinux.org p10/branch/x86_64-i586/classic release

Найдено http://ftp.altlinux.org p10/branch/noarch/classic pkglist

Найдено http://ftp.altlinux.org p10/branch/noarch/classic release

Найдено http://altlinuxclub.ru x86_64/hasher release

Чтение списков пакетов...

Построение дерева зависимостей...

Reading Package Lists...
Building Dependency Tree...
Selecting codeblocks-debuginfo for '/run/media/a/Новый том/codeblocks-debuginfo-20.03-alt7.x86_64.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following packages have unmet dependencies:
  codeblocks-debuginfo: Depends: /usr/lib/debug/lib64/ld-linux-x86-64.so.2.debug but it is not installable
                        Depends: debug64(libc.so.6) but it is not installable
                        Depends: debug64(libgcc_s.so.1) but it is not installable
                        Depends: debug64(libgdk-3.so.0) but it is not installable
                        Depends: debug64(libglib-2.0.so.0) but it is not installable
                        Depends: debug64(libm.so.6) but it is not installable
                        Depends: debug64(libpthread.so.0) but it is not installable
                        Depends: debug64(libstdc++.so.6) but it is not installable
                        Depends: debug64(libtinyxml.so.0) but it is not installable
                        Depends: debug64(libwx_baseu-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_baseu_net-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_baseu_xml-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_aui-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_core-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_html-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_propgrid-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_qa-3.1.so.5) but it is not installable
                        Depends: debug64(libwx_gtk3u_xrc-3.1.so.5) but it is not installable
E: Broken packages

Оффлайн YYY

  • Мастер
  • ***
  • Сообщений: 5 976


у вас сети нет?

apt-get update
apt-get install codeblocks

Онлайн GrishaDm

  • Давно тут
  • **
  • Сообщений: 332
у вас сети нет?
В том то и дело, что сеть есть.
[a@lureenvoy ~]$ su -
Password:
[root@lureenvoy ~]# apt-get update
E: Невозможно заблокировать /var/lib/apt/lists/lock - open (11 Ресурс временно недоступен)
E: Unable to lock the list directory

Оффлайн artenaki

  • Давно тут
  • **
  • Сообщений: 198
вообще лучшая IDE на GTK это Geany
В Visual Studio встроят Copilot. Вот это будет бомба. Придётся ставить десяточку.
Не программист совсем, но если Copilot будет писать софт за меня, то это будет круто.
Может быть даже уйду на винду, если в линуксовые IDE, типа QtCreator, подобное не встроят.

Оффлайн andrew_b

  • Завсегдатай
  • *
  • Сообщений: 536
У меня не устанавливаются пакеты codeblocks-contrib-debuginfo-20.03-alt7.x86_64.rpm и codeblocks-debuginfo-20.03-alt7.x86_64.rpm
А зачем они вам? Вы собираетесь отлаживать codeblocks?