Автор Тема: Автовход и энергосбережение в LXDE [решено]  (Прочитано 9867 раз)

Оффлайн Paul.ZS256

  • Завсегдатай
  • *
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
Re: Автовход и энергосбережение в LXDE
« Ответ #15 : 01.02.2017 04:22:36 »
Вот только как быть с энергосбережением?

xset -dpms s off

Увы. Как выяснилось, рано радовался. Результат не подтверждаю. Все-таки не то :-(
Простой учитель из Приморья

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 493
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #16 : 01.02.2017 06:03:51 »
Как не подтверждаете. Оно, только до первой перезагрузки. Если постоянно надо, надо в настройках xorg прописать.

Option "DPMS" "false"
« Последнее редактирование: 01.02.2017 07:47:21 от ruslandh »

Оффлайн Paul.ZS256

  • Завсегдатай
  • *
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
Re: Автовход и энергосбережение в LXDE
« Ответ #17 : 01.02.2017 07:26:56 »
упс... понял.

вот только почему-то не могу найти xorg.conf
« Последнее редактирование: 01.02.2017 08:07:25 от Paul.ZS256 »
Простой учитель из Приморья

Оффлайн berkut_174

  • Мастер
  • ***
  • Сообщений: 7 087
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #18 : 01.02.2017 10:03:39 »
вот только почему-то не могу найти xorg.conf
Потому что его нужно создать самому: /etc/X11/xorg.conf.d/10-monitor.conf
Сноси Винду, переходи на Линукс ! :)

Оффлайн stranger573

  • Мастер
  • ***
  • Сообщений: 1 314
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #19 : 01.02.2017 13:10:27 »
1. Чтобы отключить dpms:
-------------------------------
в файле /etc/X11/xorg.conf.d/10-monitor.conf в конце секции "Monitor" нужно дописать строку — Option "DPMS" "false".

Секция должна выглядеть примерно так:
Section "Monitor"
    Identifier "Monitor0"
    Option "DPMS" "false"
EndSection
Причём это лучше сделать даже при наличии файла xorg.conf ибо записанное в этом файле подгружается последним и переопределяет параметры xorg.conf
=================

2. Далее. Одно это не поможет, поскольку монитор будет гаситься ещё одним способом. Чтобы решить и эту проблему надо в файле /etc/X11/xorg.conf в конце секции "ServerLayout" дописать строку — Option "BlankTime" "0".
Если по этому пути такого файла нет, то создать пустой файл в этом месте с именем xorg.conf
В случае если создали пустой файл его содержимое должно быть таким:
Section "ServerLayout"
    Option         "BlankTime" "0"
EndSection

Не забываем, что в конце файла должна быть пустая строка!
Все указанные действия производим от рута.
Далее перезагружаемся и проверяем.

Для проверки можно использовать команду в консоли (а вот это уже делается с правами пользователя):
xset q
Если всё сделали правильно, то таймаут для "prefer blanking" должен равняться нулю и присутствовать запись "DPMS is Disabled".
=================

3. Есть ещё гашение экрана в текстовых консолях (тех, что вызываются наподобие Ctrl+Alt+F3). Тут можно сделать от рута в консоли:
setterm -blank 0 -powersave off
« Последнее редактирование: 01.02.2017 13:18:40 от stranger573 »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 393
    • Домашняя страница
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #20 : 01.02.2017 17:36:32 »
Спасибо. Оформил: https://www.altlinux.org/DPMS
Андрей Черепанов (cas@)

Оффлайн stranger573

  • Мастер
  • ***
  • Сообщений: 1 314
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #21 : 01.02.2017 18:42:33 »
To Skull не совсем правильно.
Это не три разных способа. Это шаги.

При всей кажущейся сложности дело обстоит несколько проще. Одновременно срабатывают три разных режима (поскольку по дефолту выставлены одинаковые таймауты). Проявляются эти режимы похоже, но тем не менее не одинаково.

В пукте первом описано отключение энергосбережения монитора (dpms). Аналог команды xset -dpms (только действует постоянно). При срабатывании dpms монитор переводится в энергосберегающий режим (в частности гасится подсветка).

В пункте втором отключается дефолтный скринсейвер (постоянный аналог параметра s для xset), который по истечении таймаута показывает чёрный экран (подсветка не отключается). Этот режим срабатывает если не задан (или не включен в автостарте) никакой скринсейвер. Т.е. первый и второй пункты вместе — это постоянный аналог команды xset -dpms s off. Уточнение — чтобы этот пункт возымел действие скринсейвер в автозагрузке должен быть выключен.

В пункте третьем выключается отключение экрана для виртуальных консолей. Это тоже отдельный механизм (используется APM).
В дополнение к пункту 3. Проверил, рут не обязателен, можно залогинится и пользователем. Команда работает до перезагрузки и действует на все виртуальные консоли. Для постоянного использования нужно при загрузке передать ядру параметр consoleblank=0 (в конфигурации GRUB) или делать стартовый скрипт. Посмотреть текущее значение (в секундах) можно командой:
$ cat /sys/module/kernel/parameters/consoleblank

Подробности для пунктов 1 и 2 можно прочитать в man xorg.conf в описании секций ServerFlags, ServerLayout, Monitor.
Для пункта 3 — man setterm.
« Последнее редактирование: 01.02.2017 22:50:16 от stranger573 »

Оффлайн Skull

  • Глобальный модератор
  • *****
  • Сообщений: 19 393
    • Домашняя страница
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #22 : 01.02.2017 19:24:38 »
Спасибо, внесу корректировку.
Андрей Черепанов (cas@)

Оффлайн Paul.ZS256

  • Завсегдатай
  • *
  • Сообщений: 112
    • МОУ СОШ им. А.И. Крушанова
Re: Автовход и энергосбережение в LXDE
« Ответ #23 : 03.02.2017 03:38:51 »
к сожалению не получилось... судя по всему я совсем разучился настраивать линукс за прошедшие три (или сколько там прошло?) года: настроил на своих машинках Школьный Мастер 7.0  и работают они как часы до сих пор, единственно что остается - обновляться.

Но к теме:

Создал  /etc/X11/xorg.conf.d/10-monitor.conf (см. приложенный файл)

Создал /etc/X11/xorg.conf с одной секцией "ServerLayout" (см. приложенный файл)

иксы не стартуют. Логи -- см. приложенный файл

После удаления созданного xorg.conf иксы стартуют без проблем, однако как было отмечено stranger573, проблема с отключением монитора остается.
« Последнее редактирование: 03.02.2017 04:21:30 от Paul.ZS256 »
Простой учитель из Приморья

dango

  • Гость
Re: Автовход и энергосбережение в LXDE
« Ответ #24 : 03.02.2017 07:33:32 »
Xorg.0.log
Цитировать
Parse error on line 3 of section ServerLayout in file /etc/X11/xorg.conf
   This section must have an Identifier line.
(EE) Problem parsing the config file
(EE) Error parsing the config file
Иксы не могут разобрать содержимое файла xorg.conf. Ругань идет на отсутствие строки идентификатора.
Цитировать
Section "ServerLayout"
    Option   "BlankTime" "0"
    EndSection
Попробуйте вот так:
Section "ServerLayout"
Identifier "ServerLayout0"
Option "BlankTime" "0"
EndSection
« Последнее редактирование: 03.02.2017 07:35:29 от dango »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 493
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #25 : 03.02.2017 07:35:06 »
Цитировать
Parse error on line 3 of section ServerLayout in file /etc/X11/xorg.conf
   This section must have an Identifier line.
Цитировать
Section "ServerLayout"
    Option   "BlankTime" "0"
    EndSection
   

dango

  • Гость
Re: Автовход и энергосбережение в LXDE
« Ответ #26 : 03.02.2017 07:40:42 »
И кстати, можно обойтись без создания /etc/X11/xorg.conf, и все поместить в /etc/X11/xorg.conf.d/10-monitor.conf
Будет выглядить так:
Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "false"
EndSection
Section "ServerLayout"
Identifier "ServerLayout0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
Option "BlankTime" "0"
EndSection
В свое время брал отсюда: https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling
« Последнее редактирование: 03.02.2017 07:45:35 от dango »

Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 493
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #27 : 03.02.2017 07:43:19 »
У вас не указан идентификатор, который указывает устройство, к которому относится ServerLayout

Должно быть что-то типа:

Section "ServerLayout"
             Identifier   "name"
            Option   "BlankTime" "0"
EndSection


Цитата: man xorg.conf
       ServerLayout sections have the following format:

           Section "ServerLayout"
               Identifier   "name"
               Screen       "screen-id"
               ...
               InputDevice  "idev-id"
               ...
               options
               ...
           EndSection

       Each ServerLayout section must have an Identifier entry  and  at  least
       one Screen entry.


Оффлайн ruslandh

  • Поспешай не торопясь !
  • Модератор глобальный
  • *****
  • Сообщений: 31 493
  • Учиться .... Телепатами не рождаются, ими ....
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #28 : 03.02.2017 07:58:50 »
И кстати, можно обойтись без создания /etc/X11/xorg.conf, и все поместить в /etc/X11/xorg.conf.d/10-monitor.conf
Да, конечно

Оффлайн stranger573

  • Мастер
  • ***
  • Сообщений: 1 314
    • Email
Re: Автовход и энергосбережение в LXDE
« Ответ #29 : 03.02.2017 11:14:05 »
судя по всему я совсем разучился настраивать линукс
Не разучились, если сразу лог приложили. :-)

единственно что остается - обновляться.
Ну зачем же сразу сдаваться, тем более, что обновление проблему с гашением экрана не решит точно, да и добавить новых проблем вполне может.

Давайте уж попробуем найти более универсальный вариант. Хотя у меня работает и так, выше правильно написали — парсеру не понравилось отсутствие идентификатора. Его можно вписать. Можно также всё собрать в одном файле 10-monitor.conf, но так делать не стоит по той причине, что пройдёт пара лет, всё это забудется — ищи потом где эти опции вдруг мешать начали. Можно также сгенерировать xorg.conf, но это тоже не очень хорошо, поскольку такой файл применим только с той конфигурацией железа с которой сделан.

Мне кажется, тогда лучше попробовать использовать менее привередливую секцию "ServerFlags". Если у вас остался созданный файл xorg.conf — удалите его. Файл /etc/X11/xorg.conf.d/10-monitor.conf оставьте, он пригодится (насколько я понял, только с ним одним система загружается у вас нормально).
Создайте файл /etc/X11/xorg.conf.d/11-serverflags.conf со следующим содержимым:
# make for screensaver off
Section "ServerFlags"
    Option "BlankTime" "0"
EndSection


У себя проверил на трёх машинах — так тоже работает.
Такой вариант, если у вас заработает, будет более изящным и универсальным, нежели предложенные ранее.