Автор Тема: звук на встроеном интеловском аудио  (Прочитано 3147 раз)

Оффлайн DuKle

  • Начинающий
  • *
  • Сообщений: 19
Добрый день! Коллеги, не могу заставить издавать звуки встроенную звуковуху на моноблоке леново
lspci показывает вот такую модель:
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)

Вот вывод по команде lsmod | grep snd:

lsmod | grep snd
snd_hda_codec_hdmi     45056  0
snd_hda_codec_realtek    86016  0
snd_hda_codec_generic    69632  3 snd_hda_codec_realtek
snd_hda_intel          36864  3
snd_hda_codec         131072  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           77824  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               110592  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_seq                61440  2 snd_seq_midi_event,snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    69632  17 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd

alsamixer показывает card: pulseaudio
если через f6 выбрать звуковуху то показывает HDA Intel PCH
но звука нет.

В какую сторону копать?

UPD:  как показывает гугл, проблема с этими звуковухами общая для разных сборок линукса: и на убунту и на центОС и на федоре...
Неужто нет способа победить сие творение интеловских инженеров?
« Последнее редактирование: 02.10.2019 07:01:54 от DuKle »

Оффлайн Speccyfighter

  • Мастер
  • ***
  • Сообщений: 9 955
В какую сторону копать?

В сторону /proc/asound/ и amixer.

Оффлайн crimeagov

  • Начинающий
  • *
  • Сообщений: 2
Проблема та же, проявляется непонятно как: на одном железе всё ок, на другом точно также всё устанавливаешь и ничего не работает.
Что нужно копать в /proc/asound/ и amixer?
Если зайти под root и запустить x, то всё работает прекрасно, а под пользователем звука нет. Пользователь в группе audio есть (а пользователя root в этой группе нет).

P.S. Альт рабочая станция 9

Спойлер
aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default
    Playback/recording through the PulseAudio sound server
pulse
    PulseAudio Sound Server
sysdefault:CARD=PCH
    HDA Intel PCH, ALC887-VD Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    Front output / input
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC887-VD Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

Решение:
Удалил пакеты alsa-plugins-pulse и pulseaudio-daemon, теперь работает и под пользователем и под рутом.
« Последнее редактирование: 27.04.2022 11:10:37 от crimeagov »


Оффлайн rits

  • Завсегдатай
  • *
  • Сообщений: 837
  • ITS
cat /proc/asound/cards
 0 [ICH6           ]: ICH4 - Intel ICH6
                      Intel ICH6 with AD1981B at irq 21
 1 [Headset        ]: USB-Audio - Logitech USB Headset
                      Logitech Logitech USB Headset at usb-0000:03:00.1-1, full speed

# apt-get install asoundconf asoundconf-gtk

$ asoundconf list
Names of available sound cards:
ICH6
Headset

Дефолтная умолчальная карта - usb-гарнитура:
$ asoundconf set-default-card Headset

Пользовать гуевое приложение asoundconf-gtk для выбора дефолтной карты.
В микшере, для выбора регулировки уровня громкости, выбрать карту.

Оффлайн crimeagov

  • Начинающий
  • *
  • Сообщений: 2
После очередных танцев с бубном вокруг звука (прошлый вариант с удалением alsa-plugins-pulse и pulseaudio-daemon не помог :)) вышел на следующую ситуацию:
всё установлено по умолчанию Альт 9.0 и обновлено через dist-upgrade.
Что в итоге: звука нет сразу. Устанавливаю pavucontrol иду в раздел Конфигурация:

там выставлено в разделе профиль: Выключено
Выбираю нужный профиль, хоть и пишет, что (не подключено)(недоступно), но фактически всё подключено


Начинает работать звук, но после перезагрузки всё сбивается и надо каждый раз заходить в Кофигурацию pavucontrol и выставлять там нужные параметры.
Поиск на просторах интернета привел к такому решению:
устанавливаем в Конфигурации рабочие параметры:
смотрим через $ pacmd list-cards и находим через какой конфиг звук работает (ищем строку в разделе с нужной картой которая начинается с active profile:).
в моём случае было так:
Спойлер

user@image ~ $ pacmd list-cards
3 card(s) available.
    index: 0
   name: <alsa_card.pci-0000_00_03.0>
   driver: <module-alsa-card.c>
   owner module: 6
   properties:
      alsa.card = "0"
      alsa.card_name = "HDA Intel HDMI"
      alsa.long_card_name = "HDA Intel HDMI at 0xf7d14000 irq 28"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:03.0"
      sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "0c0c"
      device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
      device.form_factor = "internal"
      device.string = "0"
      device.description = "Встроенное аудио"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   profiles:
      output:hdmi-stereo: Digital Stereo (HDMI) выход (priority 5900, available: no)
      output:hdmi-surround: Digital Surround 5.1 (HDMI) выход (priority 800, available: no)
      output:hdmi-surround71: Digital Surround 7.1 (HDMI) выход (priority 800, available: no)
      output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) выход (priority 5700, available: no)
      output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) выход (priority 600, available: no)
      output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) выход (priority 600, available: no)
      output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) выход (priority 5700, available: no)
      output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) выход (priority 600, available: no)
      output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) выход (priority 600, available: no)
      off: Выключено (priority 0, available: unknown)
   active profile: <off>
   ports:
      hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
      hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
      hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
    index: 1
   name: <alsa_card.usb-lihappe8_Corp._USB_2.0_Camera-02>
   driver: <module-alsa-card.c>
   owner module: 7
   properties:
      alsa.card = "2"
      alsa.card_name = "USB 2.0 Camera"
      alsa.long_card_name = "lihappe8 Corp. USB 2.0 Camera at usb-0000:00:14.0-8, high speed"
      alsa.driver_name = "snd_usb_audio"
      device.bus_path = "pci-0000:00:14.0-usb-0:8:1.2"
      sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.2/sound/card2"
      udev.id = "usb-lihappe8_Corp._USB_2.0_Camera-02"
      device.bus = "usb"
      device.vendor.id = "038f"
      device.vendor.name = "lihappe8 Corp."
      device.product.id = "0541"
      device.product.name = "USB 2.0 Camera"
      device.serial = "lihappe8_Corp._USB_2.0_Camera"
      device.form_factor = "webcam"
      device.string = "2"
      device.description = "USB 2.0 Camera"
      module-udev-detect.discovered = "1"
      device.icon_name = "camera-web-usb"
   profiles:
      input:analog-stereo: Аналоговый стерео вход (priority 65, available: unknown)
      input:iec958-stereo: Цифровой стерео (IEC958) вход (priority 55, available: unknown)
      off: Выключено (priority 0, available: unknown)
   active profile: <input:analog-stereo>
   sources:
      alsa_input.usb-lihappe8_Corp._USB_2.0_Camera-02.analog-stereo/#0: USB 2.0 Camera Аналоговый стерео
   ports:
      analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
         properties:
            device.icon_name = "audio-input-microphone"
      iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
         properties:
            
    index: 2
   name: <alsa_card.pci-0000_00_1b.0>
   driver: <module-alsa-card.c>
   owner module: 8
   properties:
      alsa.card = "1"
      alsa.card_name = "HDA Intel PCH"
      alsa.long_card_name = "HDA Intel PCH at 0xf7d10000 irq 29"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:1b.0"
      sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "8c20"
      device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
      device.form_factor = "internal"
      device.string = "1"
      device.description = "Встроенное аудио"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   profiles:
      input:analog-stereo: Аналоговый стерео вход (priority 65, available: no)
      output:analog-stereo: Аналоговый стерео выход (priority 6500, available: no)
      output:analog-stereo+input:analog-stereo: Аналоговый стерео дуплекс (priority 6565, available: no)
      off: Выключено (priority 0, available: unknown)
   active profile: <output:analog-stereo>
   sinks:
      alsa_output.pci-0000_00_1b.0.analog-stereo/#5: Встроенное аудио Аналоговый стерео
   sources:
      alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#6: Monitor of Встроенное аудио Аналоговый стерео
   ports:
      analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "audio-input-microphone"
      analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "audio-input-microphone"
      analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
         properties:
            
      analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
         properties:
            
      analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "audio-headphones"

Т.е. звук работает через звуковую карту 2 и профиль <output:analog-stereo>

Далее идём в /etc/pulse/default.pa и там добавляем в конец файла:
set-card-profile 2 output:analog-stereo, где 2 - номер рабочей карты, analog-stereo - рабочий профиль. Перезагружаемся и должно работать.

p.s. оригинал решения найден тут: https://www.mycomputertips.co.uk/213
« Последнее редактирование: 14.07.2022 13:07:00 от crimeagov »