Автор Тема: Не работает OpenGL renderer на Nvidia Quadro FX 1800  (Прочитано 559 раз)

Оффлайн Dron983

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Здравствуйте!
После обновления с p9 на p10 не работает OpenGL-графика.
Драйвер NVidia, по всей видимости, загружается:
# inxi -G
Graphics:
  Device-1: NVIDIA G94GL [Quadro FX 1800] driver: nvidia v: 340.108
  Display: server: X.Org 1.20.14 driver: loaded: nvidia
  resolution: 1280x1024~60Hz
  OpenGL: renderer: N/A v: N/A

# uname -r
5.10.136-std-def-alt1

Драйвер с сайта NVidia не компилируется и пишет, что неправильная конфигурация ядра.

Возможно ли решить проблему с графикой, не переустанавливая систему с нуля?

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
Да, поставить драйвер из репозитория. Правда это сработает, если у вас не сильно поломана система "ручной" установкой.

Оффлайн Dron983

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Сейчас стоит драйвер из репозитория (установился при обновлении ядра).
Драйвер с сайта NVidia не компилируется.

Оффлайн Dron983

  • Начинающий
  • *
  • Сообщений: 23
    • Email
Ошибка, которая выдаётся в лог при компиляции драйвера с NVidia:
   In file included from /tmp/.private/root/selfgz5390/NVIDIA-Linux-x86_64-340.108/kernel/nv.c:13:
   /tmp/.private/root/selfgz5390/NVIDIA-Linux-x86_64-340.108/kernel/nv-linux.h: At top level:
   /tmp/.private/root/selfgz5390/NVIDIA-Linux-x86_64-340.108/kernel/nv-linux.h:139:10: fatal error: linux/ioctl32.h: No such file or directory
     139 | #include <linux/ioctl32.h>          /* register_ioctl32_conversion()    */
         |          ^~~~~~~~~~~~~~~~~
   compilation terminated.

Оффлайн yaleks

  • Мастер
  • ***
  • Сообщений: 6 157
не надо ставить драйвер с сайта nvidia.
Вспомнил - у альтов большой косяк при обновлении с p9 на p10 - графика nvidia действительно отваливается. Надо удалить все пакеты nvidia (иначе никак) и ставить снова по инструкции на wiki.

Оффлайн zerg

  • ненужная строка
  • alt linux team
  • ***
  • Сообщений: 2 306
  • ненужная строка
    • Найдётся всё
После обновления с p9 на p10 не работает OpenGL-графика.
Удалите /etc/X11/xorg.conf и /etc/X11/xorg.conf.d/10-monitor.conf
Убрать этот мусор можно переключателем: Не показывать подписи других пользователей.

Оффлайн Dron983

  • Начинающий
  • *
  • Сообщений: 23
    • Email
После обновления с p9 на p10 не работает OpenGL-графика.
Удалите /etc/X11/xorg.conf и /etc/X11/xorg.conf.d/10-monitor.conf

Помогло.
Спасибо большое!