Автор Тема: [РЕШЕНО] P9 -> P10: конфликт пакетов wine-vanilla-common и libwine-vanilla  (Прочитано 1060 раз)

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Выполняю инструкцию по обновлению с Вики.
При исполнении apt-get dist-upgrade получаю массу ошибок по пакету wine-vanilla-common.

Вот одна из таких:
file /usr/share/wine/wine.inf from insall of wine-vanilla-common-1:7.14-alt1.noarch conflicts with file from package libwine-vanilla-5.20-alt1.x86_64

Жалобы есть и на другие пакеты из старого wine.

Попытка удаления с помощью apt-get remove libwine-vanilla приводят к предложению удалить еще пару тысяч пакетов.
apt-get -f install ничего не решает.

Попытка сделать апгрейд с помощью EPM (тоже по инструкции) дает абсолютно тот же результат.

Подозревая, что дело в ошибке в apt-get или rpm я обновил их отдельно командой apt-get install.
Версии изменились незначительно (но точно с переходом пакетов apt и rpm на P10). Но это частичное обновление тоже не помогло.

Как избавиться от этой болячки и продолжить обновление?

ПК я не выключаю. Процедуру выполняю в консоли по Alt+Ctrl+F2.
« Последнее редактирование: 03.09.2022 19:37:26 от kiav »

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 765
Как избавиться от этой болячки и продолжить обновление?
Для начала надо повесить баг соответствующий. Потом, наверное, через удаление wine и последующую установку будет проще, если не ждать исправления.

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Для начала надо повесить баг соответствующий.
Для бага потребуется вывод apt-get dist-upgrade. Я не знаю как его сохранить в файл и отвечать на запросы этой софтины.

Потом, наверное, через удаление wine и последующую установку будет проще, если не ждать исправления.
А нет в системе, по мнению apt-get, ни wine, ни wine-vanilla.

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Как я уже написал в Telegram, проблема решилась.
И для меня неожиданно.

У меня по wine были в системе вот эти пакеты:i586-libwine-vanilla-twain-5.20-alt1.i586
i586-libwine-vanilla-5.20-alt1.i586
i586-libwine-vanilla-gl-5.20-alt1.i586
i586-wine-vanilla-5.20-alt1.i586
libwine-vanilla-gl-5.20-alt1.x86_64
libwine-vanilla-twain-5.20-alt1.x86_64
libwine-vanilla-5.20-alt1.x86_64
wine-mono-5.1.1-alt1.noarch
wine-gecko-2.47.1-alt1.noarch

Мне удалось по одному, командой apt-get remove, удалить почти все. Остались только libwine-vanilla и i586-libwine-vanilla. Их удаление тем же способом было невозможно - apt-get предлагал удалить почти все пакеты в системе.

Но их наличие не помешало apt-get dist-upgrade продолжить работу.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 765
Для начала надо повесить баг соответствующий.
Для бага потребуется вывод apt-get dist-upgrade. Я не знаю как его сохранить в файл и отвечать на запросы этой софтины.
Как это!? Выделить мышкой, вставить средней кнопкой.
Потом, наверное, через удаление wine и последующую установку будет проще, если не ждать исправления.
А нет в системе, по мнению apt-get, ни wine, ни wine-vanilla.
Так написано "with file from package libwine-vanilla-5.20-alt1.x86_64", а не wine

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 765
Остались только libwine-vanilla и i586-libwine-vanilla. Их удаление тем же способом было невозможно - apt-get предлагал удалить почти все пакеты в системе.
Это тоже как-то странно выглядит. Точно команда была
apt-get remove libwine-vanilla i586-libwine-vanilla?

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Было отдельно:
apt-get remove libwine-vanilla
apt-get remove i586-libwine-vanilla

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Как это!? Выделить мышкой, вставить средней кнопкой.
:)

Ковыряюсь на бездыханном ПК (только терминал), где идет обновление и вылезая на форум с ноута у меня это не получилось.

Оффлайн asy

  • alt linux team
  • ***
  • Сообщений: 7 765
Было отдельно:
apt-get remove libwine-vanilla
apt-get remove i586-libwine-vanilla
Не принципиально. Не должно за libwine систему уносить.

Оффлайн predator2018

  • Давно тут
  • **
  • Сообщений: 89
Прошу прощения, как начинающий пользователь дистрибутива я мало что о нём знаю.
В Debian based дистрибутивах, даже если вы накосячили  можно скачать вручную альтернативные пакеты ( например более низкой или высокой версии ) при установке через утилиту dpkg они просто замещают установленные пакеты и система остаётся работать как и работала.
По идее и здесь долджны быть подобные инструменты.

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Не должно за libwine систему уносить.
Тоже так думаю. Но что было, то было.

Вот сейчас, послое перехода на P10 удаляются только они:# apt-get remove libwine-vanilla
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие пакеты будут УДАЛЕНЫ:
  i586-libwine-vanilla.32bit libwine-vanilla
0 будет обновлено, 0 новых установлено, 2 пакетов будет удалено и 0 не будет обновлено.
Необходимо получить 0B архивов.
После распаковки будет освобождено 425MB дискового пространства.
Продолжить? [Y/n] Y
Совершаем изменения...
Подготовка...                                           #################################################################################################### [100%]
Очистка / удаление...
1: i586-libwine-vanilla-5.20-alt1                       #################################################################################################### [ 50%]
2: libwine-vanilla-5.20-alt1                            #################################################################################################### [100%]
Завершено.

Оффлайн kiav

  • Завсегдатай
  • *
  • Сообщений: 502
  • Стич-спасатель
    • Email
Прошу прощения, как начинающий пользователь дистрибутива я мало что о нём знаю.
В Debian based дистрибутивах, даже если вы накосячили  можно скачать вручную альтернативные пакеты ( например более низкой или высокой версии ) при установке через утилиту dpkg они просто замещают установленные пакеты и система остаётся работать как и работала.
По идее и здесь долджны быть подобные инструменты.
В Альте предлагают два варианта. Совсем жесткий - downgrade (чтобы им не пользоваться, предлагают timeshift). Есть вариант помягче (частичный downgrade). В этом варианте прописываются репозитарии на определенную дату. В этом сценарии удаляешь ненужно и ставишь то, что было в репе на ту самую дату.
В моей ситуации timeshift не помог (он требовал хранилище на 5,7ТБ, а было у меня 5,5). Downgrade и определенная дата - тоже так себе. Можно было только продолжать.
« Последнее редактирование: 04.09.2022 18:58:53 от kiav »

Оффлайн Nicom

  • Давно тут
  • **
  • Сообщений: 179
    • Email
Ковыряюсь на бездыханном ПК (только терминал), где идет обновление и вылезая на форум с ноута у меня это не получилось.
Подключение по ssh из графической консоли никто не отменял.